Jump to content

Recommended Posts

Hello everyone, this is my first time on this forum and it's pretty interesting how thinghs work around.

To tell the truth I've never tried/experienced Hackintosh, so sorry for being noob.

 

This is my Laptop specs, it seems that the cpu and gpu are pretty close/same with the new Macbook Pro 2013
2.0 GHz (i7-4750HQ) quad-core Intel Core i7 Crystalwell with 6 MB on-chip L3 cache(15") + 

Nvidia GeForce GT 750M with 2 GB GDDR5 memory. (15", 2.3GHz)

 

Model: Asus n550JV - 15.6 inch Full HD (1920*1080)

Ram: 8 GB LDDR3 - 1600 Mhz (Kingston)

Cpu: Intel I7-4700HQ Haswell

Gpu: Nvidia Geforce GT 750m (4GB)

HD: 1 TB (5200 rpm) (yeah I know, slow like hell)

More detailed info see in attachment.

 

Update1:

I made a bootable usb with myHack 3.3 + changed kernel with custom one 

10.9 Ivy Bridge-E & Lapic Fix Kernel

(http://www.osx86.net/files/file/3606-109-ivy-bridge-e-lapic-fix-kernel/)

 

I have succeeded to boot in USB but unfortunately I got stuck at Pthread support aborts when sync kernel primitives misused 

 

Update2:

Made a new Bootable Usb using Clover together with the custom kernel + moded efi files. Installation started and succeeded.

BUT everytime I try to boot OS X, I keep rebooting after something like  "uuid loading ....................................................................++++++++++++++"

 

So could someone please help me? Is it because my Smbios is wrong? And if it is, what should I do to get a good working one?

 

UPDATE 3:

Succesfully booted in Mac Os X 10.9 ;D

- Wifi & bluetooth doesn't work. (bluetooth works rarely (20 % chance it works))

- Sound also doesn't work but it's fixable by moding with kexts etc. ( haven't connected with internet so is it possible that it will after connection 1* time?) (fixed sound)

- About, finder, configuration, wallpaper, live wallpaper, mounting all works perfectly.

- It's performing truth to be told butter smooth, and I booted with all cores (4). But it's working whole time on max speed (2.4 ghz) so that needs to be fixed or at least limited to +- 2 ghz so it would use less power & make less heat.

- Battery stats could not be seen (0% whole time) (fixed with patched kext)

- sleep doesn't work.

- shutdown, restart works :P

- Tried iMessage and App store, worked fine without internet (lol).

 

That's it, can't think or find another thingh to mention.

 

GUIDE for OS X 10.9 on Asus n550JV

(note this may not be detailed/complete enough to succeed):

- First make a usb stick with restore from OS X Mavericks (search google, it's almost same everywhere -_-)

 

- Then make a clover bootable stick using Clover v2: https://mega.co.nz/#!csACCYwI!Cx-GC02... guide:

 

- Follow everything in that youtube vid exactly, because it could turnout differently if you don't :)

 

- Use these modded EFI files and overwrite/merge with EFI partition of usb (credit goes to my russian friend amocc

 for his amazing work): 

https://docs.google.com/file/d/0BxmvHU43bIiQS3hTTHNFem1iVnc/edit?usp=sharing

amocc's profile: 

http://www.osx86.net/user/508444-amokk/

Another discussion on forum:

http://www.insanelymac.com/forum/topic/292368-laptop-reboots-after-root-device-uuid-is/page-3?do=findComment&comment=1959561

 

 

- Reboot system with usb plugged, check if USB LEGACY is on.

And get in bios/efi or whatever and change boot priority

for example UEFI: CLOVER boot should be the first one to boot.

 

- Clover bootloader will show up, go to Mac Os installer (or what it is called) and press space than go to without caches and press enter.

- Installer will show up, make a Mac Os Extended Journaled partition by going to Utilities than Disk Utility.

- Instal, REBOOT back to Installer (trust me).

 

IMPORTANT: Launch Terminal and give these command (change YOUR_Partition!):

cp /mach_kernel "/Volumes/YOUR_Partition/mach_kernel"

 

++++++++++++++++ THEN RENAME mach_kernel to mac_kernel  --> mv mach_kernel mac_kernel

++++++++++++++++OR goto your folder of EFI bootloader(EFI-> CLOVER -> Config.plist) and change

mac_kernel to mach_kernel

 

- Reboot into OS X (not installer) using without caches.

 

- After configuring your system with username, password you'll appear on desktop.

 

- Now you'll need to use different kexts to fix several issues:

For audio go to this link: 

http://www.projectosx.com/forum/index.php?showtopic=355

Use the latest one, I used VoodooHDA_v284.zip

Than you should edit info.plist in VoodooHDA.kekst

... 

___ Will continue guide...

ShortSysInfoAsusN550JV.txt

Link to post
Share on other sites
  • Replies 203
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Download this mach_kernel: http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=131161 - unpack, rename it to "mac_kernel" and put it to the root of y

My current dsdt is attached to the post. Display brightness control is working just right now, just be sure to use Clover's EmuVariableUefi-64.efi driver (better install it with the newest Clover). D

Here we go ... good new year! CLOVER.zip

Posted Images

  • Administrators

It should be, just try it out with a myHack USB installer configured with the Generic bootpack. Report back afterwards.

 

One thing to be aware of: that Atheros AR9485-based Qualcomm wireless card remains unsupported under Mac OS X as far as I know so you'll probably have to replace it by a compatible model. I understand the PCI ids of that AR9485 are 168c-0032.

Link to post
Share on other sites

 

UPDATE 3:

Succesfully booted in Mac Os X 10.9 ;D

- Wifi & probably bluetooth doesn't work.

- Sound also doesn't work but it's fixable by moding with kexts etc. ( haven't connected with internet so is it possible that it will after connection 1* time?)

- About, finder, configuration, wallpaper, live wallpaper, mounting all works perfectly.

- It's performing truth to be told butter smooth, and I booted with all cores (4). But it's working whole time on max speed (2.4 ghz) so that needs to be fixed or at least limited to +- 2 ghz so it would use less power & make less heat.

- Battery stats could not be seen (0% whole time)

- sleep doesn't work.

- shutdown, restart works :P

- Tried iMessage and App store, worked fine without internet (lol).

 

That's it, can't think or find another thingh to mention.

 

 

Hi,

 

I'm new with hackintosh. I also have an ASUS N550JV (cn222h version). I replaced the wifi card with an Intel ® 6235AN.HMWWBand the HDD with a an SSD Samsung 840 PRO :)

 

Can you explain to me the few steps to make 10.9 working on your PC ?

What is the goal of your *.txt file ?

 

Edit : I don't want to install in EFI mode, my HDD is dos partitionned (I didn't manage to install Archlinux, Ubuntu and Win8 toegether in UEFI mode, too noob lol)

Link to post
Share on other sites

Hi, I have an N550JV too and I've installed 10.9 :-)

All work except Wifi, sleep, battery, nvidia card, imessage & facetime auth :-(

 

Wifi : no support I think we need replace but there is maybe a WLAN Whitelist in BIOS

 

Bluetooth : seems working OOB but not detecting any devices -> if someone has a solution tell me :-)

 

Sleep : we can fix this with DSDT edit 

 

Battery : VoodooBattery doesn't work -> we can fix this with DSDT edit or maybe patched AppleSmartBatteryManager.kext

 

Nvidia Card : even if MacBook Pro can use it, nobody never success enable it on a hackintosh, so for now we can just try to turn off it -> DSDT edit 

 

Fn Hotkeys : works for Volume and for Brightness but brightness is not modified. And keyboard backlight keys don't work

 

Sound : work with VoodooHDA but it's not perfect so the best is DSDT edit + patched AppleHDA.kext

 

 

So right now we have to clean our DSDT because this will allow us to get working several things.

I began with macIASL but the stock DSDT (BIOS 207, last version from asus) already contains 8 errors.

Some errors are simple like a lack of " " but some other are more complicated :-(

I don't have good known in DSDT edit but I hope we can learn together :-)

 

A last thing : I've found the Nvidia Optimus Table in the last SSDT table ; the method "_OFF" will be useful to  turn off the card at boot but before we need a clean DSDT.

Maybe we can have help from the linux community because some things like Brightness key doesn't work even on linux (buggy DSDT).

 

Good luck to everyone and please share any news ! :-)

 

PS : Clover applys mask on the DSDT so extract your tables on Windows or Linux 

Link to post
Share on other sites

I followed this guide several times but i didin't managed to install OS X 10.9

The installation doesn't work in Clover menu.

 

My disk is not GUID partition but MS-DOS cause i didn't manage to install Archlinux, Ubuntu and Win8 in UEFI on my disk so i formatted in MS-DOS.

 

What can I do ? I tried disabling "Launch CSM" in the BIOS, changing the UEFI options in Clover, set my partitions on my USB stick with a ms-dos table, ....

 

Nothing is working.

 

Does anyone can help me ?

 

(N550JV also)

Link to post
Share on other sites

Hi all,

I gonna try to clarify several things. Primo, my UEFI-GUID Clover config (EFI directory) is only for UEFI boot. So, Gons, I cannot help you with MBR-partitioned HDD. You may try to install Clover in legacy mode though (with boot sectors), and use some drivers from my EFI package to make your system/installator boot. In your case the "Lauch CSM" option should be enabled in BIOS, USB stick should have ms-dos table partitions set.

Secundo, Battery now works w/o DSDT edit but with VoodooBattery.kext.

Tertio, WiFi won't work AFAIK. It should be replaced with another device (leads to warranty voidance however). Also you may try some USB wifi devices.

PS: I'd love to see someone's made a good DSDT.aml 'cause personally I hate editing, bugfixing and compiling it.

 

Tip: In order to boot directly from HDD do the following:

1) mount System (disk0s1 AFAIR) with Disk utility

2) goto System's "Boot" directory & copy your "Clover" directory from USB stick here

3) reboot to BIOS and create new boot option (choose Clover/cloverx64.efi). make it first one in the list

4) profit

Link to post
Share on other sites
Hi,

 

I used diskmaker x to create a pendrive with mavericks,so I created another pendrive with BootDiskUtility with windows and I  overwrite the efi files,but when I try to start the installer from clover,the screen has flash and the pc return to clover within 1 second

 

What can I do?

 

EDIT:

 

Now I have "error loading kernelcache (0xf)" or "could not open file mac_kernel,error loading  kernel mac_kernel (0xe)

 

What can I do now?

Link to post
Share on other sites

×
×
  • Create New...