Jump to content

Yosemite (Final) on E5540 I5-4310U (Haswell) using Clover


Recommended Posts


I've been desperately trying in vain, to get Yosemite to install on my Dell E5540.

My Specs:

Dell E5540 with I5-4310U @2GHz

Intel HD4400 with Nvidia Gforce GT720M
Intel Ethernet I218-LM Network Card
(I've disabled the un-suported Intel WIFI)
AHCI is Enabled for SATA

I've followed the below guide to no avail (along with other guides in the forums)


Not once have I been able to get to the Installation screen.

Could someone please enlighten me as to what I'm doing wrong... (With Mavericks I tried the patched Mach_Kernel for 10.9.4 which also resulted in a continuous boot loop)

I've attached my EFI Folder along with the modified DSDT.aml file.

All Im looking to do, is to get LAN / Sound & Video working on Yosemite.



Link to comment
Share on other sites

i updated a few files and your config. i did not touch your acpi folder.


You sir, you are a genius! I'm not commenting a lot on all forums but your zip package worked instantly without any modifications on my Latitude E5540 without GTX graphics card. I never got any version (DP, Beta, GM or even the Final) of Yosemite to get into the installer. THANKS A LOT!!!!

Link to comment
Share on other sites

@ Bronxtech
Thank you for your help, however I'm unfortunately not as lucky as makzinations.
Mine is still ending in a reboot loop.
I added the -v option behind the ones already set and took a photo where it reboots.
I set the Bios to defaults (except for SATA which is set to AHCI and VT-d is disabled)

The screenshot is attached... Am I missing something?


Link to comment
Share on other sites

@ Bronxteck

That did the trick! Thank you so much for all your help! =)
I've attached my working EFI folder for anyone else who would like it!

I now just need to figure out how to get sound & VGA display out working and I'll be a happy man!

Sound is now working using VoodooHDA-v2.8.6 installer pkg, however no sound out through headphone jack (anybody know how to fix this?)
No VGA output yet though... anyone know of a edited kext for HD4400 to allow display to a 2nd monitor?


Link to comment
Share on other sites

  • Create New...