Jump to content

Yosemite on Latitude E5520 with Clover


Recommended Posts

I am glad to introduce my successful bootpack for a Latitude E5520 8-)

Could be used for E5420 too.


My configuration :

dell Latitude E5520 i3-2310M 2.1GHz, 4Gb

Graphics HD3000

LCD 1920x1080


Not working :

SDcard (not event tested)

boot UEFI (buggy Dell firmware)


Working :

boot UEFI

Everything else: display, VGA and HDMI/sound outputs, HDA sound, buttons, trackpad, multitouch, sleep, battery monitor, speedstep,...

Wifi (OOB using a replacement DW1510 / BCM94322HM8L)


Use any retail/clover installation guide.

Install Clover on the disk and copy the EFI from this kit (merging mode).

Upgrade to 10.10.x with combo update.

Copy the few kexts from EFI/CLOVER/OEM/Latitude E5520/kexts/Others/ to /S/L/E/ as usual.


Custom EDID and slide=0 options added to Clover's config.plist to get rid of the HD3000 artifacts.


Thanks to this forum and many contributors here and there.

Good hack ;-)




Edit: guess what ?

I could add entries for UEFI boot with an EFI partition formatted with FAT16 ! Incredible, the last Dell firmware do not recognise FAT32 !

You need to reformat the EFI partition : sudo newfs_msdos -v EFI -F 16 /dev/rdiskXs1

Reboot OSX, mount EFI , copy EFI folder into. Reboot again and hit F2 to enter bios setup. Add an entry into UEFI boot menu (name OSX or anything, path to EFI/BOOT/BOOTX64.EFI.


Edit2: remaining minor issues.

No logo and no verbose log on screen during UEFI boot. I use CustomLogo option in config.plist as a workaround.

No variables from NVRAM after UEFI reboot. EmuVariablesUefi-64.efi does not work (crash on boot).

No way to deactivate Bluetooth (grey biutton) The known patch to inject DW375 device (413c:8187/16700:33159) in a plugin in IOBluetoothFamily.kext doesn't correct the problem.

No functionnal MIC (internal or jack). Works once but not after unplug/plug (use VoodooHDA to solve the pb).


Edit3: Adding OsxAptioFixDrv-64.efi in Drivers64UEFI solved many issues.

No more artifacts/glitches, no CustomEDID needed, no slide=0 param, Apple boot logo OK.

NVRAM is now persistent. I can use "sudo nvram Clover.MountEFI=yes" to automount EFI ;-)

The above uploaded archive is modified.

Link to comment
Share on other sites

Hi !


It's been so much time that I was waiting for someone that would work on this Latitude model !


It seems to work quite well my side (I have an i3 2.19Ghz).


Only things that seems not to work here is Wifi (Atheros 9285) and Audio. I'm not very experienced in hackintosh engineering :P I've learned it all browsing forums.


Find attached kexts that are actually working using Chameleon boot loader. It seems that they aren't loading using Clover (r0394 UEFI install)

working kexts e5520 audio and wifi.zip


Find also a custom DSDT that was made for me some time ago + SSDT files (it was OS X Lion this time)

custom dsdt ssdt SMBios.zip


I have Windows 8.1 already installed and my filesystem is GPT.


I wasn't able to boot Clover before. I was working on it to get closer to an iMessage fix.


Thank you for your help / advices !





I've sorted it out.


AR 9285 Wifi (Atheros) = OK

Touchpad = OK

Audio = OK (Internal mic OK) I had to modify VoodooHDA.kext plist to fix Mute button, Level control... Alright now !

SDCard = Not tested Tested : could be better, have some read errors sometimes on some SD Card... Using VoodooSDHC.kext (see below)

Webcam = Quite OK, very pixelised in Facetime preview at start, but OK during a call, seems stable.

Ethernet = seems OK not tested

Graphics = OK no glitch so far

Firewire = Not tested (Disabled in BIOS because of previous stability issue with ML). Kernel panic : booting OK but kernel panic when logged in. Workaround : wait for detection prior login (mourse cursor will hang for 15-20sec on login screen) then login and it seems OK. I've disabled it in the BIOS (A14).

SSD (Samsung 840 EVO 500GB) = transfer rate seems OK, TRIM enabled

Logo splash screen works OK with progress bar

Bluetooth : not tested  Tested OK (tethering iPhone thru bluetooth without any problem)

NVRAM = not tested (not learnt yet actually...)  NVRAM is persistant OK

My BIOS A14 is not having problem with the ESD which is FAT32 (prior formated with Windows which was installed first)


I've tweaked config.plist and found the right drivers.


Here are all my Kexts (Jan 3rd 2015) : working_kexts_e5520_with_atheros_wifi.zip


I hope it may help.


Will give feedback if anything new.





Link to comment
Share on other sites


thanks K8L,

I could compare your CLOVER folder with mine. The obvious difference was the missing OsxAptioFixDrv-64.efi in Drivers64UEFI.

The graphics and nvram problems disappeared with this AptioFix driver.

The E5520 is an almost perfect hack now 8-)


I also added VoodooHDA to avoid the MIC issues with the patched AppleHDA.

Link to comment
Share on other sites

Hi !


I could make iMessage, iCloud and Facetime work using these guides :






Everything works except Firewire which make randomly crash the Latitude.


See ya,



Link to comment
Share on other sites

First of all many thanks for this excelent guide :D


I'm a little confuse if i use the @filbip or the @kahuitel files :(


I've build my Yosemite USB setup using clover with this guide, but what config.plist i use? any generic or the one from the first post?


If use @kahuitel files i don't need to buy a new WiFi card?


thank you

Link to comment
Share on other sites

  • Moderators

Files from either should work, but seems kahuitel's might be a bit more updated.

No, you will have to replace the Wifi with a supported device. Kahuitel uses an atheros but didn't mention which model.

filbip mentioned a DW1510 which works out of the box, not kexts needed.

Link to comment
Share on other sites

I confirm. Thank you Jake Lo.


A new tip about Bluetooth :

In BIOS, you can choose which interfaces (BT/Wifi/GSM) the external switch can activate/deactivate.

I choosed to start/stop only BT with this external button.

Now I activate/deactivate wifi only from OSX and I activate/deactivate BT with this external switch.


Link to comment
Share on other sites

As I wrote above, I tried to patch with no success... In fact, BT is useless for me ;-)


No way to deactivate Bluetooth (grey biutton) The known patch to inject DW375 device (413c:8187/16700:33159) in a plugin in IOBluetoothFamily.kext doesn't correct the problem.


Link to comment
Share on other sites

  • Create New...