Jump to content
Mariusz

DSDT for D630/D830/D530

Recommended Posts

WARNING: This dsdt is far from perfect and not finished

This is for Dell Latitude D630 X3100 1280x800 modell with Dell 1395 WiFi, D530 X3100 1400x1050 and D830 (both nVidia and X3100)

What you get here is dsdt.aml file with my workshop /Extra folder for this specific model.

Start by setting your bios to default and change to AHCI mode - that's it for now.

Install Chameleon v2.0-RC5 r700

Copy /Extra folder to your disk root

VoodooHDA.kext and AppleBCM5751Ethernet.kext are meant to run in /System/Library/Extensions

Download attached dsdt.aml file for your model and copy it to /Extra/

 

DSDT:

- dsdt is based on fresh A09 dump.

- Minimal X3100 graphic injection

- some other fixes

- Screen brightness and sleep by lid

- Sleep works without bios password

 

D630:

- X3100 injection for 1280x800

- Dell 1395 WiFi injection

 

D830:

- X3100 injection (for GMA)

- Dell 1395 WiFi injection

 

D530:

-X3100 injection for 1400x1050

 

All You D630/D530 Intel X3100 users do test this out and report here, thanks.

dsdt_D530_x3100.aml.zip

dsdt_D630_X3100_1280x800.aml.zip

D630_D530_X3100_Pack.zip

dsdt_D830_nVidia.aml.zip

dsdt_D830_X3100.aml.zip

dsdt_D830_X3100_1280x800.aml.zip

  • Like 1

Share this post


Link to post
Share on other sites

So far, this is the issues that i have found:

 

1. Classic irq usb issue

 

2. CPU is identified as 1,8ghz - where is it should be a 2ghz

 

3. Memory is identified as 604mhz, where it should be 800mhz

 

4. I see alot of these errors in console "dyld: shared cached file was build against a different libSystem.dylib, ignoring cache"

  • Like 1

Share this post


Link to post
Share on other sites

Ummm... Mariusz you forgot to post the file Chameleon v2.0-RC5 r700...

Right, thanks.

It is included in D630_D530_X3100_Pack.zip from now on. (Post updated)

Share this post


Link to post
Share on other sites

Mariusz

Latest BIOS for D630 is A017

Please find enclosed zipped dmg with freedos and the D630_A17.exe file for upgrading

Put it on a 1GB USB stick and lets hope the boot sector works

Otherwise theres allways unetbootin

Anders

Yes I know. I just wanted to experiment on older dsdt to see how its performing and make an update to see if the changes are actually doing something if anything at all. How is the dsdt file performing on Your D630?

Share this post


Link to post
Share on other sites

Hi

Just tested your files and instructions exactly on a sister machine to the one you've got.

BIOS A17 latest

Question: Should i have touched /S/L/E ? (the com.apple.kext.caches dated summer.)

Question: How to evaluate dsdt ?

 

BIOS reset and AHCI set

Booted without switches

 

Not lots of worriesome rows in bdmesg, kernel and system log

 

Saw followning problems

External VGA not found but no KP or lined unusable display either

Mic dead

USB connector 3 and 4 dead

No touchpad settings panel

 

The rest worked fine

Sound out loudspeakers and plug

Firewire disk

Ethernet

WiFi

Modem port seen in network settings

Touchpad

Pointer

External mouse

Battery and ext power symbols

Sleep both powerbutton and lid closing

AFP disk

CPU 1,81 GHz bus 724 MHz 2 cores

Graphics 1280x800 works fine

CD reader

Video and sound good

USB memory pin

KB

Thanks Nice work

Anders

Share this post


Link to post
Share on other sites

About USB no 3 and 4

Maybe this below would help you Mariusz

Two extra interupt flags

 

Found here http://byteco.de/200...-1/#comment-594

 

Anders

In my previous post I forget to write how to get all the 4 USB port working.

 

Thanks goes to: http://www.insanelym...howtopic=206313

 

Search for HPET section and change things as following:

 

Device (HPET)

{

Name (_HID, EisaId (“PNP0103″))

Name (ATT3, ResourceTemplate ()

{

IRQNoFlags ()

{2}

IRQNoFlags ()

{8}

IRQNoFlags ()

{11}

IRQNoFlags ()

{15}

Memory32Fixed (ReadWrite,

0xFED00000, // Address Base

0×00000400, // Address Length

)

})

 

Recompile and repair permission with Kext Utility.

 

Now your USB port are working as ever!!!!

Share this post


Link to post
Share on other sites

All is not well

Sometimes after first sleep the pointer doesnt follow the mouse/touchpad and its like someone pushes lots of "7" on the keyboard.

Strange is that it only happens in Finder. If i start some program I have no probem in its menus but if I once again selects Finder

the pointer once again doesnt follow mouse fully. Pointer moves upward.

 

I have seen this in other combinations like the one Mario (Bronxteck) put up a few days ago.

 

I put your files incl Cham r700 on my installation stick with installation image of SN 10.6.0 (my comments 10.57 PM friday was with 10.6.6)

and booted it. All ok except had to use external mouse (stick and touchpad dead).

Would be useful to fix.

 

Anders

Share this post


Link to post
Share on other sites

I have forgot to add that this dsdt is far from perfect and not finished :) (I guess I'll update the post now)

Yes I know the USB EHCI problem - I'm just not a big fan assigning resources in HPET and right now I'm experimenting to find out more elegant solution. I always start with no IRQ's in HPET. The CMOS reset is another thing related to that.

Proper cpu and ram detection can be defined in smbios.plist or by using better boot loader (like latest Slice branch - detects all just fine)

To have external display you must force display detection (and force detect when cable is disconnected).

Resume from sleep trigers the strange 777777 until you press any key to stop it.

VoodooHDA needs to be restarted after resume from sleep to have a working mic. Strange the mic is not working for you at all? -double check that.

Also do check if the modem you see in Network is not the Serial port - cause this is another anomaly :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...