Jump to content

Latitude E6510 El Capitan


griftopia
 Share

Recommended Posts

Managed to lay my hands on one. I'm collecting the parts and might have to dismantle whole thing to put Bluetooth card seems like. However, that can wait.

 

Had some startup questions.

 

- Can I use Enoch? (I'm seriously Clover challenged, but this has UEFI)

- Anyone has DSDT I can use for this model?

- Should I update the BIOS to A16? (have A14 now)

 

Specs

RAM 4GB (will get 4 more GB)

CPU i5 M520 2.4 Ghz

GPU Nvidia NVS 3100M (1920 x 1080)

Wifi DW 1510 (I replaced the stock N 3600)

Link to comment
Share on other sites

  • Replies 25
  • Created
  • Last Reply

Top Posters In This Topic

  • Administrators

Of course you can use Enoch.

You'll find copies of DSDT in most E6410/E6510-related threads on the forum; just use the search facility.

You may update BIOS but check if it's worth it on Dell's web site (on older systems, latest BIOS often only brought enhanced password encryption)

Link to comment
Share on other sites

Hah! Didn't know I can use e6410 DSDT for e6510 ?!?!?!?! I am guessing I will need to use DSDT with the Nvidia card though. I know some of this series laptops come with Intel Graphics.
 
Will give this a shot before bothering with Clover or bother with BIOS update.
 
*EDIT*
So I searched and took DSDT from post that said "it worked!". Slammed it into my trusted El Capitan usb stick. Lo and Behold, booted straight into language selection and then Disk Utility.
 
Now the wierdest thing. Disk Utility cannot see my hard drive ?!?!?!? It is there in the BIOS. Why? I have attached DSDT I used.

DSDT.aml.zip

Link to comment
Share on other sites

  • Administrators

Yes, it goes without saying, re-use the DSDT of a model of identical specs (the nVidia model in your case). Afaik, E6510 only differs from E6410 by screen size.

 

For your HDD, make sure you've set SATA operation mode to AHCI in the BIOS settings.

Link to comment
Share on other sites

Okay my problem was I was in "UEFI" mode. I thought this was right. I switched to "Legacy" mode. Problem is with "UEFI" mode I don't see any items in the boot list (while I dunno how it booted my USB stick). With "Legacy" mode I see all my drives in my boot list. Now in "UEFI" I do see buttons to Add/Remove/View boot options ?!?! When I try to add, I see list of two items that are cryptic. I thought they were my USB and hard drive and tried to add them. No dice - computer refuses to boot.
 
So "UEFI" mode with nothing visible in boot list - Diskutility cannot see HD.
 
So I'm using "Legacy" mode now and can see the HD. However, not sure if this is correct. If you can please confirm Enoch needs "Legacy" and this is okay? As I'm typing, El Cap is installing on my HD.
 
PS - The trackpad is very sluggish. Sometimes will not respond at all. Little painful, but does not seem like hardware issue. Just informing, in case there is something missing there...

Link to comment
Share on other sites

Thanks for confirming. And I hope using legacy is not a serious drawback. I really hate Clover - too unpredictable for me and not to mention have not had much luck. Enoch on the other hand I can kiss.
 
So I have El Capitan installed now and will try to work through issues.
 
1) Ethernet Works with AppleIntel1000e
2) Wifi Works, BUT on boot up tries to connect then will not until I turn it OFF/ON. Tested many times. I don't have to enter password again so it does retain it, only won't automatically connect after boot.
3) Shutdown Works
4) Restart Works
5) Sound with VoodooHDA 2.8.2 already in /S/L/E and Fix applied.
6) Sleep DOES NOT Work. This sucks most intensely. 
7) USB Ports ALL Work!!!
8) Trackpad the longer I leave it on, the more flaky it is. Taking me 2 minutes to move mouse to Submit button on this post!
 
Attaching my DSDT, kexts and plists. Incidentally based on my search smbios for MacBook Pro 6.2 is appropriate, so I hope I'm right. Thanks in advance for any help.

e6510_NVidia.zip

Link to comment
Share on other sites

Made some progress.

 

First found out that if I have laptop battery then Wifi does not have issue connecting after reboot. Not sure why, but I can hardly complain.

Second found that the trackpad RHS does not work well, the LHS does. In Windows there is no issue. One of those things...

 

The only real issue I have right now is Sleep. Is there a DSDT patch or kext I'm missing?

Link to comment
Share on other sites

I tried what you said. Default was 3, changed it to 0. Didn't make any difference. I cannot resume. This is a real bummer. I got this real checap - was so excited  :-(
 
Is it one of those things that might get fixed in future, or are we saying resume after sleep will never work?
 
Also I have one more issue now. I got DVD RW drive for the laptop. I popped in a  CD and it mounted, which tells me the drive is working fine. However just to double QE/CI I launched DVD player and it gives me error "DVD Drive cannot be found". Is this because I installed without DVD drive in place? Do I have to reinstall the OS? The problem is that Help menu does not have "Show supported features" menu item for me to check and also as soon as I dismiss the initialization error box, DVD player exits.

Link to comment
Share on other sites

 Share


×
×
  • Create New...