Jump to content

[solved] E5420 i5 SandyBridge El Capitan problem booting into installer


ndog
 Share

Recommended Posts

I have followed the guide to create USB stick installer and am having the same issue as this users post

(Unless I didn't follow the clover setup guide properly, but I tried various options and I think its right.)

 

I had to enable asuspm patch in clover, but now am getting the fuzzy screen with crossed-circle icon.

 

​Apparently I have to disable USB 3.0, however there is no way to do that on this model. There is an option to disable external USB but this then disables all USB ports. I have checked various setting in the BIOS and tried eSata/USB combo port and other USB ports, but same result. Does this mean I should use a USB 2.0 stick instead or is there another trick?

 

Link to comment
Share on other sites

  • Replies 24
  • Created
  • Last Reply

Top Posters In This Topic

Hmm I think I made a mistake and wasn't doing the clover preparation step properly. I did these steps the second time around

Install Clover to EFI partition as per E5420 legacy instructions.

Delete the EFI folder

Copy the downloaded EFI_Clover there and rename to EFI

extract E5420.zip and move that to /EFI/Clover

 

Now I have another issue where the computer reboots. I have set DIMM to slot A

This is the screenshot right before it reboots (sorry about broken screen, i will replace next week)

 

Optimized_IMG_4886.jpg

Link to comment
Share on other sites

Thanks Jake. I replaced the kext and booted without caches however it is still rebooting with the same error message as above.

For good measure I attempted to use a random VoodooPS2Controller.kext from the internet and it rebooted after this line 

Waiting on <dict ID="0"><key>IOProvider</key><string ID="1">IOResources</string></key><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>

Any advice next?

Link to comment
Share on other sites

  • Moderators

Rehabman's ps2controller is for Synaptics, not for Alps. Although it won't cause any issue, you won't have touchpad scrolling feature.

I would just remove that kext and replace with the one I linked. Looking at your second post, the KP is like to wireless kext. Try removing your wireless card temporarily.

By the way, what wireless card does it have?

Link to comment
Share on other sites

Thanks for help so far.

 

I removed the wireless card. According to Hardware ID it is Dell Wireless 1530

I'm certain it is the factory stock and if i get El Capitan working I will definitely replace it.

 

I tried also using chameleon boot loader incase that made any difference, using the same kexts but it pretty much the same error message. It appears that before the kernel panic kicks in there is an error message about IO80211Controller. Very bad screenshot sorry.

 

This error persists even removing the wireless card.

 

IMG_4898.jpg

Link to comment
Share on other sites

Solved - I have a script to automate the USB pen with the steps.

 

Watch in action here

 

After installed must perform an initial boot from HDD using -x (safe boot)

After first time GUI load this step is no longer required

 

create-USB-installer.sh

#!/bin/bash

## E5420 SandyBridge i5 2520M Intel HD Graphics
## Dell E5420, A05, Samsung DDR3 4GB PC3-10700, EVO 850 SSD, 14" 1366 x 768
## Tested and working with OSX 10.11.5 installer @ 18 June 2016

## using BaseBinaries clone method from RehabMans guide

# OS X latitude way
## https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-el-capitan-clover-guide/#entry54632
## https://osxlatitude.com/index.php?/topic/9095-e5420-i5-sandybridge-el-capitan-problem-booting-into-installer

# Authors note
## If you are modifying this script I recommend to use TextWrangler to get proper syntax highlighting


# Downloads

# OSX App Store
distro="/Volumes/1800GB/~Development/OS/Mac/MAC OS X 10.11 - El Capitan/Install OS X El Capitan 10.11.5.app"

# https://sourceforge.net/projects/cloverefiboot (chameleon, stolen and rebranded)/
clover="/Volumes/1800GB/~USB/install/OSX/Hackintosh/clover/Clover_v2.3k_r3599.pkg"

# https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-el-capitan-clover-guide/#entry54632
EFIbase="/Volumes/1800GB/~USB/install/OSX/Hackintosh/zInstructions/E5420/EFI Stuff/EFI_Clover.zip"
customEFI="/Volume s/1800GB/~USB/install/OSX/Hackintosh/zInstructions/E5420/EFI Stuff/E5420.zip"




formatUSB() {
    local device=$1
    # repartition /dev/disk1 GPT, one partition
    # EFI will be created automatically
    # second partition, "install_osx", HFS+J, remainder
    diskutil partitionDisk $device 1 GPT HFS+J "install_osx" R
    }


BaseBinariesclone() {
    # unlock su
    sudo echo
    
    # temporary directory
    mkdir /tmp/install_esd
    
    # mount InstallESD.dmg in installer package
    ## hdiutil attach "/Applications/Install OS X El Capitan.app/Contents/SharedSupport/InstallESD.dmg" -readonly -mountpoint /tmp/install_esd -nobrowse
    if [[ -d "$distro" ]]; then
        hdiutil attach "$distro""/Contents/SharedSupport/InstallESD.dmg" -readonly -mountpoint /tmp/install_esd -nobrowse
    else
        echo "Directory $distro does not exist."
        return 1
    fi  
    
    # restore it to target
    sudo asr restore -source /tmp/install_esd/BaseSystem.dmg  -target /Volumes/install_osx -erase -format HFS+ -noprompt
    
    # rename the target to be less unwieldy
    diskutil rename "OS X Base System" install_osx
    
    # remove Packages symlink
    rm /Volumes/install_osx/System/Installation/Packages
    
    # copy Packages as folder
    rsync -ah --progress /tmp/install_esd/Packages /Volumes/install_osx/System/Installation
    
    # copy BaseSystem.dmg
    rsync -ah --progress /tmp/install_esd/BaseSystem.dmg /Volumes/install_osx
    rsync -ah --progress /tmp/install_esd/BaseSystem.chunklist /Volumes/install_osx
    
    # unmount InstallESD.dmg
    hdiutil detach /tmp/install_esd
    
    # remove temporary directory
    rmdir /tmp/install_esd
    }


installClover() {
    # Install Clover
    echo "Install Clover to install_osx"
    echo "Install Clover in the ESP, Bootloader > Install boot0af in MBR, CloverEFI > CloverEFI 64-bits SATA"
    #rm -rf /Volumes/ESP
    if [[ -f $clover ]]; then
        sudo open -W "$clover"
    else
        echo "File $clover does not exist."
        return 1
    fi
    }


customEFI() {
    # check files exist
    if [[ ! -f $EFIbase ]]; then
        echo "File $EFIbase does not exist."
        return 1
    fi
    if [[ ! -f $customEFI ]]; then
        echo "File $customEFI does not exist."
        return 1
    fi

    # remove default EFI folder after installing boot loader
    rm -rf /Volumes/ESP/EFI

    # overwrite EFI folder (post boot loader install)
    ditto -V -x -k --sequesterRsrc --rsrc "$EFIbase" /Volumes/ESP
    
    # rename folder correctly
    mv /Volumes/ESP/EFI_Clover /Volumes/ESP/EFI

    # update custom EFI for this model
    ditto -V -x -k --sequesterRsrc --rsrc "$customEFI" /Volumes/ESP/EFI
    
    # rename folder correctly
    mv /Volumes/ESP/EFI/E5420/* /Volumes/ESP/EFI/CLOVER
    rm -rf /Volumes/ESP/EFI/E5420
    }


customUSB() {
    # custom files
    customDSDT="/Volumes/1800GB/~USB/install/OSX/Hackintosh/zInstructions/E5420/EFI Stuff/DSDT.aml.zip"
    MBRpatch="/Volumes/1800GB/~USB/install/OSX/Hackintosh/MBR/osx_10.11.5_MBR_patch.tar"
    # custom directories
    customKext1="/Volumes/1800GB/~USB/install/OSX/Hackintosh/zInstructions/E5420/kexts/BCM5722D.kext"
    
    # check files exist
    if [[ ! -f $customDSDT ]]; then
        echo "File $customDSDT does not exist."
        return 1
    fi
    if [[ ! -f $MBRpatch ]]; then
        echo "File $MBRpatch does not exist."
        return 1
    fi
    # check directories exist
    if [[ ! -d $customKext1 ]]; then
        echo "Directory $customKext1 does not exist."
        return 1
    fi

    # remove Intel graphics kexts - only for first generation Intel HD problems - doesn’t work
    ## rm -r /Volumes/install_osx/System/Library/Extensions/AppleIntelSNB*
    ## rm -r /Volumes/install_osx/System/Library/Extensions/AppleIntelHD*
    ## rm -r /Volumes/install_osx/System/Library/Extensions/AppleIntelFrame*

    # reboots at VoodooPS2Touchpad Version 1.9.0 loaded… or com.apple.AppleFSCompressionTypeDatale

    # overwrite kexts with forum suggested ones

    # https://osxlatitude.com/index.php?app=core&module=attach&section=attach&attach_id=10692
    # reboots - VoodooPS2TouchPad(Base) Version 1.8.3 loaded…
    ## rsync -ah --progress /Volumes/930GB/\~USB/install/OSX/Hackintosh/zInstructions/E5420/kexts/VoodooPS2Controller.kext /Volumes/ESP/EFI/CLOVER/kexts/Other/.

    # https://osxlatitude.com/index.php?/topic/9109-mac-os-1012-dp1-voodoops2controller-error/#entry61061
    # reboots - Waiting on <dict ID="0"><key>IOProviderClass
    # rm -rf /Volumes/ESP/EFI/CLOVER/kexts/Other/VoodooPS2Controller.kext
    ## rsync -ah --progress /Volumes/930GB/\~USB/install/OSX/Hackintosh/zInstructions/E5420/kexts/ApplePS2Controller.kext /Volumes/ESP/EFI/CLOVER/kexts/Other/.

    # overwrite DSDT
    # custom DSDT made by JakeLo - required to boot into installer
    # https://osxlatitude.com/index.php?/topic/9095-e5420-i5-sandybridge-el-capitan-problem-booting-into-installer/page-2#entry61109
    rm -rf /Volumes/ESP/EFI/CLOVER/ACPI/patched/DSDT.aml
    ditto -V -x -k --sequesterRsrc --rsrc "$customDSDT" /Volumes/ESP/EFI/CLOVER/ACPI/patched

    # allow installation on MBR disk
    # http://www.insanelymac.com/forum/files/file/426-el-capitan-mbr-patch
    # cd /Volumes/930GB/~USB/install/OSX/Hackintosh/MBR
    tar zxvf "$MBRpatch" -C /Volumes/install_osx
	
    # fix issue where large transfers kicking off lan
    # https://bitbucket.org/Jief666/bcm5722d/downloads
    rm -rf /Volumes/ESP/EFI/CLOVER/kexts/Other/BCM5722D.kext
    rsync -ah --progress "$customKext1" /Volumes/ESP/EFI/CLOVER/kexts/Other	
    }



main() {
    clear

    media=$(df -lH | grep "/Volumes/install_osx" | awk '{print $1}' | cut -c1-10 )
    echo $media
    echo You must format a USB pen and label it as install_osx
    echo

    PS3='Please enter your choice: '
    options=("format USB pen" "copy install files" "install clover" "overwrite EFI osxlatitude" "customise USB" "quit")
    select opt in "${options[@]}"
    do
        case $opt in
            "format USB pen")
                USB=$media
                diskutil list
                read -p “=====\ WARNING\ Are\ you\ sure\ you\ want\ to\ format\ $USB\ ???????\ =====“ -n 1 -r
                echo
                if [[ $REPLY =~ ^[Yy]$ ]]; then
                    # do dangerous stuff
                    formatUSB $USB
                fi
                    break
                ;;
            "copy install files")
                BaseBinariesclone
                ;;
            "install clover")
                installClover
                ;;
            "overwrite EFI osxlatitude")
                customEFI
                ;;
            "customise USB")
                customUSB
                ;;
            "quit")
                echo "remember to boot without caches if not working first time!"
                break
                ;;
            *) echo invalid option;;
        esac
    done
    }

main
Link to comment
Share on other sites

My new monitor arrived today so I have better screenshots now.

 

Now it keeps rebooting at

VoodooPS2TouchPad(Base) Version 1.8.3 loaded...

- or - 

VoodooPS2TouchPad Version 1.9.0 loaded...

 

Depending if I use Jake Lo's attachment, or the E5420 pack VoodooPS2Controller.kext

 

regardless which USB port or if using safe mode or without caches mode.

 

IMG_4930.jpg

 

 

IMG_4926.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...