Jump to content
PayPal donations: [email protected] ×

Recommended Posts

Hello. I successfully installed macOS and all WiFi and Bluetooth drivers. 

Bluetooth is working but the Settings tell me that I can't use Handoff / Instant Hotspot e.t.c... 

 

I used the brcm repo kext to install. 

 

So, how I activate Instant Hotspot and all the things ?

 

I have this Wifi Card: DW1560 BCM94352Z

 

I have this Wifi Chip: 

 

        Card Type: AirPort Extreme  (0x14E4, 0x19)

  Firmware Version: Broadcom BCM43xx 1.0 (7.21.94.136.1a1)

 

 

I have this bluetooth chip :  

       

         Manufacturer: Broadcom

  Transport: USB

  Chipset: 20702A3

  Firmware Version: v14 c5668

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Hi :)

 

I have the same WiFi card installed in my E7450 so hopefully You will manage to get Handoff/Hotspot running comparing Your configuration to mine.

I have followed a simple guide by Ross Fisher, however not step by step - I skipped some points, as everything works perfectly without them.

 

I have installed the following kexts on my EFI partition (/EFI/CLOVER/kexts/10.11):

  • FakePCIID
  • FakePCIID_Broadcom_WiFi
  • BrcmPatchRAM2
  • BrcmFirmwareData

These should deal with proper WiFi module identification as Airport Extreme, which results in working 5GHz band without any additional patches and fakeID injections in Clover Configuration.

Also Bluetooth module should be working visible in System Report, although without Handoff/Hotspot support yet.

There are no custom or modified kexts files connected with WiFi/Bluetooth neither in /Library/Extensions nor in /System/Library/Extensions.

 

Next thing is Clover KernelAndKextPatches configuration in config.plist file:

<dict>
	<key>Comment</key>
	<string>10.11-BT4LE-Handoff-Hotspot-lisai9093</string>
	<key>Disabled</key>
	<false/>
	<key>Find</key>
	<data>
	SIX/dEdIiwc=
	</data>
	<key>Name</key>
	<string>IOBluetoothFamily</string>
	<key>Replace</key>
	<data>
	Qb4PAAAA60Q=
	</data>
</dict>

My system definition is MacBookPro12,1 and I have El Capitan 10.11.5 installed.

 

Good luck :)

Share this post


Link to post
Share on other sites

Yes, and it helped. Calls worked. Instant hotspot for 2 seconds. After restart, nothing worked again. AirDrop never worked. 

 

I also noticed that the Wireless LED on the Laptop is only on when im open the bluetooth preferences on mac and searching for devices...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...