Jump to content

Help with El Capitan, Clover changing SIP setting in config.plist


jfmac
 Share

Recommended Posts

Hello, 

I used Jake Lo’s El Capitan Latitude/Inspiron/Precision Clover Guide for installing on a Latitude E6230 (clover 3556). Replaced the DSDT from the bootpack with Jake Lo’s DSDT for correcting “instant wake†found elsewhere on this site. Everything is working perfectly. :-P  THANK YOU! Prior to this install I’ve used Chameleon on several desktops and a couple of Latitudes. The guides found on this site are always excellent = again Thank you.
 
I see sip/crs is set at 0x67 in the config.plist which completely disables sip. Seems a bad idea to have sip totally disabled? Using Terminal on the mounted EFI partition, I changed the value 0x67 to 0x3 in EFI/EFI/CLOVER/config.plist. 
 
upon rebooting the error is “almost word for word†to below: 
OsxAptioFixDrv: Starting overrides for System\Library\CoreServices\boot.efi
Using reloc block: yes, hibernate wake: no
Error allocating 0x#### pages at 0x####... alloc type 2
Error loading kernel cache (0x9)
Boot failed, sleeping for 10 seconds before exiting...
 
Yes, I do see this error under the Trouble Shooting section, but I have 2 4gb DIMMS… am I missing something here?
 
Also used Clover Configurator to change to 0x3 and just got reboot
 
Question: :shock:  is it possible to run with clover at crs 0x3? and if yes how? Is it a matter of rebuilding the kernel cache or placing some/all of the kexts in S/L/E or what? Any help much appreciated.
 
 
Link to comment
Share on other sites

  • Administrators

Yes, you can run El Capitan and/or Sierra with CsrActiveConfig set to 3. That's what I use on all my Hacks, E6230 included. Reboot without cache when you 1st call on the revised value and rebuild your cache thereafter.

Link to comment
Share on other sites

Hello Herve, thanks for responding. Clover no longer includes the boot with no caches entry in the menu. I've tried booting -NoCashes and same without forward dash in boot arguments of the menu and it's a no go.  Tried -F, Also changed <key>NoCaches</key> to true in the config.plist. None of these methods allows to boot. At this point I need to know how to boot without cache. :?  Thanks

Link to comment
Share on other sites

Thanks Jake Lo. Can't find 3556 anywhere. all the supposed links go to current source forge installer. I can see 3577 still available at source forge so I'm downloading it. Do you still have the package installer for 3556?

 

 

Herve, yes I was pretty comfortable with chameleon. Don't really want to start over @ this point

Link to comment
Share on other sites

Did recommend replacements. Then changed 0x67 to 0x3 in config.plist. Upon reboot there's still no option in the menu to boot with NoCaches. I entered NoCaches=true on the Boot Args: line. 

 

Here's the failed boot image: post-77927-0-41870400-1481330419_thumb.jpg  

I wish I could make this work; I don't like not being able to turn sip at all. Not giving up yet. Is there some other tell tail clue in the image?

 

 

 

 

Link to comment
Share on other sites

 Share

×
×
  • Create New...