Jump to content

[SOLVED] Wrong resolution E5540


rubbereend
 Share

Recommended Posts

Hi, 

 

I made a clover installer with your guide on how to install El Capitan / Sierra.

When i boot the USB stick everything looks good untill the actual mac OS X installer appears...

It looks like there are two screens in one...

 

I attatched two pictures to make ik a little clearer.

Any help would be much appreciated.

 

The videocard is an Intel HD4000 the screen has a resolution of 1920x1080.

 

thanks!, 

 

Roelof

 

post-111024-0-94465300-1499626856_thumb.jpg

post-111024-0-68131700-1499626865_thumb.jpg

Link to comment
Share on other sites

  • Administrators

1st screen defect (at Apple logo) is perfectly normal until you apply the IOGraphicsFamily patch. For the 2nd screen defect, with a resolution > 1600x900, you need to set DualLink to 1 in your Clover config.

 

NB: Are you sure you have HD4000 graphics on an E5540? I'd have thought that was a Haswell platform with HD4200/4400/4600 graphics...

Link to comment
Share on other sites

  • Moderators

If you use Clover Configurator to open the Config file, it's under the Graphics tab. There you could change the dual link to 1.

But from my experience you don't have to set that for Haswell and newer...HD4400, HD4600, HD 5500, HD520..etc. It'll automatically detect the correct resolution.

Only SandyBridge and IvyBridge, HD3000 and HD4000, that you have to set it to differentiate low and high resolution.

 

Which OS X version are you installing?

Could be the boot glitch patch for 10.11.x that's causing it if you're installing Sierra using my Elcapitan bootpack.

Link to comment
Share on other sites

  • Moderators

What version of BIOS are you running?

Can you boot to the Clover GUI, hit F4 to extract the raw files, I'll repatch it for you and create a new Sierra bootpack.

Once extracted, go to /EFI/Clover/ACPI and compress the Origin folder and attach it here.

Make sure you see files in Origin folder, if not then you did something wrong.

Link to comment
Share on other sites

  • Moderators

Can you list the system's specs, starting with the CPU?

Does it only have just the HD4400 or also a discrete card?

 

Try setting the BIOS to Load Default. Apply. Then go back and change to

UEFI

AHCI

Enable Legacy Option ROMs

Enable XD CPU support

Disable TPM

Disable Secure Boot

 

Then try booting again.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...