Jump to content

[SUCCESS] High Sierra on Dell xps 12 9Q33


jones333333
 Share

Recommended Posts

Hello to everyone,

 

First, sorry for my English I speak french ;)

 

I really need your help and your expertise in order get High Sierra functionning on this laptop.

 

The specs:

 

DELL XPS 12-9Q33

Intel Core i7-4510 (Haswell)

Intel HD 4400

 

During the 2 past weeks, I tried to get this laptop running with proper power management and graphics with Clover.

 

I have to admit that I am a little bit confused for now as I tried to follow several tutorial about patching DSDT etc... but I think that I am a little lost with this one.

 

 

Could somedy help me this please.

 

In attach, the EFI folder that I used to be able to boot and install from USB. High Sierra is installed for now but without any power management and a lot of glitches in the graphics.

 

I know, my EFI folder  is a real mess...

 

Thanks in advance for your help, you really are my last hope.

EFI.zip

Link to comment
Share on other sites

  • Moderators

Replace Config. This should at minimum get your full graphics acceleration.

Post screenshots of Status and PCI List with

DPCIManager https://sourceforge.net/projects/dpcimanager/

and Launch

IOReg IORegistryExplorer_v2.1.zip

Save and attached all here for review

 

I saw you had exported the raw DSDT/SSDT. I'll try to patch for you once I have the info above.

What version of BIOS are you on?

config.plist.zip

Link to comment
Share on other sites

  • Moderators

Looks like it doesn't have built-in ethernet

Not sure what audio CodecID it has either...do you know what it is?

I see in you attach you have a patched AppleHDA for ALC275, is that the correct CodecID?

Does system has HDMI and DisplayPort or both?

Link to comment
Share on other sites

  • Administrators

How did you arrive to this? Try and temporarily install VoodooHDA (+ AppleHDADisabler) then run DPCIManager again. That should list the detected codec.

 

Your CPU is an i7-4510U @2.00GHz (Turbo to 3.10GHz), right?

 

NB: Since you appear to have a HiRes screen, please only post the useful part of screenshots, not the entire maximized windows where most of them is blank. Contents is then hardly readable, I've had to retouch them. Or reduce windows size to their minimum required... Merci!

Link to comment
Share on other sites

Hervé,

 

Thanks for your help and my apologies for the high res screenshots.

 

Here the info that I get from DPCIManager after installing VoodooHDA and the AppleHDADisabler

post-114013-0-93233100-1509574799_thumb.png

 

Also you are right about the CPU, it's an i7-4510U @2.00GHz (Turbo to 3.10GHz).

 

For now the the display of the laptop can't wake from sleep, I assume this is normal as I still need to fix the power management.

 

Also I am unable to change the level of brightness (slide doesn't appears in the display settings).

 

Thanks in advance for your precious help.

Link to comment
Share on other sites

  • Moderators

Ok, remove VoodooHDA + AppleHDADisabler

Replace the attached contents into /EFI/Clover

Copy kexts in  /EFI/Clover/kexts/Other/LE to /Library/Extensions 

Repair permission and rebuild cache

      sudo chmod -Rf 755 /L*/E*

      sudo chown -Rf 0:0 /L*/E*
      sudo touch -f /L*/E*
      sudo chmod -Rf 755 /S*/L*/E*
      sudo chown -Rf 0:0 /S*/L*/E*
      sudo touch -f /S*/L*/E*
      sudo kextcache -Boot -U /

XPS_12.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...