Jump to content

Dell lattitude 7480 - Mojave install : need help

Recommended Posts


I still do have a problem with headphones not working and HDMI freezing the computer whenever the cable is plugged in, 

any ideas about this.?


Share this post

Link to post
Share on other sites

Previously you stated all works even with HDMI output. What changed?

Try removing these arg

-cdfon -igfxnoHDMI

  • Like 1

Share this post

Link to post
Share on other sites


Before the migrate to Mojave worked, and after the migration, this is the only thing that I did not check. I apologize for being misleading.

remove this key, but after plug HDMI have hang and KP report after reboot



*** Panic Report ***
panic(cpu 0 caller 0xffffff801e6da29d): Kernel trap at 0xffffff7fa204a38b, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x00000000000001dc, CR3: 0x000000002cc60000, CR4: 0x00000000003626e0
RAX: 0x04b8e111a69c0055, RBX: 0x0000000000000001, RCX: 0x0000000000000001, RDX: 0x0000000000000001
RSP: 0xffffff820755be30, RBP: 0xffffff820755be90, RSI: 0x0000000000000001, RDI: 0x0000000000000002
R8:  0xffffff801ee9dc00, R9:  0xffffff80485f0040, R10: 0xffffff801ee9dc60, R11: 0x0000000000000000
R12: 0x0000000000000001, R13: 0x0000000000000000, R14: 0xffffff81c5e42000, R15: 0x0000000000000000
RFL: 0x0000000000010246, RIP: 0xffffff7fa204a38b, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0x00000000000001dc, Error code: 0x0000000000000000, Fault CPU: 0x0, PL: 0, VF: 1

Backtrace (CPU 0), Frame : Return Address
0xffffff820755b900 : 0xffffff801e5aeb0d mach_kernel : _handle_debugger_trap + 0x48d
0xffffff820755b950 : 0xffffff801e6e8653 mach_kernel : _kdp_i386_trap + 0x153
0xffffff820755b990 : 0xffffff801e6da07a mach_kernel : _kernel_trap + 0x4fa
0xffffff820755ba00 : 0xffffff801e55bca0 mach_kernel : _return_from_trap + 0xe0
0xffffff820755ba20 : 0xffffff801e5ae527 mach_kernel : _panic_trap_to_debugger + 0x197
0xffffff820755bb40 : 0xffffff801e5ae373 mach_kernel : _panic + 0x63
0xffffff820755bbb0 : 0xffffff801e6da29d mach_kernel : _kernel_trap + 0x71d
0xffffff820755bd20 : 0xffffff801e55bca0 mach_kernel : _return_from_trap + 0xe0
0xffffff820755bd40 : 0xffffff7fa204a38b com.apple.driver.AppleIntelKBLGraphicsFramebuffer : __ZN31AppleIntelFramebufferController20invokeHotplugHandlerEj + 0x4e1
0xffffff820755be90 : 0xffffff7fa2029913 com.apple.driver.AppleIntelKBLGraphicsFramebuffer : __ZN31AppleIntelFramebufferController18SWInterruptHandlerEP8OSObjectP22IOInterruptEventSourcei + 0x195
0xffffff820755bed0 : 0xffffff801ec5799d mach_kernel : __ZN22IOInterruptEventSource12checkForWorkEv + 0x13d
0xffffff820755bf30 : 0xffffff801ec55a32 mach_kernel : __ZN10IOWorkLoop15runEventSourcesEv + 0x1e2
0xffffff820755bf70 : 0xffffff801ec54fbc mach_kernel : __ZN10IOWorkLoop10threadMainEv + 0x2c
0xffffff820755bfa0 : 0xffffff801e55b0ce mach_kernel : _call_continuation + 0x2e
      Kernel Extensions in backtrace:
            dependency: com.apple.iokit.IOPCIFamily(2.9)[5C9A453F-559B-3683-9E81-D288D13A33CE]@0xffffff7f9eece000
            dependency: com.apple.iokit.IOACPIFamily(1.4)[67079254-1B34-31D2-8C7B-B138E26BFDD8]@0xffffff7f9f608000
            dependency: com.apple.iokit.IOAcceleratorFamily2(404.2.2)[3F0DBC5F-414B-379E-8C7B-A2F50B278A2A]@0xffffff7fa17a4000
            dependency: com.apple.iokit.IOReportFamily(47)[5F165AE5-F4F2-3415-857C-34F2462A730E]@0xffffff7f9faf6000
            dependency: com.apple.AppleGraphicsDeviceControl(3.28.4)[E80DEB91-2401-31C2-901F-CA63B4342337]@0xffffff7f9fa88000
            dependency: com.apple.iokit.IOGraphicsFamily(530.14)[D44517BE-2B53-3BD5-826E-4E78B55E3B73]@0xffffff7f9f1a9000

BSD process name corresponding to current thread: kernel_task
Boot args: dart=0 debug=0x100 keepsyms=1 



  • Like 1

Share this post

Link to post
Share on other sites

Here is my config: catmat-7480-v7.zip

But now i broke sound in headphones. cant find reason why, try layout 13,56 , but no luck

SSDT-ALC256.aml in ACPI/Patched , CodecCommander.kext in S/L/E , layout 13 , and no sound in phones. Then i plug phones in jack, sound off (speaker) but no sound in phones. 

@Jake Lo, did you have any advise ? 

Share this post

Link to post
Share on other sites

I want to share my observations about touchpad issues.

I used a bootpack from this tread to boot Mojave 10.14.3 on my SkayLake based Latitude 7480. Unfortunately I don't remember build version of Mojave.

The trackpad did not worked until DarwinFix was applied in Clover config. I installed Mojave update version 18D109 later. After update I got Touchpad broken. After some time I removed DarvinFix and got the touchpad functionality back 🤪. So, to me the track pad issues (when VoodooI2C kext work for some peoples while it doesn't work for others) is also depends on OS build version and ACPI patches in clover.


Now I wonder if you guys managed to get backlight adjustment work properly. I use AppleBacklightFixup.kext but the best I could get was 100% brightness, with a non-working slider :-(. Actually the backlight has 2 states depends on the slider position - Full brightness and no backlight at all. I have followed AppleBacklightFixup instructions down to the letter but no success.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...