Jump to content
muttonhead411

DW1820a - the general troubleshooting thread

Recommended Posts

So happy I bumped into this thread. 

 

At this time, I need to buy a new card, since I bought the "Lenovo OEM FRU P/N: 00JT493 Broadcom BCM94350ZAE" card at the beginning of my journey (I believe Herve said that this card hasn't been tested for compatibility in the Wifi thread). I can say that WiFi works perfectly but I cannot get the Bluetooth to work at all. Alas, I most likely need a new card...  

 

What cards are the most likely to work OOB at this point in time? I'm on Mojave.  

 

Paging @Hervé for help :)

 

--------------------------------- What I've Done ------------------------------- 

 

My BT shows up in my menu bar up top and can detect Bluetooth devices such as my wireless speaker, etc.  It attempts to connect, very rarely connects for a split second, then DCs and refuses to connect again.  

 

I've tried the fixes through browsing package contents of BRCMPatch2 and BRCMFirmwareRepo and changing with PlistEditPro, I attempted to change the firmware of my BT to the v7 5803... no change as you can see in pics.

 

I also checked to see if this was a chip problem but on Windows 10 which I have dual booted, the BT worked fine after installing some drivers.  I was able to click thru a bunch of properties, etc and find that the driver?hex?idk? it's using is "BCM4350C5_003.006.007.0095.1668.hex" . Back on the Hackintosh side, I downloaded this .hex file from some random site and tried to put it into my BRCMFirmwareRepo + set it in the BRCMPatch2 but to no avail.  TBH, I had no idea what I was doing at this point 🤣

 

Please help! I'm by no means a computer expert (surprised at how I even built this thing so far), I'm a med student, so I'm sorry if I ask silly questions.  BT is the most important feature to me and it sucks I haven't been able to get it to work 😕 

 

As mentioned above, I'm beginning to think a new card like the DW1560? might be my best bet... hopefully it runs OOB?

Screen Shot 2019-07-26 at 1.11.17 PM.png

Screen Shot 2019-07-26 at 1.09.59 PM.png

 

Share this post


Link to post
Share on other sites

I have installed DW1820A that seems wrong labeled as OVW3T3, because it's subsystem ID showing up as 1028:0023.

The wifi is working fine, even without airportbrcmfixup, but the bluetooth is not detected at all.

 

i've usb working, installed usbinjectall, and implemented custom ssdt. even if i'm removing custom ssdt, the bluetooth device won't show up. Than i'm doing the pin masking like @Naidis did, and than my wifi card is unavailable, but the bluetooth device is appear.

 

the bluetooth it self have BCM2045A0 detected with Vendor ID : 0A5C, and  product ID : 6412, the location of usb port is on HP13, that mean the bluetooth device using USB 2 BUS, on PR11, like this

 

Spoiler

photo_2019-07-27_11-43-37.thumb.jpg.b8e6af05cc2f85f4ef4114bb3e668507.jpg

 

The conclusion is,

1. If my pin card is masked, the bluetooth detected, but it make wifi unavailable

2. if my pin card is not masked, the bluetooth is not detected at all, and wifi work normally

 

i don't know it's my card problem, or my ngff slot hardware problem, becasue it have same case on windows. Anybody please help me out

 

i'm attached my IOReg without pin masking for now

Azrul’s MacBook Pro WPM.ioreg

Share this post


Link to post
Share on other sites

A few questions for you... how does the device work on windows with pin masked and not masked? If they work normally then it’s more than likely a configuration issue on your Hackintosh.

 

also Herve mentioned before that the functiontionality of wifi and Bluetooth are different. All DW1820A will have Bluetooth detected as long as you have rehabman kext loaded. Getting Bluetooth usable with a connected device is the tricky one. 

 

Pin masking is required for your version of card to work with WiFi. 

Share this post


Link to post
Share on other sites

@tazorac8 Bluetooth working reliably on our card hasn’t have a permanent fix yet. Only known way so far is to get the drivers loaded from windows, then reboot to Mac OS for Bluetooth to work stable. To do this you need an injector on Mac side, without firmware upload functionalities. 

 

Otherwise yep DW1560 seems to be a popular card for full functionalities. Note that it’s not plug and play OOB functionality. You will need kext to get it working...

Share this post


Link to post
Share on other sites

Hi all, have been playing around with the driver to see if I can get firmware upload in Mojave  to work on my dw1820a without needing windows to upload the firmware.  

 

It seems to be working ok , but am still testing to see if it works consistently.  

 

Attaching the kexts if anyone else would like to try with their dw1820a.  These need to be uploaded to /EFI/CLOVER/Kexts/Other.  Make sure you don't have any equivalent kexts in /L/E or /S/L/E.

 

Let me know if you have any success.

BrcmBluetoothInjector.kext.zip BrcmFirmwareData.kext.zip BrcmPatchRAM2.kext.zip

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites

I'm not sure how you did it... but you somehow got it to work....

 

I'm gonna keep testing for now... Wondering if you could make a version that works via L/E if possible...

 

Thanks.

Share this post


Link to post
Share on other sites

Yes, will see what I can do.  Out of interest is Apple watch unlock or personal hotspot working for you? Those are the only things that don’t work now for me. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...