Jump to content

DW1820a - the general troubleshooting thread


Recommended Posts

@Hervé - I tried your kext as well... same behaviour as before. 


If sysinfo is showing v7 c5799, it probably means firmware isnt being loaded. When this happens, you will be able to connect to devices, but they will randomly disconnect, and have "choppy" behaviour. 


I'm surprised all is good on your end... -jealous-

Link to comment
Share on other sites

Since we have it a bit of roadblock with bluetooth, I decided to go out and buy a bluetooth dongle to test out. 


I bought the following CSR Bluetooth USB dongle:



Steps that I followed:

- removed all traces of Rehabman's kext so that bluetooth is not showing in System Information

- plugged in bluetooth dongle


What happens next is surprising:

- Bluetooth dongle lights up, it is working

- Bluetooth shows up on menubar, bluetooth is functioning


But... when it try to connect to my bluetooth mouse, it does NOT work. It exhibits the same behaviour as DW1820a! Device discovery is fine, but it cannot connect to any device.


I'm beginning to think it is not a hardware issue (since both dongle and dw1820a both don't work), but the way we are configuring bluetooth on our machines


Paging for @Hervé @Jake Lo. Any thoughts on what could be happening? 

Link to comment
Share on other sites

Well, I finally returned from a long business trip.


I made some progress on using this card, and the most important thing is, I never correctly upload any version of firmware via macOS.


Basically, according to BrcmPatchRam's instructions, you will need an injector (brcmpatchram2 or custom injector) and a firmware store ( brcmfirmwarerepo or brcmfirmwaredata or a brcmfirmwarerepo including customized firmware).

After trying so many combinations, I could see correct firmware version I was uploading from SysInf, I could detect bluetooth devices around, I can even make connections, but those devices just won't work.


Now I'm uploading the firmware via windows, then reboot into macOS with a modified BrcmNonPatchRAM2.kext.

That's it. There's no need for BrcmPatchRam2, Fixairport, brcmfx-driver=x. The macOS will try to load the cached firmware uploaded by Windows, and works perfect.


You may check here for details and my latest build.



I walked through threads in recent months, and are going to try the kexts uploaded by you guys. Hopefully I can upload the firmwares via macOS itself.


Link to comment
Share on other sites

Well, I tried again BrcmFirmwareRepo.kext ( with BCM4350C5_003.006.007.0221.4688_v8784.hex ) plus BrcmPatchRAM2.kext ( modified ), put them into /L/E, rebuilt cache and repaired permissions with hackintool (I don't like this method since since 10.15 we won't be able to modify /L/E).


After releasing the firmware uploaded via windows, I boot into macOS and firmware version turned to v7 c4688, which means I uploaded the firmware. However the paired bluetooth devices kept disconnecting and reconnecting, won't work at all. 


Since I'm not using latitude, I'm not sure if I could get this problem fixed here. It could be related to USB map. But I'll stay with my old windows-uploading method until I got some spare time testing it.

Link to comment
Share on other sites

On 7/7/2019 at 8:45 PM, muttonhead411 said:

Hi everyone, 


Through testing, I've managed to confirm the following, FYI @Hervé maybe it will be of use.


When using Rehabman kext to inject firmware (BrcmPatchRam2& BrcmFirmwareRepo/Data), bluetooth is:

- Able to be enabled

- Able to detect bluetooth devices

- NOT able to sustain connection to bluetooth devices


When using Rehabman kext to ONLY inject bluetooth  (using BrcmBluetoothInjector.kext, or when firmware fails to load), bluetooth is:

- Able to be enabled

- Able to detect bluetooth devices

- Able to connect to bluetooth devices, but not stable/jumpy connection, and will disconnect/crash bluetooth after a while



It is weird, but without firmware upload, the card is able to do more with bluetooth, than without firmware upload. However, the card is still not usable with this setup. Note also that this behaviour is only happening to 1028:0021cards. for 1028:0023, there are no bluetooth issues, but wifi is garbage on this model

Try upload the firmware via Windows or virtual machine windows. Remember to release the uploaded firmware first.


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...