Jump to content
muttonhead411

DW1820a - the general troubleshooting thread

Recommended Posts

Yes, 5ghz is working on both Windows 10 and macOS and both perform virtually the same according to iperf. 

 

I've been using the Mac setup for a few hours now without any crashes or performance drops whatsoever. I'm very happy with these results!

Share this post


Link to post
Share on other sites

@Hervé I've tried my best to read up on this, and figure out how to fix my bluetooth issues, but I can't seem to succeed. Would like to get your guidance

 

Symptom: Bluetooth is recognised, and is able to discover devices, but is unable to connect to any device successfully (mouse, AirPods, non of them work)

 

Since its likely a USB discovery issues, I've attached the following materials, maybe you can point me in the right direction for this... I am using a very similar setup as your 7490 on 10.14.5 (except I'm on i5, without thunderbolt)

ioreg profile posted as well.

 

Thank you!

01.jpg

 

02.jpg

 

03.jpg

 

04.jpg

 

 

 

 

Share this post


Link to post
Share on other sites

Funny that you copied all your add-on kexts to /L/E, except FakeSMC. Depending on your Clover settings, you could be trying to inject kexts that are already cached. So, copy FakeSMC to /L/E, repair permissions, rebuild your cache and set Clover kext injection to "Detect". Reboot and check Bluetooth again.

 

This being said, your setup is probably Ok: your Bluetooth SysInfo, things look identical to the info for my own card.

DW1820_BT_info.jpg

 

On my side AirDrop works perfectly with my other Hacks and so does HandOff with my iPhone. I had not even attempted to pair with any other Bluetooth device but on trying to connect to my JBL speaker, I too cannot establish a connection. I guess more work is required on that front. In all likelihood, Rehabman's kext need an update of firmware in which case you could try to extract the latest one as explained here. Device 0a5c:6412 is not mentioned in the list of tested devices but, nevertheless, it appears to be covered by a 4yr+ old firmware (BCM4350C5_003.006.007.0095.1703_v5799)...

 

Looking at the contents of BrcmFirmwareRepo, you'll see a list of firmware and that's where the latest version for the DW1820A should go. I'll try to update asap.

Share this post


Link to post
Share on other sites

Ok, I downloaded the latest driver for DW1820A I could find on Dell's web site here (Win7 64bit for XPS 9350, dated May 2019). I extracted the firmware 1707 for our 0A5C:6412 DW1820A device:

BCM4350C5_003.006.007.0095.1707_v5803.hex.zip

 

All you need to do then is:

  1. copy the uncompressed .hex firmware file to the Resources folder of BrcmFirmwareRepo kext to supersede current version 1703 (=v7 c5799)
  2. update the key for device 0a5c_6412 in Info.plist file of BrcmPatchRAM2 kext
    • BrcmPatchRAM2_patch.jpg

 

After repairing permissions and rebuilding the cache, I can now connect to my JBL USB speaker without issues:

BT_PrefPane.jpg     JBL4_audio_output.jpg

 

BT_v5803.jpg

 

This firmware version 1707 (which equates to v7 c5803) seems to be quite old (dated December 2015) but works Ok nevertheless. I'll try and lookup for a more recent firmware than that one.

 

Edit: reverted to uncompressed .hex firmware file.

 

  • Like 1

Share this post


Link to post
Share on other sites

@Hervé

 

You are absolutely amazing. Thanks to you and the community, we now have a fully working DW1820a, both wifi and BT together! you solved this issue in a matter of hours, which I couldn't even do over several weekends!

 

Look at this... 2 devices at once!!

image.jpg

 

My work on Dell 7490 is almost perfect... what a beauty it is. Thanks again!!

 

 

Share this post


Link to post
Share on other sites

I found version 4688, dated July 2018 which seems to work Ok too.

BCM4350C5_003.006.007.0221.4688.hex.zip

 

In BrcmPatchRAM2 kext, the FirmwareKey for device 0a5c_6412 in Info.plist file must be updated to "BCM4350C5_003.006.007.0221.4688"

 

Edit: reverted to uncompressed .hex firmware file.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

I've been doing further testing on bluetooth and wifi for DW1820a. Here are my observations so far:

- Bluetooth connection stutters. When using bluetooth mouse, the cursor jumps on the screen. When using AirPods, the audio skips.

- When left idle, bluetooth devices will disconnect on their own

- Bluetooth is more stable when wifi is running on 2.4ghz, or turned off

 

Initial suspect is related to power management to the card, or some form of interference. On windows the card works perfectly, which means it is not an antenna problem. 

 

@Hervé do you observe the same as well?

Share this post


Link to post
Share on other sites

The only thing I've now used intensively is my JBL speaker and I've had no issues whatsoever.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...