Jump to content
muttonhead411

DW1820a - the general troubleshooting thread

Recommended Posts

I followed @Hervé guide for 7490 with much success, but minor hiccup on wireless card access.

 

Not sure if it's just my luck, or I got conned, but the DW1820a OVW3T3, which should work great in this setup, faces performance issues once wifi network is connected. 

 

I read @Hervé guide on wireless cards so many times, until I noticed that the subsystem ID, which should have been 1028:0021, is showing up as 1028:0023. I'm basing this info on the system profiler picture attached. 

 

Hopefully I'm wrong on all of this, but any ideas how I can get this card working? 

 

@Jake Lo @Bronxteck

IMG_20190520_111427.jpg

IMG_20190520_111430.jpg

Share this post


Link to post
Share on other sites

In your case, I suspect the wrong label was erroneously fitted on the card or it was actually changed from the 08PKF4's to 0VW3T3's. Why? Well, because:

  1. this would be the very 1st 0VW3T3 model I see with subsystem id 1028:0023 (I now possess 3 x 0VW3T3 cards with id 1028:0021, like the others I've dealt with for other forum members)
  2. the MAC address of the card's label (clearly C8FFxxxxxxxx) does not match the real MAC address shown in macOS (3052xxxxxxxx)
  3. you experience the reported behaviour/problems of the 08PKF4 model

 

Depite the label fitted to the card, I'm pretty confident you do not have the 0VW3T3 model. Sorry. If you can, demand a refund/return to the buyer you got it from on the basis that it does not meet the advertised specs.

 

Share this post


Link to post
Share on other sites

Hi muttonhead411,

 

I advise you to do not go further with the dw1820a and to take directly a dw1560. With a problematic dw1820a (like yours), I successfully get a working wifi but with these downsides :

- 1 boot out of 3 or 4 is ok (else kernel panics, freezes)

- issues when shutting down the laptop (freezes)

- issues when locking the session (freezes)

 

And it is the most stable situation I got thanks to a mix of Hervé patches and other forum patches...

 

Best regards.

 

Share this post


Link to post
Share on other sites

Thanks @Hervé and @grui.

 

@Hervé you are spot on about the sticker on the card. Most probably a fake sticker and hence the issues. Trying my best now to get a refund. May I know where you get your cards from since you've had good success with 3 of them now?

 

After reading a bunch more, am thinking of making the jump to Dw1830 directly, for BT4.1, and out of box compatibility. However, do you think the size will fit given the above? I may try pulling the wwan antennas to attach to the additional socket. What do you think? Cost isn't too much of a concern for now, I would have loved to get DW1820a working though... Size is right, antenna slots right and BT4.1... Would have been nice. 

 

@Jake Lo you had experience with Dw1830 before. Any thoughts on this? 

Share this post


Link to post
Share on other sites

DW1830 works perfectly like the DW1560 which also has 2 antennas like DW1820A.

There's no issue with size, they are basically the same sizes.

Share this post


Link to post
Share on other sites

WWAN antennas are too short for the WLAN slot in the 7490. DW1560 is a better alternative than the DW1830.

 

NB: I purchased my DW1820a off the well-known auction site; I'll send you details of the seller by PM.

Share this post


Link to post
Share on other sites

You may refer to the wikidevi link provided in our wireless inventories for details of the DW1820a (not to be confused with DW1820).

Share this post


Link to post
Share on other sites

Same thing for @muttonhead411: the sticker of your card does not match the hardware specs and the real MAC @ differs from the sticker's ! So, no, it's not a DW1820a 0VW3T3 model. This being said, it's interesting that you report that the 1028:0023 model works for you.

 

You're using AirportBrcmFixup + boot option brcmfx-driver=1 as I had suggested a few weeks ago and I'm wondering if you could test it without AirportBrcmFixup + the associated boot options and tell us how it goes. It may well be that, for those cards that end up clogging the Hackintosh to a halt, It's actually required. I'm going to try that with the CN-096JNT model I recently acquired.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...