Jump to content

DW1820a - the general troubleshooting thread


Recommended Posts

@Hervé - some updates, the new DW1820A card from ebay finally arrived, installed, and working as it should. No hangs, no kernel panics. Things are looking good.


However, there are 2 things I noticed:

- Bluetooth isnt working well. When setting properties through clover: 14e4:4331 does not detect bluetooth at all, but 14e4:4353 detects bluetooth correctly

- However, with 4353 detecting bluetooth, in actual fact nothing can connect to it. It discovers available bluetooth devices correctly, but will not successfully connect to them (i tried both airpods and bluetooth mouse, both didnt pair successfully). 



Link to comment
Share on other sites

  • Administrators

Bluetooth has nothing to do with wireless. You've got to make sure you've got all your USB ports working through an injector or otherwise and then use Rehabman's firmware patching kexts as detailed in my 7490 guide.


Link to comment
Share on other sites

I have DW1820A part # CN-0VW3T3, but 1028:0023.

I managed to get it work like described with 14e4:4331.

But even with KEXT AirportBrcmFixup and argument brcmfx-driver=1, after few minutes, macOS start be very laggy and wifi stoped working. Then I have to 

I mentioned that with brcmfx-driver=1 there are still 2 system kext for wifi loaded:





I also tried clover config fixes:






but result is the same.

Do you have any suggestion what is wrong?


Thank you.

Link to comment
Share on other sites

I've been following this thread and I decided to make an account because I was able to get my CN-08PKF4 working with @Naidis' fix.


I only did the following steps based on @Hervé's solution:


  1. Inject AirportBrcmFixup, BrcmFirmwareRepoData, and BrcmPatchRAM2 in C/K/O
  2. Add the boot option brcmfx-driver=1 (it would not boot otherwise)
  3. Inject properties (I tried injecting subsystem-id 21 as per another thread but it didn't work 😕)
  4. Taped the 3 pins on the front side and only 2 pins on the bottom just like @Naidis did.

I did not apply FixAirport or AddDTGP. I played a 10 hour loop of a fireplace on youtube to test variations of fixes, and the only one that didn't end up crashing is the method above.


On 6/5/2019 at 2:18 AM, Hervé said:

Maybe you can explain what pins you masked and why.


I suggest we figure out why blocking those pins somehow fix the problem.



Changing to brcmfx-driver=2 allows me to do Handoff

Link to comment
Share on other sites

Interesting, could you explain the IORegExplorer story please (I still don't get it, I have no Windows on the laptop anymore). Xcode is probably used but not sure where to get the app and if the USB ports (Injects etc) have to be changed?

Link to comment
Share on other sites

I'm a little confused about what you are asking. Are you trying to see what's going on in the IORegistry?

I was able to download IORegExplorer from some random GitHub repo, but you can still download it straight from Apple's dev tools.


I also have no idea what the pinout is for this particular DW1820a (CN-08PKF4) and why pins need to be disabled as opposed to the other variants.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...