Jump to content

DW1820a - the general troubleshooting thread


Recommended Posts

Got it working now including Handoff using v7 4096. C/K/O only! 

- Configured USB correctly with USBInjectAll to get bluetooth USB on internal USB

- Added Device Property

- Added brcmfx-driver=1 brcmfx-country=#a


And VERY, VERY, VERY important, disabled Wake on LAN and PCIE ASPM in BIOS.



Screenshot 2019-08-16 at 16.21.38.png

Screenshot 2019-08-16 at 16.26.07.png

Link to comment
Share on other sites

Purchased three of the 0VW3T3 Models with ID 0021. Only one of them is working correctly without issues at a Lenovo (used below way 2).


The two others do not work at HP and Asus, I can no more test them at the Lenovo.

With Linux all three cards are working great.


Tried these three ways:

1) Only modified Info.plist with 43a3 to get Brcm4360 Kext load. This should to be the fastest way to get this DW1820A running.

2) Searched PCI-Path with IOreg (it is RP06) and created SSDT with injections according to @Hervé s Manual

3) Made Clover Injections (Properties) according to @Hervé s Manual


Always getting KPs with two of the cards.


Unfortunately so seems to me not all of these 0VW3T3/0021 are going to work as described.


Did anyone try the Pin-Masking with the 0VW3T3 / 0021 models?

Do I have to mask the same Pins as at the 08...?


(By the way: Mac-Address matches printed Address on Label, one is 30... the other 74...)

Link to comment
Share on other sites

Hello guys 

I need your help please , 

I have DW1820a OVW3T3 with Subsystem ID 0x0021 

I get wifi and Bluetooth works successfully after following @Hervé thread 

But unfortunately my system freeze and huge processor usage only after 10 minutes of using 

As @Hervé mentioned regards 0x0021 I should not have any issues with this card 

Please have a look on my screen shot 

Laptop is Lenovo P50 with latest Mojave


FYI : I am using this card on a desktop build running mojave as well without any problems 

I am getting KP on laptop without boot arg brcmfx-driver=1 and without AirportBrcmFixup.kext 

For me both pci14e4,43a3 and pci14e4,4353 works 

I've tried IO80211Family.kext method from old os 10.10 and it works great with no system freeze or hang at all but 2 or 3 KP if system reboots 


Thank you  


Screenshot 2019-08-18 at 21.29.34.png

Screenshot 2019-08-18 at 21.33.47.png

Screenshot 2019-08-18 at 21.26.38.png

Screenshot 2019-08-18 at 21.28.20.png

Screenshot 2019-08-18 at 21.29.09.png

Screenshot 2019-08-18 at 21.34.26.png

Screenshot 2019-08-18 at 21.34.57.png

Screenshot 2019-08-18 at 21.35.33.png

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...