Jump to content
muttonhead411

DW1820a - the general troubleshooting thread

Recommended Posts

Hi, i'm only use brcmfx-country=#a , and removed your Device patch from clover, the driver still loads AirPortBrcmNIC withous any issues, if i'm not using AirportBrcmFixup the device detected as third party wireless device.

Share this post


Link to post
Share on other sites

Ok, it's perfectly clear. You must be the 1st person for whom the DW1820A actually works nearly OOB!

  • Thanks 1

Share this post


Link to post
Share on other sites

hahaha thanks 😂, but is there any way to force macOS to use the 5Ghz channel, sometimes the channel change itself to 2.4Ghz, or do you think that i broke the Built-in antenna, because that time when i'm replacing the device, i didn't know the antenna soldered to Intel wifi 7265, and now i'm using cheap small ngff antenna, does the antenna affect the network band???

Share this post


Link to post
Share on other sites

Yes, given the nature of the signal (short waves), 5GHz networks will work better with 2 x antennas. I don't think it'll work properly on a single antenna. If you want to force your card on 5GHz, I guess you could try and split your SSIDs and have one for 5GHz and a different one for 2.4GHz.

Share this post


Link to post
Share on other sites

i got it, i can't stable connect to 5Ghz because this connector, got ripped out, dmn i wish i knew earlier that my laptop wifi card was soldered with the antenna. anyway thanks for your guide and support for this card.

Untitled.png

Share this post


Link to post
Share on other sites

Hello! I'm trying to get my card to work, the bluetooth literally works and is able to pick up my phone, however the PXSX device no longer shows in ioregistry under RP20.

Wifi does not work at all. What do i need to help diagnose this, and what steps should i take?

Share this post


Link to post
Share on other sites

also tested my airpods, they connect fine and display the battery level. really confused why the wifi side isnt working yet bluetooth is.

Share this post


Link to post
Share on other sites
On 8/31/2019 at 7:20 PM, Hervé said:

Ok, it's perfectly clear. You must be the 1st person for whom the DW1820A actually works nearly OOB!

 

I am 2nd.

 

08PKF4 OOB, no property injection, no masked pins on 10.14.6 (18G95)

 

Loaded kext: com.apple.driver.AirPort.BrcmNIC (1400.1.1)

 

Software Versions:

  CoreWLAN: 13.0 (1375.2)

  CoreWLANKit: 13.0 (1375.2)

  Menu Extra: 13.0 (1380.2)

  System Information: 12.0 (1300.2)

  IO80211 Family: 12.0 (1200.12.2)

  Diagnostics: 1.0 (805)

  AirPort Utility: 6.3.9 (639.9)

  Interfaces:

en6:

  Card Type: Third-Party Wireless Card

  MAC Address: xx:xx:xx:xx:xx:xx

  Supported PHY Modes: 802.11 a/b/g/n/ac

  Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165

  Wake On Wireless: Supported

  AirDrop: Supported

  AirDrop Channel: 149

  Auto Unlock: Supported

 

Card does not show up under PCI devices.

 

I am sure, it did not work before!

 

I only checked now after I read the post and I installed both Supplemental updates since I last tried.

 

Is it possible, that something changed with one of the last two 10.14.6 supplemental updates here?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...