Jump to content

DW1820a - the general troubleshooting thread


Recommended Posts

46 minutes ago, Hervé said:

I believe I had explained in may guide that combining compatibility with 14e4:4353 injection + boot parameter brcmfx-driver=1 caused issues to me. Try without the boot parameter.


What's interesting though -and that's probably key- is that your system runs Ok if you restrict the card to 40MHz. But is that on the 5GHz or, presumably, the 2.4GHz network band?


For 2.4Ghz the bandwidth is locked to 20MHz only adjusting the wireless router doesn't effect anything at all the bandwidth is always 145Mbps. For 5.0GHz I'm able to connect to all the bandwidth 20/40/80MHz only 80MHz is seem to cause many issues such as kernel panic at boot/restart and system sometime freeze. But I just try limiting the throughput(from 867Mbps to 780Mbps) while staying at Bandwidth 80MHz seem to work flawlessly. But I think I prefer to stay with 5GHz 40MHz to avoid random kernel panic on start/reboot/shutdown. Without brcmfx-driver=1 I always get kernel panic one time before booted up and the machine,  sometime turn on itself after shutdown.

Screen Shot 2562-08-21 at 19.29.34.png





Link to comment
Share on other sites

  • Administrators

It's not a train I wanted to jump on but I've now experienced the issues reported by so many people; on a Latitude E7250 that I'm working on. None of my BCM4350 cards will work in it. I've tried:

  • 2 x DW1820A 0VW3T3 (1028:0021) models that actually work 100% Ok in my Latitude 7490
  • 1 x DW1820A 096JNT (1028:00xx)
  • 1 x Foxconn T77H649.00 (17aa:075a)


I believe I've tried everything that had been mentionned in this thread, including the pin masking (3 @front, 2 @rear); on all 4 cards; to no avail.


Given that the 2 x 0VW3T3 run perfectly in the 7490, I suspect it's not just a matter of cards but, also or instead, an issue of M.2 slot and/or ACPI definition. I'm supposed to handover the E7250 to its owner by September 1st so I don't know if I'll have sussed out the issue by then. We'll see...


Link to comment
Share on other sites

On 8/21/2019 at 1:55 PM, osxosx said:

What's going on here?


I am still using after mask without any issue at all for the third day 

Check your mask again , maybe it moved from its place when you insert it ..

And you know what !!! 

I believe I've masked 3 pins in two sides , not 3 front 2 back as thread suggest , I realized that after I read the post one more time  , but thought everything is ok ..

Link to comment
Share on other sites

On 8/5/2019 at 2:16 AM, nickhx said:

Thanks credit to @headkaze for the updated brcmpatchram kexts for Catalina, which I am using as a base here.


 I have made some changes to the underlying code which I am still testing to deal with the patching issue.

What changes have you made? I'd be interested in taking a look.

Link to comment
Share on other sites

I thought everything was fine since WiFi and Bluetooth work great now including Handoff and without freeze. (Even though it is a CN-08PKF4).


I just noticed, that something must be still shady since running Wireless Diagnostics hard crashes the computer.


Did anybody try to run Wireless Diagnostics yet? 

Link to comment
Share on other sites

  • Moderators

I would stay clear of it...I bought one to test what everyone here is reporting issue for on my E7470 /E7450 and I encountered the same hang/freeze/lag after 15- 30 min usage.

I got the 0VW3T3 cards with id 1028:0021, and the Mac Address matches the label too. I had also tried the pin masking, no difference.


I would recommend DW1560 and not waste any money on this one. I know it's a lot cheaper than DW1560 though.


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...