Jump to content

Dell Alienware 15R4\17R4\17R5 Installation and help!!


Recommended Posts

Hello I have been trying to get OSX installed on my Alienware 15R4 for quite some time. It is successfully installed and i'm actually posting this very post using the same. There are a couple of problems though.

This install has issues such as the nvme kernel panic issue. I have tried following multiple posts but it doesn't help. I have tried multiple ssd patches none of them work.

Present config that i have is mentioned below:

Alienware 15r4 i7 8750H , 32gb RAM, GTX1070OC, gsync display 120hz, 2ssd's(Hynix301 and samsung 981), 1TB SATA(only used for data).

OSX is installed on Hynix partition and Windows is installed on samsung.

Error that i whilst i try to copy files from samsung ssd to hynix ssd is mentioned below:


>>>>>>>>>>>>>>>>>>>>Start of MEssage<<<<<<<<<<<<<<<<<<<<<<

*** Panic Report ***
panic(cpu 2 caller 0xffffff7f97390e2b): nvme: " NVMe: Command timed-out and request found in the completion queue\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-356.71.1/IONVMeController.cpp:5184
Backtrace (CPU 2), Frame : Return Address
0xffffffa3d2f7bb60 : 0xffffff8014a6d1c6 
0xffffffa3d2f7bbb0 : 0xffffff8014b95a74 
0xffffffa3d2f7bbf0 : 0xffffff8014b87d44 
0xffffffa3d2f7bc60 : 0xffffff8014a1f1e0 
0xffffffa3d2f7bc80 : 0xffffff8014a6cc3c 
0xffffffa3d2f7bdb0 : 0xffffff8014a6c9fc 
0xffffffa3d2f7be10 : 0xffffff7f97390e2b 
0xffffffa3d2f7be30 : 0xffffff801509eb7c 
0xffffffa3d2f7bea0 : 0xffffff801509eaa6 
0xffffffa3d2f7bed0 : 0xffffff8014aa6624 
0xffffffa3d2f7bf40 : 0xffffff8014aa6185 
0xffffffa3d2f7bfa0 : 0xffffff8014a1e557 
      Kernel Extensions in backtrace:
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[9AC0F895-00AA-35E6-A561-4FF35C9281B8]@0xffffff7f95d37000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[70EA0775-DFBE-3132-9001-F5A9C20D0CF3]@0xffffff7f95294000
            dependency: com.apple.driver.AppleEFINVRAM(2.1)[F35A52E2-CF80-3BA9-92B5-25EFE216094F]@0xffffff7f97371000
            dependency: com.apple.iokit.IOStorageFamily(2.1)[F27A8A2A-6662-3608-83BD-415037509E01]@0xffffff7f960de000
            dependency: com.apple.iokit.IOReportFamily(31)[D2F2FBDF-4EE4-38BA-99F5-B699F886F413]@0xffffff7f97330000

BSD process name corresponding to current thread: kernel_task
Boot args: -lilubeta kext-dev-mode=1 -wegbeta -alcbeta 

Mac OS version:

Kernel version:
Darwin Kernel Version 17.7.0: Wed Feb 27 00:43:23 PST 2019; root:xnu-4570.71.35~1/RELEASE_X86_64
Kernel UUID: E385ABD9-67BA-3CA7-9436-8F52D9C5634C
Kernel slide:     0x0000000014800000
Kernel text base: 0xffffff8014a00000
__HIB  text base: 0xffffff8014900000
System model name: MacBookPro14,3 (Mac-551B86E5744E2388)

System uptime in nanoseconds: 96990501825
last loaded kext at 10228475039: com.nvidia.CUDA    1.1.0 (addr 0xffffff7f95f18000, size 12288)




This is one of the problems, secondly i do not have my headphone jack working at all only speakers work.

I'm also attaching my debug files if someone can please take a look and guide me as to what is needed.


Thanks much!!



Link to comment
Share on other sites

  • Moderators

It's a known issue with Samsung PM981 not working well on Hackintoshes. You might think about replacing it with a known supported drive.

As for headphone, I see you're using a patched AppleHDA.kext. What's and where's the source of that kext?

I see it's for an ALC298. Have you tried AppleALC.kext with layout-id 11, known to work on Alienware 17.

You could try all these different layout-id 3, 11, 13, 28, 29, 30, 47, 66, 72, 99

You'll need to restore the vanilla AppleHDA.kext to /S/L/E, repair permissions and rebuild cache

Link to comment
Share on other sites

Thanks for the quick reply, I have tried to using ALC but it never seems to work so one of the guys "insanedeepak" helped me on git on the same topic well, the speakers started working after that but then headphones etc never work. Also, i have an alienware 15.

Also, can you tell me if its a good idea to install OS mojave cos i have heard that people do not have GPU acceleration on Mojave.

Link to comment
Share on other sites

  • Moderators

Yes, InsanelyDeepak might be able to fix that HP for you if AppleALC don't have the right codec for your system.

UHD 630 works just fine on Mojave, the Nvidia might need web drivers, however Hackintosh don't support Optimus. You'll need to disable the Nvidia card anyway to preserve Energy.


Link to comment
Share on other sites

Thanks for the reply, although i sorted out the ssd issue and i have a gsyc panel in which i can't disable nvidia card.

now i'm trying out catalina install but during the install i was getting this error in the attachment. Any help on this will be greatly appreciated. I have tried the same clover but it doesn't work. My present clover files are attached as well.




Link to comment
Share on other sites

  • Administrators

If you cannot disable the nVidia card and/or can only run on it, you'll be limited to High Sierra since that's the last version with Web Drivers available. GTX 1070 is Pascal and that's only supported with Web Driver; no such driver since Mojave and there won't be (you can Google for the whole story between nVidia and Apple).


You'd only be able to run Mojave or Catalina on the Intel iGPU and have the nVidia chip disabled through DSDT/SSDT patching in order to save battery life.


Then Catalina needs renaming of the Embedded Controller ACPI device and you're not doing that. See our thread entitled Minimum requirements for Catalina. It's pinned to the Our Picks column on the forum main page.

  • Like 1
Link to comment
Share on other sites

  • Create New...