Jump to content
Tubardus

Dell lattitude 7490: method to install Catalina

Recommended Posts

Hello,

 

I have now Mojave on a Latitude 7490. I would like to know how to install Catalina. Must I follow the tuto made by @Hervé or is there a way to update from my actual installation?

 

For example, do I have to install special kext and launch the update software from Apple?

 

Share this post


Link to post
Share on other sites

If run currently run Mojave or a Catalina beta version, you may simply run the downloaded Catalina installation app and update via that direct route. Clover has fully supported this for years. It's not mandatory to proceed with a fresh/new installation.

https://www.insanelymac.com/forum/topic/340581-macos-catalina-1015-is-out/?do=findComment&comment=2692666

 

Share this post


Link to post
Share on other sites

OK. What I understand is that I must first update Clover to the r5093 and then just update normally from system preferences. Is that right?

 

2/Kaby Lake R/UHD620 Latitude 7490 laptop:

initial OS: Mojave 10.14.6

initial Clover: r4919

Catalina offered through the macOS Software Update panel.

Updated Clover to r5093 before updating macOS.

All Ok on upgrade completion.

Share this post


Link to post
Share on other sites

I felt it safer to update Clover 1st because I was running on a much older version than r5093. But you may use or stay with your existing version, depending on what it is. For instance, I ran Catalina beta with r5035 and r5058 so those older versions than ran Ok for beta releases should be Ok too.

Share this post


Link to post
Share on other sites

I tried to update Clover. It is now on version r5070 (I don't know why it isn't r5093). Nevertheless while booting on Mojave, it won't show the apple and the computer restarts over automatically

 

When I updated to r5070, I checked that the drivers in UEFI where the same, but I'm stuck now. What can I do?

 

Thanks

Share this post


Link to post
Share on other sites

boot with verbose + debug 0x100 to discover the reboot issue

Press the spacebar when you boot to Clover to get those options enable

Share this post


Link to post
Share on other sites

All you had to do, was install r5070 with the exact same settings you had (those listed in my guide). You must have messed up the modules... Re-install accordingly.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...