Jump to content
FaserF

[RESOLVED] Dell 7470 OSX 10.15 Catalina wont boot

Recommended Posts

I have tried to boot a newly created MacOS 10.15 boot stick with catalina on it but unfortunatley I am stuck on the following line (see attachement).

My EFI folder is attached, I have updated all kext files and installed clover 5070 on it. 

MacOS Mojave boots fine with the attached EFI folder.

 

Any help is appreciated.

CLOVER.zip

2019-10-13 15.01.20.jpg

Share this post


Link to post
Share on other sites

Which config file are you using?

 

I understand that the Embedded Controller device of the E7470 is called "H_EC" but can you try and dump your ACPI tables by pressing F4 at Clover's main menu and then search your dumped DSDT (in ACPI/origin folder) for "PNP0C09"? 

 

Then, although it's not going to affect starting up Catalina, your add-on kexts needs adjusting:

  1. AppleBacklightFixup is obsolete and necessary with WhateverGreen; remove it
  2. either use USBInjectAll OR USBPorts_E7470, not both!

Share this post


Link to post
Share on other sites

Hello everybody,

 

i have the same problem, but with another Error.

 

I got to HS with a lot of help from Jake Lo in this old Thread and I liked it. But with a lot of changes in Catalina id like to upgrade. If I stick to my existing EFI just upgraded, Clover and kexts I get a kp after a while.

 

If I try the the Bootpack suggested above I get very soon the attached error.

I attach my updated HS EFI hope you can help me out with that.

 

Thanks a lot for your work!EFI.zip

IMG_8190.JPG

EFI.zip

Share this post


Link to post
Share on other sites

@burzlbaum

Use bootpack from here and then update it for Catalina following my Catalina Update guide in middle of the section

For Bluetooth, you'll need new kexts from Mieze here

You'll need these 3 kexts, remove the old BrcmPatchRAM2.kext from /L/E

  • BrcmBluetoothInjector.kext
  • BrcmFirmwareRepo.kext
  • BrcmPatchRAM3.kext
  • Like 1

Share this post


Link to post
Share on other sites

Thank you very much both of you!

 

With the EFI of @FaserF I was able to boot into macOS and the installation of Catalina worked too. 

 

I have a few questions left:

  1. I still have the problem, that brightening only works after waking up from hibernate. But that's ok for me.
  2. From the moment I hit Hibernate to being able to press the start Button to wake it up it takes 18 seconds. I am pretty sure before the update it was much faster. Restarts take a while too from the moment I hit restart to seeing the DELL logo.  Maybe it has something to do with it?
  3. I have a 7270 with touch Display. Right now the Touch-Display isn't working.

 

//edit BT working perfect after Updating to 10.15.1

  • 5th I installed the 3 Bluetooth Kexte with the Hackintool (btw. is it possible that there is no L/E in Catalina?) but bluetooth works only after hibernate same as brightening controls.

 

I think that's all for now. Already pretty happy maybe you can push me in the right direction?

 

Thanks a lot so far!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...