Jump to content

Dell Latitude D830 Thread


macluscious
 Share

Recommended Posts

I have finally found a good working Latitude D830, my initial plans for converting my D620 were scrapped. D830 have the following configuration:

 

CPU Brand Name: Intel® Core2 Duo CPU T7300 @ 2.00GHz

Motherboard Chipset: Intel GM965 X3100 (Crestline-GM) + ICH8M

Memory: 3GB

BIOS Version: A15

Network Card: Broadcom 802.11g Network Adapter

 

The Problem:

As per wiki suggestions, I created a USB pen stick using the MacOsx method described here. I followed it to the letter. When I booted the D830 via USB stick the OS selection screen appears. Following the install instructions when I select the install leopard option, Apple Logo screen appears with twirling round thingy for a minute or so, then the screen goes black with no activity lights blinking. Initially I suspected there must be some thing wrong with the display, so I connected an external monitor. I was able to see the "Apple Restart your computer" warning screen. I have been repeated the install 3 times more with the same results. I have used the latest bootloader (Ver2-RC5) with extra folder copied on to the usb drive.

So guys what could be wrong here?

(My apologies if I have posted this topic twice)

  • Like 1
Link to comment
Share on other sites

  • Administrators

Hey,

 

Congrats with the new laptop :)

 

Do you happend to have another machine running OSX ?

 

With the latest EDP, you can put it directly on a usb pen a do a build for the usb pen, the problem is that the graphic, also known as x3100 isent supported via the standard boot package - rest asure that we are looking for a permanent solution.

 

Thund3r (Joe) also posted a temp. guide here on the forum for installing on a D630 wich is very similar to the d830...

 

give it a go...

Link to comment
Share on other sites

Hey Leon,

I tried to find a D830 with NVIDIA graphics but unfortunately could not find one. But other then that this machine was in great condition, the owner had hardly used it since he bought it.

I am running Snow Leopard in Oracle VirtualBox Emulation software, yes getting it to work on my i3 H55 desktop was a bit tricky but I did managed to get it up and running, not exactly flawless but still gets the job done.

Thanks for pointing me in the right direction, I think after replacing the Extra folder I have not been rebuilding the package as suggested by Joe. I am not sure how to actually rebuild that but I will definately search the forums for it.

Will keep you updated on the situation.

Wish me luck :D

Link to comment
Share on other sites

After downloading the EDP package by Thund3rbolt here for installing on d630 with Intel X3100 GMA. I created a new usb pen in the similar manner as described in the wiki. The only difference was to use Thund3rbolt's EDP package instead of the standard one provided.

 

The Problem

 

1- The system boots but when I selected the install Snowleopard option, the restart message appeared. Next time I selected the Verbose method, this time the system started to load the files required for the install, but again got stuck with the panic error (picture attached below)

img0112ir.jpg

 

 

2- After rebooting the system this time I selected Ignore Cache method. The kernel panic did not took place this time, instead the system went to load the installer completely. As the program loaded it was unable to detect "TrackPad" as a result I have to use a usb mouse. The install went fine this time, But system was unable to shut down completely the power light was still on.

After restarting the system again selected the boot via USB, from the disk selection screen selected to boot from the hard drive with verbose method. The system boot went perfect, wireless adapter, BlueTooth both worked flawlessly. The trackpad was still not functional.

Next the latest version of bootloader was installed, followed by the EDP rebuild. After the bootloader update and EDP install restart, the restart message keeps on appearing. No matter which method I try I am unable to boot the system.

 

3- I decided to reinstall the Snowleopard again, but this time I am getting no kernal panic rather the system gets stuck at some point (picture attached below)

img0113ek.jpg

 

So guys I am a stuck, what should I do next now?

Link to comment
Share on other sites

Not sure why it's loading natit? I'm wondering .. when you rebuilt .. did you just select 1) rebuild and then A) from existing? Please note if you completely rebuild you will lose the modified extra I created. If it's booting properly from USB simply delete the extra once again, install my files to Extra, delete ioatafamily from /Extra/Extensions and then rebuild from existing. Also repair extensions and clear cache. That's it .. oh and also make sure you have set to ATA and not AHCI.

 

gl bro.

Link to comment
Share on other sites

Guys I have a working D830 finally thanks to you. I will explain in some detail how I was able to do that and the current issues I have.

 

Installation

1- Restored Snow Leopard image onto the USB stick via OSX disk utility utilizing a Snow Leopard running in Oracle VirtualBox.

 

2- Once the Original image was restored, the latest version of the bootloader was installed onto the USB, followed by copying EDP by Thund3rbolt.

 

3- From the boot menu "Boot Ignore Cache" option was selected and Snow Leopard was installed with fresh partition.

 

4- External USB mouse was attached as the trackpad was not working.

 

5- Once the installation was complete, system restarted from the boot menu USB storage device was selected and then "boot ignore cache" was selected again.

 

6- The Snow Leopard was installed completely. Trackpad was still not working.

 

7- Latest version of bootloader was installed, EDP prepared by Thund3rbolt was used. Contents were copied from the Extra folder on the USB to the Extra folder on the Snow Leopard HD.

 

8- IOATAFAMILY.kext was deleted from /Extra/Extensions folder. EDP was rebuilt from exsisting.

 

9- System Cache was deleted with permission repiared.

 

10- MacOSX update combo 10.6.6 was applied.

 

11- System restarted, sound and trackpad was in a working condition.

 

 

 

Sleep Enabled

The sleep was enabled by copying a modified kext (here) to /Library/Extensions folder.

Sleep function works with a 5 second delay. I did not went through the method described on the wiki for enabling sleep.

 

Issues

 

Although the installation went fine and I currently have a working D830 machines which is performing well, there are few issues.

 

1- The temperature are in the range of +55 C when working, but at 44C when idle.

 

2- The external VGA port is not working, once a external monitor is attached the screen goes haywire. The picture is scattered both on the laptop and external display.

 

3- Screen lacks the color depth and sharpness (around 15% is lost), maxmium resolution is 1280 x 800. The crispness is lacking but still not bad.

 

4- Takes longer to shutdown, + 1 minute, screen goes completely black 40 seconds before the machine shut downs with no hard disk activity.

 

5- Processor is Core2 Duo 2.0Ghz but only 1.80 GHZ are being shown.

Link to comment
Share on other sites

Excellent! Don't worry the hard part is over and the rest will come in time. Little by little those issues will vanish as fixes come down the line. Main thing is you have a running Snow Leopard !

 

I too noticed the long wait on reboot. very strange shutdown behavior where your dell will go to purgatory for 30 secs or so. Not sure what that's all about but funnily enough I once had installed slice's bootloader just to experiment with it .. and that abnormality was gone. So it must be boot loader related or dsdt issue.

 

Cheers, and nice Job man.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...