Jump to content

Latitude 7400 2-in-1: no graphics acceleration/Touchpad in Big Sur (OpenCore)


tommyluco
 Share

Recommended Posts

  • Moderators

For graphics, try

Add deviceID = 9B3E0000 

For keyboard, add VoodooPS2Controller.kext

For Touchpad, remove VoodooI2CElan, doubt your Dell's touchpad is Elan, most likely it's Alps. Replace it with VoodooI2CHID.kext

 

 

 

Link to comment
Share on other sites

  • Replies 24
  • Created
  • Last Reply

Top Posters In This Topic

Sadly adding the deviceID does not seem to have any effect.

I thought it might be an issue with the UEFI configuration so I checked out Herves article: 

But that seems to not have changed anything either. 
I want to primarily focus on getting the GPU up and running, so that the system is usable. The rest I don't really care much about as of now.

I have attached the current settings as an image.

I didn't change anything else from my initial configuration except for adding bluetooth support (which works fine)

Also I attached the bootup logs with the change of deviceID-setting set the way as you recommended so maybe that helps to figure out what's going on.

 

 

Thanks a lot for helping me already to get this far
 

Screenshot 2021-05-17 at 16.51.20.png

opencore-2021-05-17-154617.txt.zip

Link to comment
Share on other sites

Hi rgomez, 

 

I second Jake's advice on not mixing OC files. With that said, you may want to take a look at my thread here. Specifically my Voodooi2C kext may work for your trackpad. Our latitude models are similar. 

 

Could you repost your latest graphics card device ID and platform ID as screenshot? something most likely is misconfigured there causing your 7mb issue. 

 

Hope this helps

Link to comment
Share on other sites

  • Administrators

Try and experiment with the various CFL mobile device ids and mobile layout ids specified in the WEG user manual. You may find a combination that works. Failing that, you may also try the settings that applied to 8th gen Kaby Lake R platforms like the Latitude 7490.

 

This being said, there are several people who posted about their Latitude 7400 laptop also fitted with Whiskey Lake i7-8665u CPU. If you run a search for 7400-related threads/posts on the forum, you'll find a few. Afaik, they all had graphics acceleration fully running with CFL layout 0x3E9B, CFL fake iGPU id 0x3E9B and MBP15,2 SMBIOS. You've got to properly configure the properties you inject of course, it clearly was not the case in the last screenshot posted by @tommyluco ("deviceID" instead of "device-id").

 

This particular post is pretty limpid on the matter to me.

Link to comment
Share on other sites

Dear members. Is there anybody out there, who got a Latitude 7400 2-in-1 to work properly with full GPU acceleration on Big Sur?
As far I tried all kinds of settings, EFIs as well as I tried to generate my own from sample on. No luck.
I got the Installer running with an Olarila image and could install Big sur 11.4.
Somehow I found a EFI, which allows my trackpad, touchscreen, audio even the Intel WIFI card to work quite properly - as far tested.
I tried different SMBIOS with different framebuffers, device-ids on and on.

 

I updated and modified my BIOS (1.11.0) to unlock my CSR with:

setup_var 0x6ED 0x00

and set PreAllocated and total allocated settings with:

setup_var 0xA10 0x2
setup_var 0xA11 0x2


Actually I can work on my Laptop but I have no acceleration - only 7MB and my HDMI is not working - not built-in hdmi and not a usb-c -> hdmi dongle (but LAN over this dongle works though). That sucks, cause I need my monitor for work - my eyes are not the best!!

My spec are: DELL Latitude 7400 2-in-1 (5WRVH) with 16GB RAM, Whiskey Lake i7-8665U with UHD 620 GPU and Full HD display
My only modification is a Samsung MZ-V7E1T0BW 970 EVO 1 TB NVMe M.2 instead of the original NVMe shipped with the laptop.

 

I've spent allredy over 4 weeks trying and trying....
I attach my EFI folder and ask anybody who can give me a hint or send me his EFI plz!!!!
Also can give a reward somehow for your spent time!

My EFI:
https://drive.google.com/file/d/1RdjLpXOpBMcKNLkLAaMLCBfa87I-ocul/view?usp=sharing

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...