Jump to content

ASUS X555LJ: no audio or wifi in Big Sur


gmahmoud2
 Share

Recommended Posts

  • Administrators

You're using an EFI made for a different model that may not have the exact same hardware specs as your own particular laptop. You need to identify your audio codec and specify the make & model of your wireless card. Don't hesitate to open up your laptop to look at the label of the wireless card. Failing that, post an IOReg extract saved from IORegistryExplorer app.

Link to comment
Share on other sites

  • Administrators

I understand that ALC3236 codec is ALC233; look that up in the AppleALC wiki and experiment with the various layout ids listed.

https://github.com/acidanthera/applealc/wiki/supported-codecs

 

Re: AR9565 wireless, those were never natively supported and required a specifically re-written Atheros40 kext. Then, performance was not great. Knowing that you'll probably have trouble getting this card to work under Big Sur, it'd be far better to replace it with a fully supported M.2 model. You can check these out in our wireless cards inventories and our M.2 wireless cards inventory, all available in our R&D->Wireless section.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...