Jump to content

Dell Latitude 7490: building OpenCore EFI for Big Sur


Recommended Posts

Hello everyone. I'm new both in this webpage and in the hackintosh community in general.
I tried to install Big Sur on my Dell Latitude E7490 7490 using the OpenCore 0.7.0 EFI Folder for a Dell Latitude E7470 at the very bottom on the followin link:


As you can imagine it did not work. But I was hoping that since E7470 and 7490 are very similar laptops, adapting one for the other would be easier than starting from scratch.


Would any of you please guide me on how to adapt that EFI Folder (OpenCore 0.7.0 for E7470) for my laptop (E7490 7490)? I would like to learn, so that in the future I can hackintosh any other PC, but if it is too dificult, let's be honest, I'm far from being a technology expert, I would be thankful if you sent me the proper EFI folder.
In case it helps, here are the main hardware parts:

Processor: Intel i7 8650U 
Intel Bluetooth
Intel Dual Band Wireless-AC 8265
Intel UHD Graphics 620
Realtek Audio

Thank you very much in advance.

Link to comment
Share on other sites

  • Administrators

It would be a mistake to believe that the E7470 and the 7490 are "very similar laptops". They're not. Former is a 6th gen Skylake model and latter is 8th gen Kaby Lake R model. They're of different generations and use different CPUs, different chipsets, different iGPUs, different audio codec, etc. Afaik, the only pieces of hardware they have in common are the Intel GigEthernet card and the Realtek SD card reader.


Your may create your 7490 OpenCore setup from an existing E7470 one but you must extensively modify it of course. At this point of time, given your stated skill set, I would recommend you use the following process instead:

1) follow the Dortania Opencore guidance for Kaby Lake R laptops

2) grab the last Clover pack I posted in my Latitude 7490 guide and adjust your Opencore setup accordingly (patched tables, properties injection, kexts)


Failing that, I believe there are several copies of Opencore EFI folders for Big Sur available in various existing 7490 threads. Here for instance.

Link to comment
Share on other sites

Thank you @Hervé!
I downloaded the OpenCore EFI folder you suggested me from this link. It got stuck at the screen with the Apple logo :-(
So I gathered courage and followed Dortania's guide for Kaby Lake Refresh, manually creating the four SSDTs.
After the OpenCore picker shows up in which I chose the installation USB, the verbose began with tons of text rushing through the screen until it got stuck on the state shown on the attached picture.
Any help you can provide me? Looks like something is wrong with the USB right? I am using USBInjectAll kext since the guide said it shouldn't be needed on DESKTOP Skylake and newer... Should I delete it?


Edited by VRdP
Updated with new tries
Link to comment
Share on other sites

@Jake Lo I've seen in many threads valuable help from you too.

I tried the EFI Herve recommended my from Swung0x48 and preparing my own following Dortania's guide, manually editing the 4 SSDTs.
Have you got any ideas on how to get to boot the USB installer for Big Sur with OpenCore on my Latitude E7490?
Thank you.

Link to comment
Share on other sites

Thank you very much, @quynkk5!
I am attaching the DSDT dumped from my Latitude E7490 which is the one on which I am trying to install Big Sur right now.
Do you think there is something wrong with the SSDTs and you are going to create and send me the correct ones?

I am planning on hackintoshing a couple more computers, so if you could help me understand how to prepare correctly the SSDTs, I would much appreciate it. In case it is too complex for a proper explanation or a couple of links to read and learn, would you please also help me with the Latitude 3390 I'll try to hackintosh right after the 7490? I am attaching the dumped DSDT of the 3390 too.


Once again thank you very much!

DSDTs Latitude E7490 and 3390.zip

  • Like 1
Link to comment
Share on other sites

I tried to follow Dortania's guide in order to create the 4 suggested SSDTs, but the USB didn't get to the install/recovery, it got stuck on the screen I showed on a previous post.
To be 100% honest, I don't know what DSDT patching is, but I don't think it's what I did. Probably there's some mistake on my SSDT then, right?

Link to comment
Share on other sites

Thank you very much @quynkk5!!
Unfortunately I've tried both of the EFI folders one on the E7490 and the other on the 3390, and in both cases the same happened:

- Picker appears

- Selected Reset NVRAM

- Reboot - picker appears for a 2nd time
- Selected the installation usb drive

- Panic (see picture)

Any clue on what may be wrong?

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...