Jump to content

HP 840 G3: OpenCore 0.7.4 EFI not working


Recommended Posts



I'm trying to make a clean install on my HP 840 G3 using your opencore 0.7.4 efi folder. The problem is that the opencore menu only shows the "reset nvram" option, and not the installer. I've tried with big sur and monterrey too, with the same result. If i just replace the efi folder with the 0.6.8 version the big sur installer boots correctly. Any ideas? I'm using a broadcom wifi card, with the normal config plist (not the intel one).


Thank you

Link to comment
Share on other sites

Thank you for your help.


I've used the entire EFI folder from this thread including the config file, I just replaced the serial number, UUID, etc with my previous data. I have tried using the config file "as is" just in case I made some mistake editing it, but I'm having the same problem.

Link to comment
Share on other sites

  • Moderators


For OC 0.7.2 and up

UEFI > APFS: Increased default APFS MinDate and MinVersion to macOS Big Sur for better security. These keys are the minimal allowed APFS driver date and version to be loaded. Examples:
- MinDate and MinVersion 0 is default (currently Big Sur), leave this value if you are using Big Sur or Monterey
- MinDate=20200306 and MinVersion=1412101001000000 is for Catalina 10.15.4 (19E287)
- MinDate=20190820 and MinVersion=945275007000000 is for Mojave 10.14.6 (18G103)
- MinDate and MinVersion -1 is disabled (not recommended).
It's required to change MinDate and MinVersion in the APFS section for macOS versions older than Big Sur.


Try setting MinDate and MinVersion to -1

I have been running Monterey with MinDate and MinVersion = 0 without issue 

But have to set MinDate=20200306 and MinVersion=1412101001000000 for Catalina when using OC 0..7.4

Link to comment
Share on other sites

Thank you. Originally it was set to 0, and i've tried with -1 for both with the same results, the installer does not show as an option and I only see "reset nvram"


I've managed to make it work doing the first installation part of Monterey with an older opencore version, and then replacing it with 0.7.4 to boot again and finish the installation. However, the installer option still doesn't appear in the selection menu.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...