Jump to content

ELAN, FocalTech and Synaptics (Smart Touchpad) Driver (Mac OS X)


Recommended Posts

try connecting a usb mouse and see it the prefpane works

 

Thanks for your response.

 

Tested with USB mouse too and it still is blank. Could you please let me know if I need to install anything outside of RehabMan VoodooPS2Controller.kext and ELAN kext 4.0.5 and SmartTouchpad 4.6.5? I tried installing them in EFI/Clover/Kext folder too.

Link to post
Share on other sites
  • Replies 1.5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Last update: 17 Sep 2017   UPDATE: 17 - 09 - 2017 Just wanted to clear few things about my commitments to community, and development on my projects which has been going slow due to my personal life

@EMlyDinEsH It's been more than 2 years since last update of the kext and about 1,5 year since last update of the first post. Can you finally release the source code, so someone could finally improve

macOS Sierra: some Fn keys do not work and trackpad work only as mouse. Please fix.

Posted Images

Installed only SmartTouchpad, PrefPane is still blank. Two finger scroll from left to right works but not the other way. Also, 4 finger tap to make an app full screen does not work. 

 

The PrefPane is no longer blank if I load the 4.7.5 Beta kext but there is a huge a discrepancy between the options in the PrefPane vs the actual behavior.

Link to post
Share on other sites

Hiya all, hope someone can help me out with a small issue I'm having. 

 

I've installed 4.7 beta 5, along with the Asus Fn keys kext, and although most things work nicely, any shortcuts involving the letter 'P' now don't work...

Oddly enough it seems to only occur if I enable the 'swap windows and alt'/swap them via system preferences. Possibly something lower level hijacks the combo if it involves the windows key?

 

Just wondering if anyone else has this?

Link to post
Share on other sites

With my Asus N752VX laptop, the touchpad works flawelessy! (ELAN1000)

 

But my keyboard doesn't. I've got some trouble understanding the config file of the keyboard.

My keyboard is not detected automatically, and It might be interfering with the USB dongle for my mouse.

 

I do have Karabiner installed to adjust the keyboard layout manually. I have it disabled when using the driver though.

 

sudo dmesg | grep -y std is empty, but the driver is loaded since I've got advanced touchpad functionalities.

Link to post
Share on other sites

Hi everyone,

i'm new user of this forum, and have problem with my touchpad ...not function , i have tried many kext but without success .

 

my computer specs are

ASUS F540LJ - 4 GIGS 1600 MHZ DDR3 - INTEL CORE i3-5005U @2.0GHZ - HD5500 - ALC 255 - Atheros AR9565 AR3012 - macOS 10.13.0

 

Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...