Jump to content
EMlyDinEsH

ELAN and FocalTech (Smart Touchpad) driver Issues

Recommended Posts

Awesome  Job dude !! V3.8 works awesome on Asus Q550LF with Elan V4,  however i have one question and don't know if it's normal.  It possible to change the delay that has when your a typing and then quickly want to move the mouse pointer ?  I'm having like 3~5sec delay,  If so where it's the function on plist ? 

Share this post


Link to post
Share on other sites

Awesome  Job dude !! V3.8 works awesome on Asus Q550LF with Elan V4,  however i have one question and don't know if it's normal.  It possible to change the delay that has when your a typing and then quickly want to move the mouse pointer ?  I'm having like 3~5sec delay,  If so where it's the function on plist ? 

 

You can control that delay by editing AccidentalInputTimeOut value in plist. There is a new update coming this week which will improve many features and fix bugs.

Share this post


Link to post
Share on other sites

You can control that delay by editing AccidentalInputTimeOut value in plist. There is a new update coming this week which will improve many features and fix bugs.

 

 

this update is beyond that beta with the sleep fix you did it for my machine?

Share this post


Link to post
Share on other sites

this update is beyond that beta with the sleep fix you did it for my machine?

Yes, this new update has many changes to the some of the features and bug fixes. I'll update the post asp with all the details.

Share this post


Link to post
Share on other sites

Hello,

 

Really appriciate your work, thanks!

 

I just have a bug on my Asus K43Sj laptop everything works great but the keyboard does some weird things.

My numpad is on the JKLMUIO keys and after installing i have to hold the Fn to write character, normally it only writes the numbers as a numpad. I have installed 3.5

Share this post


Link to post
Share on other sites

You can control that delay by editing AccidentalInputTimeOut value in plist. There is a new update coming this week which will improve many features and fix bugs.

Ohh didn't know that was the accidental input.  After a week of usage I notice also tha sometimes when I left click something there is a delay on pointer to start moving again, but it's not always it's kinda unpredictable, that is controlled somewhere ?

Share this post


Link to post
Share on other sites

Ohh didn't know that was the accidental input.  After a week of usage I notice also tha sometimes when I left click something there is a delay on pointer to start moving again, but it's not always it's kinda unpredictable, that is controlled somewhere ?

 

wait for my new update which might solve your problem as there are many improvements and bug fixes. If you still have the problem in my update too that then PM me about your problem and i'll take a look.

Share this post


Link to post
Share on other sites

Hello,

 

Really appriciate your work, thanks!

 

I just have a bug on my Asus K43Sj laptop everything works great but the keyboard does some weird things.

My numpad is on the JKLMUIO keys and after installing i have to hold the Fn to write character, normally it only writes the numbers as a numpad. I have installed 3.5

 

Well, its not a bug and seems like your problem is related to NumLock (which was changing these keys to function differently in some keyboards for others before and made me to lose huge amount of time to debug the driver and finally figured that its just NumLock function of that keyboard) which is turned on by driver. So, disable this in keyboard plist and install kext (or) manually toggle the NumLock key.

Share this post


Link to post
Share on other sites

First of all, thanks for all your work, almost everything works like a charm ;)

 

I have one issue, I managed to make fn+ insert/Start work in my lenovo g580 keyboard using a dsdt patching method.

 

When I install elan v3.8 this feature seems to be overwritten by this kext features, and I don't know how to ignore them (only brightess features).

 

I've read all the related threads but can't find it... What am I missing? Any help?

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

With the last 3.8.5 version, I've got constant computer reboot. It can take up to 5 minutes, sometimes less than 20 seconds... So bad as I felt that mouse precision is better, I've got no more mouse jump when I want to close a window. But I also encounter issues with scrolling (more link to the need pression I have to put on the touchpad to have this one working - certainly link to your new palm pressure option and need some ajustement in config.plist from me).

 

Sadly, I cannot test more due to reboot, so I switched back to 3.8 release.

 

I've got an Asus UX32LN, with Elan V4 and software buttons. If you can explain me how to help you (and me) on this topic, with certainly some debug session, it will be a pleasure !!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...