Jump to content
EMlyDinEsH

ELAN and FocalTech (Smart Touchpad) driver Issues

Recommended Posts

Dell XPS 15z, Synaptics touchpad.

Unsupported touch found in logs.....

Only mouse mode.

no chance?

 

PM me your system.log with my kext installed, so i can take a look. My kext works only if you have firmware v7.5+ for synaptics.

  • Like 1

Share this post


Link to post
Share on other sites

Hi EMlyDinEsH. I am using your Smart Touchpad on my Elan deivce. It works well. Thanks very much.But FN + F2 do not work. It should enable/disable  WiFi/BT. I have patched DSDT by your Asus DSDT patches (WiFi BT Toggle Patch (4 toggles) or WiFi BT Toggle Patch (2 toggles)). My laptop is Asus Fx50JK. I used ApplePS2SmartTouchPad.kext and AsusNBFnKeys.kext.

Share this post


Link to post
Share on other sites

Thanks for the great kext. I am using it on my elan touchpad.

 

Is there a way to disable it when a mouse is connected?

 

I have tried the 'Ignore built-in trackpad when mouse or wireless trackpad is present' option in accessibility/mouse&trackpad but OS X seems to think its external? the option doesn't have any effect(it does get rid of menus in system preferences/trackpad).

 

if not possible, is there a way to map a key to disable/enable it?

 

thanks.

Share this post


Link to post
Share on other sites

There is a problem with the keyboard driver. If the override button places (option and command), then stopped working to adjust the brightness.(Fn - F4,F5). What can be done?

Share this post


Link to post
Share on other sites

selecting "Ignore built-in trackpad when mouse or wireless trackpad is present" has no affect, touch pad still active. don't know if it's my mis-config or the driver don't support this.

Elan touchpad  , SmartTouchPad_v4.6.

Share this post


Link to post
Share on other sites

Hi, @EMlyDinEsH

first thanks for your great work!

I have a thinkpad x1 yoga laptop,

the issue i'm facing is that the left,middle right buttons which is above the trackpad are not working see the pic below:

 

https://www.dropbox....padTrackpad.png

 

I noticed that pooch5150 on post #712(https://osxlatitude.com/index.php?/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/page-73?hl=thinkpad)also used thinkpad laptop but he didn't mention any button problem
I hope there's a solution to fix it
 
thanks!

Share this post


Link to post
Share on other sites

Hi EMlyDinEsH, How are you?

 

I am one of a *big* fans of your ApplePS2SmartTouchPad.kext on Dell Precision M3800/XPS9530. The longer I use this driver the more I get impressed by it. 

 

With the latest v4.6, I cannot wait to test it on my M3800, works great except v4.6 ApplePS2SmartTouchPad.kext sometimes lose response. The issue mention above has occurred in several scenarios:

1. TouchPad lose response upon sleep

2. TouchPad lose response suddenly during use

3. TouchPad lose response from startup 

 

All the three scenarios can be fixed by a simply reboot, but v4.5 has no such issue. 

I have tried to change value of DisableTPadOnLIDClose to see if this can solve the issue[see here], but no luck:(

 

In Sierra, ApplePS2SmartTouchPad cannot perform the function keys normally. And also, I have to enable "SysPref/TouchPad/clicking" each time booting into Sierra to make the touchPad perform clicking normally. 

 

Here's my log, ioreg and modified Info.plistlog_and_ioreg.zip. I will provide what you want to figure out the issue. 

Again, thanks for this great project, the best TouchPad kext for M3800/XPS9530 I have ever seen! !

Best wishes,

syscl

Share this post


Link to post
Share on other sites

Hey there :)

 

Can´t seem to get my Touchpad to work :/

I removed all the kext´s mentioned in your first post.

Installed it with kext utility and rechecked permissions. 

Using driver version 4.6; El Captian 10.11; Acer E1-571G

 

Tried to use Fn Key Mode 2 (Shift Caps + F9) but nothing.

 

My keybord works and all seems well when booting in verbose:

- Enhanced Apple PS2 Controller and Keyboard driver v4.6 .............
- Initializing keyboard ...
- Keyboard echo success.
- Keyboard enabled.
- Smart PS2 Touchpad v4.6 Copyright (c) ...........
- Detecting the touchpad ........
- ELAN touchpad found, Hardware version 3 (Firmware version 0x450f01)
- ClickPad? No
- Capabillities query result 0x68, 0x15, 0x0a.
- Touchpad ranges are X_min 0 Y_min 0 X_max 2508 Y_max 1056, CenterX 1254, CenterY 528.
- Touchpad enabled.

I seen some guy here getting it to work so what am I doing wrong?  :?

Share this post


Link to post
Share on other sites

Hi, gentlemen. Often, rapidly double tap by 1 finger doesn't work (for example select word in text) and I need either to tap slower or to tap rapidly 3 times. Is the way to correct this behavior in plist (ver 4.6, synaptic)?

Share this post


Link to post
Share on other sites

I've got multiple problems:

 

1st:

everytime the system wakes up (bootup, suspend to ram, ...) there is a 30% chance, that the keyboard OR the touchpad stops working. Sometimes it just breaks the left click... It's pretty rare that both breaks down completly at the same time. Only solution found so far is a reboot (or hard power down). Is this a common problem?

 

EDIT: used the new version 4.6.5 and changed the sleep value to 2500ms. Bug didnt appeared anymore, but cant say if it's fixed, yet.

 

2nd:

i cant get forward or backward gestures to work. i already switched to ISO and added the keyboard code (0x30 for german)... only get the "unknown command" beep.

 

any clue how to fix these?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...