Jump to content

ELAN and FocalTech (Smart Touchpad) driver Issues

Recommended Posts

hello. I'm using msi ge60 2pl apache laptop and using applepd2smarttouchpad ver4.7 beta5. I checked in window manager. it show my keyboard is ps/2 keyboard. ur kext worked for me, but is there any way to use Fn key as normal keyboard (not using shif+caps lock)?

your set up with sift+caps lock + key is perfect. but when I'm using fn+F3 or special key from my keyboard it alway turn on/Off sound. or when I press Fn F6 to turn on/off my camera, it alway become brightness up.
hope u help me fix it. thank you very much (and sorry for my bad English)

I hope new update will have an option to make fn work as shift + caps, so we can chose method to use shift + caps or fn or contex menu


PS: my keyboard look like attached. fn+f3 and special key which have yellow led alway turn on/off sound. fn+f4, fn+f6 alway become up/down brightness. fn+f10 not work but it not important. fn+f12 worked. all of another working perfectly.



Link to post
Share on other sites
  • Replies 615
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi everyone, I've started this thread in order to know the bugs in my driver, so please post your issues here and I'll try to fix them asp. You may sometimes not receive answer from here, so try to P

@everyone, new update for my driver is coming this week which is a major update and will fix everything mostly. Just wait for that update meanwhile don't use v3.8.5 and go for old versions if you have

Ok, I'll look into this and upload a new one as soon as possible. May be some two finger features I was working could have ended up on this release to make this unstable. Sorry, for uploading an unsta

Posted Images





I have an Aero 15x V8 Laptop with an Elan PS2 Touchpad. I'm on High Sierra 10.13.5

I use this driver which works with my trackpad and allow to access Sysprefs>Trackpad Options.


However, i have 2 issues : 

-The trackpad often freezes for 1-2 seconds, especially after clicking but not only.

-The options made on Sysprefs>Trackpad are working but not upon reboot. (For example if i check double finger tap=contextual menu, it works. But upon reboot it doesn't work anymore. If i open Sysprefs>Trackpad, the option is still checked. If i uncheck et recheck the option, it works again... until reboot).


I've tried v4.5, v4.6.5, v4.7 beta 5


Anyone having the same issue? Any idea on how to resolve this?


Link to post
Share on other sites

i finished install mojave all things work ,but when move pointer by tarkpad or mouse
i see not sensitivity and inexactness and Deviation in motion


i am used app cursersence for make mouse and tarckpad better 
my mose is better now 
but i cant found tarckpad in list devices in app to change setting for it 
plz help me


my laptop hp probook 450 g5 i7

pad: Synaptics HID ClickPad

        Hid complaint mouse

        PS/2 Compatible








Link to post
Share on other sites

Hello I installed catalina using opencore. if i apply applesmarttrackpad kext touchpad shows in preference but keyboard and trackpad both won't work and if i use voodoops2 only my keyboard works, my touchpad doesn't work. i have elan touchpad. Please help.......... 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...