Jump to content

D430 lion 10.7.x failing to get to initial setup screen


Recommended Posts

Hello OSXlatitude community- Newbie here. Got a cheap D430 from a craiglist - Found your site and decided to try it out as my first Mac (physical). After 2 weeks of frustration, not getting anywhere so hope someone else there can help!



Cannot get to initial setup screen


Steps I followed

1. Configured my bios per


2. downloaded myhack 3.3.1

3. downloaded bootback for 10.7 (confirmed my bios shows cpu is intel core duo)


4. Created boot usb using the above along with OSX 10.7.5 image (also tried 10.7.4, 10.7.2 and 10.7)

5. Replaced /extra folder with the contents from bootpack

6. Installed OSX using usb stick, selected to install extra from "my own" and selected the extra folder on USB stick

7. rebooted, but got kernel panic screenpost-52979-0-83678800-1393107811_thumb.jpg

8. tried replacing extra folder with one I found in this thread and re-ran myhack / reapplied extra


9. reboot, getting this screen. (just stays there forever)


10. It does boot to setup screen if I use safe option (-x), but then network/mouse/kb is not found.


Any help would be appreciated.

Link to comment
Share on other sites

Thanks for the quick reply

- Removed wireless card - no difference

- Booted up using usb keyboard, completed setup, rebooted then getting stuck at same point.

-  Removed contents of extra folder on boot usb and replaced with contents of D430_extra_lion.zip, got this screen


- Found this thread


which suggested to replace AppleBCM5751Ethernet.kext in extensions folder which I did

- Booted up again using -v option, did see that it associated the ethernet card with a MAC, but immediately was brought to a blank screen with a white cursor on upper left corner, which then just sits there (for the last 10 min already), which makes it difficult to determine next step to troubleshoot....

Link to comment
Share on other sites

  • Administrators

i would start all over with the bootpack I gave you (it has the correct Ethernet kext by the way). Redo your USB installer and make sure to re-run myHack at the end to install the bootpack to uour USB installer with "install Extra".

Link to comment
Share on other sites

Update - rebuilt boot stick from scratch, replaced extra folder with d430_extra_lion above, ran myfix.


-  Boot stick got stuck at the same point (network card issue) when using the above d430_lion_extra bootpack. I redownloaded the D430_Extra_Lion bootpack- The AppleBCM5751Ethernet.kext is definitely the 655k one which I believe was the universal one/not recommended per the other thread.



- Replaced the kext with the 134k one from the other thread. The bootpack now gets past the NIC (gets MAC), but goes to a blank screen with cursor on upper left.


So good news is that the behavior is consistent at least. As for next steps- Unknown.

Link to comment
Share on other sites

Try this pack...



Thank you Hervé!!


I spent too much time trying to follow the instructions using MyHack + bootpack on the compatibility page.  I spent hours reading this forum to figure out why I was not able to get the boot screen on my D430 when trying to load Lion 10.7.


Only after loading your zip file of Extras was I able to get it working.  I'm not sure what is different between this zip file and the bootpack, but it worked.


So thank you very much.


PS: After succesfully booting up, it displayed the screen that said it could not detect a keyboard but trackpad did work.  I had to plug in an USB keyboard, then didn't need it again.  

Link to comment
Share on other sites

Thanks for the file. I tried this one as well and it has the same issue as the one provided above (repeated NIC errors, and if I replace the AppleBCM5751Ethernet.kext with the smaller one, then it gets past the NIC error but then just goes to a blank screen. I got a picture of the screen before it went blank (see attached). The only thing that looked like a critical error was


Super IODevice: [Fatal] found unsupported chip! ITE sequence ID=0x2803, Winbond sequence ID=0xffff


Repeated once


Found this thread which mentions this



I checked the contents of fakesmc but only see these items (no mention of the kexts in the thread)







I can try to remove these one by one but they all seem mandatory.


Link to comment
Share on other sites

  • Create New...