Jump to content

Dell E6420 with Nvidia Nvs 4200M on Mavericks


veedub89
 Share

Recommended Posts

I have the 6420 with the nVidia 4200m(specs in sig).  UEFI and Optimus turned off, and AHCI enabled in BIOS.  I have tried using Nolen's Extra pack when installing with MyHack and kept getting KPs from AppleIntelCPUPowerManagement just booting from the USB.  Went back and made an installer using just the generic extra.  Installer booted fine, and I got Mavericks installed and updated to 10.9.2.  Tried using the Extra folder again, and still got the same kernel panic.  So, I reinstalled and I have been trying out all the kexts one by one without the DSDT from the pack as I assume that it wont work with the nVidia chip.  They all work for me except AppleIntelCPUPowerManagement.kext(KP), and AppleHDA.kext(no audio).  I do have the NullCPUPowerManagement.kext for now from the generic MyHack install.  I can get audio with the latest VoodooHDA, but cant adjust the volume except directly in the app.  I also do not have any volume on the HDMI out line.  Sleep seems to only be a display sleep no matter how I have set the hibernatemode.  The power button light stays on, and the fan continues to run, I just do not have a picture on the display.  No lid sleep either(video stays running).  VoodooSDHC works when I installed it after checking for sleep issues.  I have a SSDT created from Rehabman's probook installer.  And I have created a vanilla DSDT in DSDT Editor.  Any ideas of what I can do to modify the DSDT like the one you guys have for the HD3000?  Maybe a reference to the edits that were made to get things working?  I am a noob when it comes to editing the DSDT, but not afraid to get my hands dirty.  Or am I going about this the wrong way?

 

Working

Wifi & Ethernet

Keyboard

USB

Bluetooth 

App Store and iMessage

Battery Percentage

Display and Screen Resolution

QE/CI

Audio (no control though)

HDMI (Auto Detection works) no audio out.

Network Switch

eSata

SDHC Card Reader

Trackpad (2 finger scroll)

Webcam

 

Not Working

Screen Brightness(using Brightness Slider app from App Store for now)

No Audio Control

No HDMI Audio out

Sleep(seems to be only a display sleep)

Link to comment
Share on other sites

  • Replies 60
  • Created
  • Last Reply

Top Posters In This Topic

Sorry to not respond to your post. The nvidia model is slightly different and Jake Lo knows how to get tha model working.

 

Hmmm. That KP you refered to, a couple people are having it and I cant figure out why. Will look into it.

 

Try my org.boot.chameleom.plist and the applehda in my bootpack. Run myfix quick and reboot, should fix audio.

 

Sleep wize, as stated above, Idk if it is possible or not...

Link to comment
Share on other sites

When I bought this laptop, it was listed with the HD3000.  When I dug deeper it had the nVidia, but for the price I paid, I couldn't turn it down.  Sleep is not a major issue for me, but would be nice to have.  I've been running hackintoshes for this long without it on my other machines so no biggie.

 

no luck with the audio.  Greyed out speaker.  No output devices are found in the Sound Preference Pane.  Even made sure there was no AppleHDA kext in S/L/E to interfere.  I had tried your plist earlier when I tried your AppleHDA, and it didn't work then either.  Tried again just now, and its still a no go.  Checked the chameleon plist and made sure the HDA Enabler is checked in Chameleon Wizard and it is.

 

System Info app shows 2 audio controllers. 

Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller Ven Id:8086 Dev Id:1c20

Nvidia GF119 HDMI Audio Controller Ven ID:10de  Dev Id:0e08
Link to comment
Share on other sites

I am using Chameleon 2.2svn r2377.  HDAEnabler= yes is in my boot plist.  And I am already updated to 10.9.2.  I've tried both AppleHDAs that queper mentioned.  The first  AppleHDA is version 2.6(same as in Nolen's), and the second one that he posted was version 2.5.2.  I first tried them individually in E/E, and then tried them in S/L/E, as I have had problems in the past with VoodooHDA not working in E/E but did work in S/L/E.  I think my next test will be to reinstall the whole system, not update to 10.9.2, and work specifically with those kexts first to make sure there is no other conflicts, or something has been wrongly modified when I installed the voodooHDA.  I'll keep you guys updated on the progress.

Link to comment
Share on other sites

  • Moderators

Use guide here for the nvidia system and bootpack, but update the AppleHDA. No need to rebuild your system. Just launch myhack.app from application. Select install Extra, select your system as the destination and bootpack as the source. Sleep is not capable in this setup.

Question:

Is your system vpro or non-pro. If it's non-vpro, you could try this guide and bootpack. This has DSDT to turn off nvidia which allows sleep with HD3000.

Link to comment
Share on other sites

Thanks Jake!!  Your first link worked like a charm.  I was going to be reinstalling anyways, as I went and bought a Samsung EVO SSD.  Didn't have to update the AppleHDA, as it came with VoodooHDA, and it just worked.  I got the volume controls back, and the buttons on the side of the keyboard work.  One thing I did find, is that the trackpad wasn't getting detected in System Preferences, although I could use the trackpad.  So, I removed the AppleACPIPS2Nub.kext, and ApplePS2Controller.kext, and replaced them with VoodooPS2Controller.kext ver 1.8.9 and got the trackpad settings back in System Preferences along with multi-touch.  The DVD player app didn't work, but I saw your fix in the second link, and that worked.  Along with the fix for enabling Trim for SSD drives, just had to take the kext from that pack, and put in my Extra folder.  Still no HDMI audio out, no brightness adjustment through the keyboard, and as expected no sleep.  No biggie though.  At least it's a very usable setup, and one that I can live happily with.

 

Not sure how to tell whether my cpu is vpro or not.  Mine is the 2.2 GHz i7-2720qm.  I did try it out anyways.  Only thing I changed was the boot plist, and renamed IOAHCIFamily.kext to enable Trim support.  I just added the -v flag, and edited for my 1600x900 display.  It did seem to boot just fine, except it had some screen artifacts showing up when I got to the desktop.  If I moused over them they would go away, but it was still unusable.  Not sure where to begin to troubleshoot that.  Didn't even attempt to check anything else.

Link to comment
Share on other sites

  • Moderators

Check out the E6520 guide in my signature. Now it supports optimus and allow sleeps. Of course, then you won't have HDMI working. Works for both non-vpro and vpro, jus have to use the correct SSDT files.

Link to comment
Share on other sites

No luck.   Got an error saying it was unable to patch the video bios.  I used the correct SSDT for my processor, and I tried with both DSDTs as I wasn't sure if I had dual link or single link.  I also double checked the BIOS to make sure that the Optimus was enabled.  Same error showed up for both.

Link to comment
Share on other sites

 Share


×
×
  • Create New...