Jump to content

Clover on Dell T3500


Recommended Posts

Hi All,


I've installed 10.9.3 using myHack and Chameleon on the Dell T3500 desktop (see my signature for specs).

It's running pretty sweet.


Has anyone got Clover running on this machine? I've tried creating a Clover usb to test as per Clover wiki but getting a boot1f error.





Link to comment
Share on other sites

Hey Robert,


Twas actually your wiki that inspired me to get a T3500 :-P Thanks, and also for sharing your config.


I do have a few more questions - particularly in reference to your Mavericks install -


(1) are you using a DSDT? If so - how did you generate it?


(2) Where did you install the BCM5722D.kext? I put mine inside the Contents>Plugins of IONetworkingFamily.kext and it seems to be working ok - although there may have been a glitch once with intense LAN and WAN activity where ethernet seemed to stop working - but returned after reboot.


If this is the right place for the kext - it may be good to amend the wiki.


(3) Have you got the front headphone jack working - if so how? I'm using Voodoo HDA 2.8.5 and Voodoo Setting Loader - got rear line out but not front headphones.


(4) Re: Clover - you're saying we should use the guides for Legacy BIOS? From the pic for custom install of Clover → you didn't install 64 drivers at all, only the 3 from Drivers64UEFI?


Many Thanks!

Link to comment
Share on other sites

Hi dm4n,


Glad you liked the wiki - it doesn't get much traffic but I wanted to share what I was able to figure out. To answer your questions:


1) I am not using a DSDT. I tried to generate one that would fix the sleep issues but never succeeded. Everything else seems to work properly without one.


2) The BCM5722D.kext should be installed in System > Library > Extensions. If you use Kext Utility to install it for you, that's where it will end up. Be sure you're using version 2.3.5 - other versions will lock up if network traffic gets heavy.


3) The front headphone jack is working for me with VoodooHDA.kext version 2.8.4. I had some problems with version 2.8.5 not adjusting the volume correctly. That might also be causing the problem you're encountering with the front headphone jack.


4) I don't have a lot of experience with Clover - I only used it because it is currently the only bootloader that works with the developer preview of Yosemite. The settings is the screenshot worked for me as long as I also used the config.plist attached to my previous post. I'm pretty sure this is a standard Legacy BIOS install for Clover.


Hope this helps. Let me know if you encounter any other issues or have anything that ought to be added to the wiki.

Link to comment
Share on other sites

Hey Robert,


Thanks for answering my questions :)


On a whim I plugged in my headphones to the front jack - as expected no sound or even typical noise. Checked settings in VoodooHDA Settings in System Preferences and made sure that Headphone Front was selected in the Sound section of Sys.Prefs too - to no avail.


But, when I clicked on the volume slider for the headphones in Sys.Prefs - the headphones suddenly began to work :-o even though the slider was already more than halfway toward max. voluume.


Also, I had the same issue you described with VoodooHDA failing to recognise volume change initiated from the top menu bar - I'm sorry I don't recall how I solved that - but am running 2.8.5 with Voodoo Settings Loader Preference Pane in Sys.Prefs and all volume controls (including in Apps and Menu Bar) work.


Re the BCM5722D.kext - the version in my Extensions folder was 1.0, and today I again experienced ethernet shutting down with high traffic - so I installed the version 2.3.5 you specified → interestingly, Kext Utility installed it in Contents > Plugins of IOnetworkingFamily.kext


A question about your GPU - is it fully recognised and did you have to patch anything? I'm running the ATI5670 and it seems to be working fine oob - DVD Player and Chess work (QE/CI?) but only shows up in About this Mac as ATI5000.


I'll post again after I run some tests booting from Clover usb.


Cheers 8-)

Link to comment
Share on other sites



Glad you were able to resolve the audio issues.


Strange how Kext Utility installed the BCM5722D.kext inside your IOnetworkingFamily.kext. I just looked at mine again and it is definitely in the main System > Library > Extensions directory and nowhere else. Just leave it alone as long as it loads properly, I guess.


My GPU (ATI Radeon HD 6670) was recognized correctly without any patches. QE/CI are all working smooth and everything renders as expected. It shows up in About this Mac as "AMD Radeon HD 6xxx 1024 MB" For what it's worth, the specific card I have installed is the HIS iSilence 4 H667PS1G Radeon HD 6670 1GB 128-Bit DDR3 PCI Express 2.1 x16.


Interested to hear how Clover works with your Mavericks installation.

Link to comment
Share on other sites

Update: Successfully made a Clover usb bootloader using the suggestions from Bronxteck amd Robert Smith.


The system boots up from the usb and was able to successfully update iWork and iLife apps (which didn't work using Chameleon).




(1) Format usb as 1 partition HFS using GPT option and name it


(2) Install Clover on the usb (I used Clover_v2k_r2747) using the screenshot from post #5 to set installation parameters


(3) Insert FakeSMC and NullCPUManagement kexts in EFI > Clover > kexts > 10.9 on the installer usb (just manually copy > paste kexts from existing Mavericks S/L/E and Extra folders)


(4) Replace config.plist in EFI> Clover with the one from post #3


(5) Boot from usb using bootflag -v


Thankyou all for your kind help :)


Having tested, the next step is to make the switch to Clover from Chameleon.

Link to comment
Share on other sites

Successfully Updated to Yosemite 10.10


Previously the system was running 10.9.5 using the Chameleon + MyHack method.


I wanted to use the Clover bootloader as it seemed a more elegant / native / something cool solution. So the experiment was whether I could convert from Chameleon to Clover AND upgrade from Mavericks to Yosemite, without having to do a clean install.


As I have a 4 internal SATA drives  in the machine (see sig) I use the 64 GB Crucial ssd as a backup OS with important apps. This was the test drive. After successfully installing on this drive I repeated on my main drive.


I followed the Clover Yosemite guide at the other infamous hackintosh site - installing the Clover bootloader in the EFI partition of the drive.


Note that it's a hands-on process -  the system needs to boot from the usb 2 times during the process - and the User needs to make sure that the usb is selected for the second reboot (check the guide). Afterwards the system booted up from the test drive and Setup proceeded.


I used Clover Configurator to generate a working plist - you will likely need to modify to your hardware eg I used the Patch VBios command to get full resolution on the bootloader screen. Note the the autogenerated config.plist has some unnecessary but non-harmful entries - I had mine pruned.


iCloud and AppStore works. Have yet to get Facetime and iMessage working which I don't use - apparently have to call Apple for a code - but elsewhere reported that that works.


Edit: called Apple and they kindly gave me the required code 8-) 


I use HWSensors to monitor CPU and temperatures - I found that it didn't supply all data when FakeSMC + Plugins was installed in the drives EFI partition, but did when installed in S/L/E so I have duplicated the FakeSMC + HW Plugins kext in both locations.


Yosemite + Clover is lovely :)


Edit: Got TRIM support using Clover Configurator and the steps in Post #80 here



Good Hack!

Link to comment
Share on other sites

  • Create New...