Jump to content
PayPal donations: [email protected] ×
marliwahoo

[SUCCESS] Latitude 3470: El Capitan 10.11 / High Sierra 10.13

Recommended Posts

With dark menu, it's more clear , but still not right.

 

There was an clover setup I used that got the sata (not gpu) working. I can not repeat that set up  :shock:. It was when I tried rehabman's nvme script. Though I can not repeat that now. I'm not really sure that had anything to do with sata working.

 

I've started over several times, I guess that's what I'll do again. 

Share this post


Link to post
Share on other sites

Could be issues with the DSDT/SSDT.

Your Origin folder contain strange duplicate SSDT. Like RSDT-SSDT-0.aml and SSDT-0.aml.

Let's start clean.

 

Clean the Origin folder, and extract new file. Hit F4 during clover boot.

If you still see those weird files, then remove all the SSDT/DSDT from the Patched folder.

In Config file, disable dropOEMSSDT, then extract the files again.

Share this post


Link to post
Share on other sites

Good news, bad news. It didn't work, but ...... re-read rehabman's laptop guid and found that some skyline sata devices will not work with out the attached kext. Now - internal sata works!

 

Graphics are the same - artifacts.

 

Strangely sound has not output devices. You did't build a new SSDT-ALC256 with the updated raw dsdt's I sent. Should the SSDT-ALC256 you built originally (from previous raw dsdt's) work? - or will I need a new SSDT-ALC256? (remember I updated bios)

SATA-100-series-unsupported.kext.zip

Share this post


Link to post
Share on other sites

Ahh, I forgot about that unsupported controller. Strangely, I didn't need that kext to work on my E7470. It just shows unknown controller on my setup, but with that kext, it shows Intel 10-Series Chipset. Without it, it still boots internally.

SSDT-ALC256 is to be use with CodecCommander and yes, the same one will work. I didn't create that by the way, it's to fix the sleep/wake sound issue (EAPD fix).

I mistakenly patch HDEF to layout-id 1, need to change to 3.

Let me know if you need me to fix it.

As for graphics artifacts, maybe try different ig-platform-id in your Config file.

Share this post


Link to post
Share on other sites

The supported platformIDs are:

[ 1] : 0x191e0000 – Skylake ULX GT2
[ 2] : 0x19160000 – Skylake ULT GT2
[ 3] : 0x19260000 – Skylake ULT GT3
[ 4] : 0x191b0000 – Skylake HALO GT2
[ 5] : 0x19120000 – Skylake Desktop GT2
[ 6] : 0x19020001 – Skylake Desktop GT1 (currently inactive)
[ 7] : 0x19170001 – Skylake Desktop GT1.5 (currently inactive)
[ 8] : 0x19120001 – Skylake Desktop GT2 (currently inactive)
[ 9] : 0x19320001 – Skylake Desktop GT4 (currently inactive)
[10] : 0x19160002 – Skylake ULT GT2
[11] : 0x19260002 – Skylake ULT GT3
[12] : 0x191e0003 – Skylake ULX GT2

 

Only one I could think of is 19160002, but you could try the others during boot in Clover Option

Files updated in post# 26

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...