Jump to content

[SUCCESS] Latitude 3470: El Capitan 10.11 / High Sierra 10.13


Recommended Posts

  • Administrators

© Consomac.fr:

[ 1] 0x191e0000 - Intel® HD Graphics 515..........(ULX GT2)
[ 2] 0x19160000 - Intel® HD Graphics 520..........(ULT GT2)
[ 3] 0x19260000 - Intel® Iris™ Graphics 540.......(ULT GT3)
[ 4] 0x191b0000 - Intel® HD Graphics 530..........(Halo GT2)
[ 5] 0x193b0000 - Intel® Iris™ Pro Graphics 580...(Halo GT4)
[ 6] 0x19120000 - Intel® HD Graphics 530..........(Desktop GT2)
[ 7] 0x19020001 - Intel® HD Graphics 510..........(Desktop GT1)
[ 8] 0x19170001 - Skylake Desktop.................(GT1.5)
[ 9] 0x19120001 - Intel® HD Graphics 530..........(Desktop GT2)
[10] 0x19320001 - Skylake Desktop.................(GT4)
[11] 0x19160002 - Intel® HD Graphics 520..........(ULT GT2)
[12] 0x19260002 - Intel® Iris™ Graphics 540.......(ULT GT3)
[13] 0x191e0003 - Intel® HD Graphics 515..........(ULX GT2)
[14] 0x19260004 - Intel® Iris™ Graphics 540.......(ULT GT3)
[15] 0x193b0005 - Intel® Iris™ Pro Graphics 580...(Halo GT4)
[16] 0x193b0006 - Intel® Iris™ Pro Graphics 580...(Halo GT4)

So only 2 x layout-id to try in theory: 0x19160000 or 0x19160002.

Link to post
Share on other sites
  • Replies 58
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I've been hackintoshing for 10 years on a dozen pc's. But need help on this one.   I have installed to and am booting from the internal sata drive and able to get into El Capitan.  

ALC3246 indeed according to Dell's 3470 specs. Should be ven/dev ids 10ec:0256, i.e. ALC256 codec.   For El Capitan, try the following Clover on-the-fly AppleHDA patches + attached kexts: Find: 6102

I'm SO happy. I finally solved my video problems. iTunes trailers and some video in safari were not working. I tried IntelgraphicsFixup.kext by Ivs1974 and it's now fixed!! YES!   New 10.13.3 bootpa

Posted Images

  • Administrators

I guess there probably will not be proper support for mobile HD530 until Apple bring out a MacBook/MacBookPro based on that iGPU. Skylake MBPs have been awaited for some time and may be launched end of the year.

 

At present, the only Skylake-based Apple Mac platforms are:

  1. MacBook9,1 which are fitted with HD515 graphics (no discrete GPU)
  2. iMac17,1 have 6th gen i5/i7 CPUs with integrated HD530 but I don't think it's being used in a switched mode with the AMD dGPU
Link to post
Share on other sites

Quick update.

 

After trying to install Sierra (crashing on the "frame buffer") I went back to the DVMT and tried different settings. Setting  0x435 0x03 worked. Graphics in El Capitan were much better and Sierra works ok (still some artifacts) 

 

Cant get audio to work in Sierra. Are their any more updated patches for Sierra? (hda or hd520)

 

 

ALC3246 indeed according to Dell's 3470 specs. Should be ven/dev ids 10ec:0256, i.e. ALC256 codec.
 
For El Capitan, try the following Clover on-the-fly AppleHDA patches + attached kexts:

Find: 6102EC10
Replace by: 00000000

Find: 6202EC10
Replace by: 00000000

Find: 8508EC10
Replace by: 00000000

Find: 8319D411
Replace by: 00000000

Find: 8419D411
Replace by: 5602EC10

 attachicon.gifAppleHDA_ALC256.kext.zip attachicon.gifCodecCommander.kext.zip
 

Patch your DSDT HDEF device to inject audio layout 3.

Link to post
Share on other sites
  • Administrators

Make sure AppleHDA gets loaded as the patches will only apply if the kext is cached. If it gets loaded, rebuild the cache:

sudo touch -f /S*/L*/E*
sudo touch -f /L*/E*
sudo kextcache -Boot -U /

ALso, please note that the 8319D411 patch is not valid in Sierra. Target 8A19D411 instead. The others should be Ok.

Link to post
Share on other sites

Thank you again so much for your help!!!!

 

Got rid of the artifacts using Clover ...... I got it working with Pike's device property patch:

AddProperties
Device
IntelGFX
Key
AAPL,GfxYTile
Value
AQAAAA==

Note: Setting DVMT seemed to work 0x435 0x03 -Also in Clover - Inject Intel Graphics = yes and set Platform ID 0x19160000

 

​Finally a completely working boot pack for Sierra. Touchpad still sorta sucks.

Latitude_3470.zip

Link to post
Share on other sites

Try Dr. Hurt's new Alps v7 kext. Keep the USB installer handy in case of KP.

 

Tried the above kext. It partially worked. Two finger scrolling worked. Tracks REALLY slow. Mouse settings could not control tracking speed. Touchpad settings would not load in system prefs. Went back to original kext.

 

I wonder if some of the crazy movement from the trackpad is somehow related to the touch screen (touch screen works). FYI - a usb mouse works just fine.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...