Jump to content

Schiller

Members
  • Posts

    14
  • Joined

  • Last visited

  • Days Won

    3

Schiller last won the day on March 7 2018

Schiller had the most liked content!

Contact Methods

  • Twitter
    @alexriveraz

Recent Profile Visitors

534 profile views

Schiller's Achievements

Private First Class

Private First Class (3/17)

8

Reputation

  1. Off-topic but I also achieved this, I didn't replace the antennas since I was lazy to open the LCD panel, instead I soldered (only a drop above each connection so they stay in place) the E7440's built-in antennas to the BCM94360CS2 chip connectors. Everything works as intended "out of the box" (no WIFI or BT patches at all) handoff, continuity, hotspot, etc.
  2. BTW for macOS High Sierra 10.13 things changed and the previous inject methods are not working like before, at least for me. After High Sierra update WiFi was working, BT more or less, I had a "Third Party Wireless Card" instead of Airport Extreme. AirDrop, hotspot, handoff, etc weren't working either. So here's a mini guide, things get simpler with these steps : You need latest Lilu (requires v1.2.0) and load AirportBrcmFixup to /EFI/CLOVER/kexts/10.13/ Clover AirPortBrcm4360 kext patches are no longer needed with AirportBrcmFixup.kext so remove or disable them. You still need to inject BT as before, in my case I'm using BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext in /S/L/E Also keep the previous Clover options active such as: ACPI > Fixes > AddDTGP ACPI > Fixes > FixAirport Devices > Fake ID > WIFI = 0x43a014E4 Have fun and pair those 4.0 bluetooth devices you love while streaming music, movies, etc
  3. macOS High Sierra 10.13.1 AirDrop is working with this card, and it's really fast Handoff / Continuity is active in my system but I never got them working: I see iPhone's safari web page in macOS dock (same with notes, messages, etc) But I can't really open it: Notes: Universal clipboard doesn't work for me either.
  4. High Sierra 10.13.1 installed (from app store) with some strange issues: First reboot when installing I got this message: Invalid partition table!I powered off/on the laptop and clover booted like before. When I ran the commands to fix permissions and rebuild cache my laptop was stuck on the Apple logo twice, power off/on fixed the issue. Everything seems to be working though. Regards
  5. MacOS High Sierra 10.13 Supplemental Update just installed without problems from the App Store. Once update finishes you just need to re-run these commands (read post #2 for details) and reboot. Repair permissions and rebuild cache: sudo chmod -Rf 755 /L*/E*sudo chown -Rf 0:0 /L*/E*sudo chmod -Rf 755 /S*/L*/E*sudo chown -Rf 0:0 /S*/L*/E*sudo touch -f /L*/E*sudo touch -f /S*/L*/E*sudo kextcache -Boot -U / Build
  6. Hi, I just followed these steps and successfully upgraded my E7440 to High Sierra, I hope it helps. Backup your information and have a bootable USB with your current EFI configuration (Time machine is best for backups). Upgrade Clover to 4233 (latest available at time of writing). Download apfs.efi.zip and put it in your EFI partition: /EFI/CLOVER/drivers64UEFI/ This will make Clover compatible with new Apple File System APFS. [Recommended] Update your current sierra kexts and place them under /EFI/CLOVER/kexts/Other/ (create the folder if it doesn't exists). I'm using these kexts: E7440 HS EFI kexts.zip Edit config.plist (I recommend using Clover Configurator 4.53 or newer) and activate Fix Headers option under Acpi: Reboot Sierra and check that everything is ok, use bdmesg | grep APFS in a terminal to see if APFS driver was loaded without problems: bdmesg | grep APFS See Jake's post below if you don't want to use APFS and keep HFS+ or install on another partition. Download High Sierra from Mac App Store and follow instructions, the installation process will reboot your laptop a couple of times, you will also notice a new option in Clover bootloader, don't move anything there, just let it reboot and choose the boot option automatically (if you have boot timeout activated it will boot with the new auto-selected option). At this point I'll assume you already have working kexts in /S/L/E or /L/E. You must rebuild cache and repair permissions, open a terminal and execute the following commands with sudo then reboot: sudo chmod -Rf 755 /L*/E* sudo chown -Rf 0:0 /L*/E* sudo chmod -Rf 755 /S*/L*/E* sudo chown -Rf 0:0 /S*/L*/E* sudo touch -f /L*/E* sudo touch -f /S*/L*/E* sudo kextcache -Boot -U / Note that the above commands may or may not need to be executed more than once if it fails. You will notice if any drivers are missing (I had to run them and reboot twice in order to get audio working again for example). Regards
  7. Do you have audio working? I lost audio after the 10.13 High Sierra update, everything else is working. I'll try rebuilding the kernel cache again... Edit: Nevermind, a second reboot fixed audio... Intel i5 and 1366x768 display
  8. For trackpad I use Dr. Hurt's: VoodooPS2Controller.kext.zip Working: 1 finger tap click Both clicks (including the ones above touchpad) Trackstick 2 finger tap for right click 2 finger scrolling 3 finger gestures (like change desktop screen) 4 finger gestures (hard to do for me mostly because of the trackpad size) Preferences settings: Not working or probably I don't have them configured: 2 finger gestures (like previous page or show all active tabs both in safari) Edges scrolling (I don't use this anyway) I load it in /EFI/CLOVER/kexts/10.12/ and I haven't found problems so far, just make sure you don't have any other trackpad kexts or duplicates in /S/L/E or /L/E and you can load the kext from any of those locations btw (just one like I said). If you load any kexts from /S/L/E or /L/E you have to repair permissions and rebuild kernel cache after moving the drivers to any of those locations. Repair permission and rebuild cache sudo chmod -Rf 755 /L*/E* sudo chown -Rf 0:0 /L*/E* sudo chmod -Rf 755 /S*/L*/E* sudo chown -Rf 0:0 /S*/L*/E* sudo touch -f /L*/E* sudo touch -f /S*/L*/E* sudo kextcache -Boot -U / Now for bluetooth, what combo card (WiFi+BT) are you using?
  9. Updated yesterday to 10.12.6 (probably last Sierra iteration) from app store without a problem. Just make sure you always update your clover installation before I'm currently running v4114.
  10. That happens when you reduce laptop's display brightness at minimum and a shutdown occurs. You have to increase brightness with Fn+Insert when macOS boots up. Also if you update let's say from 10.12.4 to 10.12.5 or any macOS update... you probably (it's best to) need to rebuild your kernel cache to avoid kexts not being loaded (sound, trackpad, etc) when the OS starts. And it's recommended to keep your kexts updated to the latest stable versions available (just in case... keep your bootable USB close )
  11. Hello ppl I just updated my E7440 to 10.12.5 without a problem.
  12. Thanks Hervé Shiki kext works and fixes several problems with streaming codecs and iTunes trailers/videos, at least under E7440 with HD4400. I can finally browse Twitter and other websites without fearing a sudden freeze... Just install these in Clover kexts folder: /Volumes/EFI/EFI/CLOVER/kexts/10.12/ Fixes freezes: IntelGraphicsFixup & Lilu iTunes trailers/videos: Shiki I'm getting these message from iTunes movies though... maybe my display is not HDCP compatible? I bet I could play iTunes movies on MS Windows/iTunes when I had it installed.
  13. Thanks Jake, it's working again. However activity monitor crashes on energy tab (avoid clicking while its fixed).
  14. I have the same issue with brightness and keys not working after upgrading to 10.12.4. I just installed brightness by berg design http://bergdesign.com/brightness/ as a workaround, I miss the Fn+F3 and Fn+Insert though.
×
×
  • Create New...