Jump to content

Syonagar

Administrators
  • Content Count

    569
  • Joined

  • Last visited

  • Days Won

    19

Everything posted by Syonagar

  1. Dear @woainba15 I saw the same KP when I used the latest whatevergreen.kext (that combines both intel and and graphics fixes) to boot high sierra 10.13.6. I had no issue using the last intel graphics fixes lilu kexts. So I think there is an issue with whatevergreen kext when it comes to intel igpu. It works fine with my amd dgpu. Did you try with the 10.13.6 clover bootpack to boot mojave? Just try to use the same kexts but install the latest clover. I will try to install mojave on my laptop when I have time later.
  2. Dear members, We are pleased to inform that the new members sign up form is working again. Enjoy!
  3. Dear new members, We are experiencing technical issues on new members sign up at the moment. Rest assured that we are looking into this matter as we speak. Please check again soon. We will provide regular updates on this matter. Thank you.
  4. @Tal Rahav Thanks for your further information. I tried you clover again and my Mac OS 10.13.6 managed to boot. I guess I must have used the wrong Clover folder previously. Strangely I still have flickering after sleep. Can you attach the following kext from your "/System/Library/Extensions" folder please:- AppleIntelKBLGraphics.kext AppleIntelKBLGraphicsFramebuffer.kext Thank you.
  5. @Tal Rahav Strangely enough I was not able to boot into mac os with my latest bootpack, previous bootpack as well as yours above. It seems the installer refuses to start with a KP when I was combo updating from 10.13 to 10.13.6. I ended up updating my usb stick from my desktop hackintosh. Upon completion, I tried my latest bootpack and it managed to boot nicely into Mac OS. Can you give it a try please. Its in the first page. I disabled the EDID injection provided by @woainba15 previously as it did not worked for me. The screen flickers upon log in. Well, the good thing is that I was able to get screen to wake albeit with flickers after @Jake Lo disabled the eDP port which was enabled previously in config.plist. One step closer to a solution hopefully. If you having screen wake from sleep issue, try to enable the EDID injection. Will put these notes on the 1st page when I get back later. Though I put out the latest clover bootpack first. Thank you.
  6. @Tal Rahav I too am having problem booting 10.13.6 at the moment. Apparently graphics handling after 10.13.5 is quite different. Let me try your clover this time Thanks!
  7. Dear @Tal Rahav Copy the whole "/clover/acpi/patched" folder and config.plist from my bootpack into your clover folder in efi and reboot
  8. Dear @Tal Rahav, Did you use the clover bootpack in the first page? How did you create your usb installer? I have not updated the bootpack for a while but let me see if I can create a new one based on 10.13.6, latest kexts and latest clover.
  9. Dear @Anh Nguyen, Did you try the dsdt.aml in the Clover bootpack? It should be the same. Thank you.
  10. Dear @vikesyy Can you log in into you apple account? Did you try to use ethernet?
  11. Syonagar

    Hello guys!

    Hi Allan, Welcome to the crew! Lets make the forum great again ! Syonagar
  12. Hey @woainba15 I have not been able to fix the HDMI and screen wake issues on my machine. I suspect its probably a different LCD manufacturer. Can you attach your complete Clover folder? If it works I can add it in my front post for others to use. Thank you and regards.
  13. Hi all, I am very excited to finally hack this world famous GPU mining motherboard and pleased to share with you all the clover bootpack. Specifications Asrock H81 BTC Pro Ver 2.0 4th Gen 3.5 GHz i3-4330 8 GB DDR3 1600 MHz Memory Intel Graphics HD 4600 HDMI output on 24-inch LED Monitor (1920 x 1080) OpenCore Bootpacks Big Sur Support for Mac OS Big Sur 11.0.1 (OpenCore 0.6.3) OC-11.0.1.zip Clover Bootpacks Big Sur Support for Mac OS Big Sur 11.0.1 (Clover 5126) CLOVER-10.15.7.zip Catalina Support for Mac OS Catalina 10.15.7 (Clover 5126) CLOVER-10.15.7.zip Support for Mac OS Catalina 10.15.4 (Clover 5116) CLOVER-10.15.4.zip Support for Mac OS Catalina 10.15.1 (Clover 5070) CLOVER-10.15.1.zip Support for Mac OS Catalina 10.15 (Clover 5070) CLOVER-10.15.zip Support for Mac OS Catalina 10.15 Beta (19A471t) (Clover 4945) CLOVER-10.15 Beta (19A471t).zip Mojave Support for Mac OS Majave 10.14.6 (Clover 4945) CLOVER-10.14.6.zip Support for Mac OS Majave 10.14.5 (Clover 4934): CLOVER-10.14.5.zip Support for Mac OS Majave 10.14.4 (Clover 4910): CLOVER 10.14.4.zip Support for Mac OS Mojave 10.14 Beta 4 18A326h (Clover 4586): CLOVER 10.14 Beta 4.zip Support for Mac OS Mojave 10.14 Beta 18A293U (Clover 4517): CLOVER 10.14 Beta.zip High Sierra Support for Mac OS High Sierra 10.13.6 (Clover 4635) CLOVER 10.13.6.zip Support for Mac OS High Sierra 10.13.4 (Clover 4428) CLOVER-V4.zip Support for Mac OS High Sierra 10.13.2 (Clover 4360) CLOVER-V3.zip Support for Mac OS High Sierra 10.13.1 (Clover v4293) CLOVER-V2.zip Support for Mac OS High Sierra 10.13.1 (Clover v4293) with Intel Graphics: CLOVER-Intel.zip Support for Mac OS High Sierra 10.13.1 (Clover v4293) with ATI Graphics: CLOVER-ATI.zip Credits goes to Jake Lo and Bronx Teck OpenCore & Clover Notes on Mac OS Big Sur 11.0.1 (1) Everything works (2) Updated all kext to latest version Clover Notes on Mac OS Catalina 10.15.7 (1) Everything works (2) Updated all kexts to latest version Clover Notes on Mac OS Catalina 10.15.4 (1) Everything works (2) Updated Lilu.kext, VirtualSMC.kexts and Whatevergreen.kext to latest version Clover Notes on Mac OS Catalina 10.15.1 (1) Everything works (2) Updated Whatevergreen.kext to latest version Clover Notes on Mac OS Catalina 10.15 (1) Everything works (2) Updated clover, efi drivers & kexts to latest version (3) Swapped from FakeSMC to VirtualSMC Clover Notes on Mac OS Catalina 10.15 Beta (19A471t) (1) Everything works (2) Whatevergreen.kext requires graphics injection from Clover Clover Notes on Mac OS Mojave 10.14.5 (1) Everything works (2) Mac OS 10.14.5 Update Installer now complaints "Cannot Find Installer Resources". A very crude workaround is to remove all other hard drives except for the Mac OS hard drive. Let me know if anyone find a solution to this without having to open the casing each time we want to update. Clover Notes on Mac OS Mojave 10.14.4 (1) Everything works (2) Whatevergreen.kext now autodetects the graphics card. Make sure no graphics injection is done in Clover. Clover Notes on Mac OS Mojave 10.14 Beta 4 18A326h (1) Everything works (2) Updated from Mac OS Majave 10.14 Beta 18A293U via Software Update in the System Preference. Clover Notes on Mac OS Mojave 10.14 Beta 18A293U (1) Everything works including sleep. (2) Dedicated GPU Radeon Pro 560 not displaying on monitor. May need to wait for WhateverGreen.kext to be updated with support for this Mac OS version. Clover Notes on Mac OS High Sierra 10.13.1 (1) Everything works including sleep. (2) Updated all kexts to latest versions (3) Added IntelGraphicsFixup.kext and Shiki.kext (4) Combined all ATI & Intel GPU configs & kexts into single bootpack for multi GPU support (5) For those that need to update 10.13 to 10.13.1, you will need to install the latest clover (version 4293 is the one I used). If there are error messages, you may try to remove EmuVariableUefi-64.efi from Clover EFI temporarily, clear NVRAM using sudo nvram -c in terminal, download the update directly from apple website and install. Clover Notes on Mac OS High Sierra 10.13.2 (1) Everything works including sleep. (2) Updated all kexts to latest versions (3) For those updating from 10.13.1 to 10.13.2, you will need to install the latest clover and lilu including plugins (or download latest bootpack above) as well as download and install the update directly from apple website. Updating via App Store doesnt seem to work for me as I get the mkpg not found error message after reboot. Clover Notes on Mac OS High Sierra 10.13.4 (1) Everything works including sleep. (2) Updated all kexts to latest versions (3) For those updating from an earlier version of 10.13 to 10.13.2, you will need to install the latest clover and lilu including plugins (or download latest bootpack above) as well as download and install the update directly from apple website. The OS X installer will reboot several times. Clover Notes on Mac OS High Sierra 10.13.6 (1) Everything works including sleep. General Notes (1) The UEFI Bios does not detect Clover EFI natively. For first boot into Mac OS, you will need to boot Clover EFI using the Installer USB. In order to add Clover EFI into UEFI Bios, you will need to manually add it using the Clover UEFI shell using the following command:- (a) bcfg boot add 3 fsX:\EFI\CLOVER\CLOVERX64.EFI "Clover" (You will need to replace X with the location of your Clover EFI partition. This is shown in the list when you first enter the UEFI shell) (b ) Lastly, do bcfg boot mv 3 0 to move the Clover boot order to the first. (2) I found that this motherboard is very compatible with Mac OS and patched DSDT / SSDT is not required. Notes on Mining (1) As all you miners know, this motherboard can take up to six (6) GPUs, I have yet to test additional GPU on the PCIEx1 slots. At the moment, the single GPU that i'm using is installed on the PCIEx16 slot. I will test it once I have opportunity to get additional GPU. In the mean time, for those miners who already have this motherboard in their rig and are already using Windows or Linux, Mac OS may be a good OS to try since some miners (like ethereum's ethminer) are also released for Darwin and both NVIDIA and ATI have provided drivers for their latest GPUs. This does open up a good possibily of using Mac OS for GPU mining! (2) I was able to use the dedicated RX560 GPU for both as primary display as well as for mining. However, it causes the system to slow down and created artifacts when I rebooted / shutdown. I was able to make the system more stable by using the integrated HD4600 GPU as primary display and the dedicated RX560 GPU for mining. In order to use both integrated GPU and dedicated GPU, both Intel and ATI need to be injected by Clover. In the case of ethereum miner, ethminer was able to recognized all GPU but I only selected the RX560 for mining. This made the system more stable. (3) [10-11-2017] I just installed a third old AMD Radeon HD 7750 GPU on the first PCIEx1 slot and am very happy to see that Mac OS recognized it straight away. In the case of ethereum miner, ethminer was able to recognized all GPU. Attached pictures below:- (4) One of my main concern is I am still not able to get HWMonitor to show GPU temperature which is very important to monitor the current health of the GPUs. We would not want the GPU to overheat due to unforeseen reasons. Let me know if you are able to solve this issue. (5) During my discussion with crew member Rhyker, we were discussing on ways to tune the GPU from within Mac OS. As you know, currently the manufacturer only provide tuning software for Windows and to a limited extend Linux. We were thinking of running Windows under a virtual machine to access the GPU tuner to tune the GPUs. However, based on my last attempt, accessing native GPU from a virtual machine is still not possible although there are projects that are attempting to do this. Let me know if this idea is workable. Let me know if the clover bootpack works for you. CLOVER-10.15.zip
  14. Hi Nouman, Welcome to osxlatitude ! Have a look at this guide and give it a try:- https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-clover-guide/&do=findComment&comment=74275 Let us know the result. Cheers!
  15. Dear griftopia, From my experience updating with the supplementary update, you will see that you need to boot installer disk as it will update from an installer rather than direct update from within mac os. If I remember correctly, I just need to boot the installer twice as the first time boot will give error. The second boot should update it nicely. Maybe this will shed some light.
  16. griftopia, I too experience that same issue where nvram.efi was not installed in my EFI partition. With every new clover updates and new machines being hacked this issue comes and go. There are a few extreme measures that you can try that may affect your existing mac os install. Try to reformat your EFI partition and reinstall clover. Make sure you save your old clover folders especially the config.plist, patched acpi, efi64drivers and kexts folders which you will need to re-copy to your new EFI folder. If still no luck, wipe clean the hard disk partition table and recreate the GUID partition table. This will create a new EFI partition apart from the Mac OS partition. Im assuming here that there may be problems with your EFI partitions. Off course after you tried each measure above to recreate your EFI partitions, repeat previous suggestions on trying to get nvram.efi installed. Good luck!
  17. Dear Griftopia, Try to install clover again but with selecting "Install RC scripts on target volume" only. After that check if rc.shutdown.d is in /etc If its there then run "sudo /etc/rc.shutdown.d/80.save_nvram_plist.local" If its still not there try to install clover again but with the EFI partition mounted.
  18. Griftopia, Type the following command from terminal and it should create the nvram.plist:- sudo /etc/rc.shutdown.d/80.save_nvram_plist.local
  19. Hi all, Just built my first budget desktop hackintosh and pleased to share the bootpack. Specification Gigabyte H81M DS2 4th Gen 3.5 GHz i3-4330 8 GB DDR3 1600 MHz Memory Intel Graphics HD 4600 (Working but unusable. See notes below.) AMD Radeon 7750 1GB (See other post here : https://osxlatitude.com/forums/topic/11048-amd-radeon-hd-7750-supported-by-mac-os-mojave-catalina/) Note: This bootpack should also be compatible with any supported 4th Gen Intel CPU on H81 Intel Chipset Motherboard. OpenCore Bootpack (macOS Big Sur) The OpenCore bootpack can be downloaded from the following link:- macOS Big Sur 11.0.1 (OpenCore 0.6.3):- OpenCore-11.0.1.zip macOS Big Sur Beta 10 (OpenCore 0.6.3):- OpenCore-11.0-Beta10.zip macOS Big Sur Beta 4 (20A5343i) (OpenCore 0.6.0):- OpenCore-11.0-Beta-20A5343i.zip macOS Big Sur Beta 2 (20A4300b) (OpenCore 0.6.0):- OpenCore-11.0-Beta -20A4300b.zip macOS Big Sur Beta 1 (20A4299v) (OpenCore 0.6.0) :- OpenCore-11.0-Beta-20A4299v.zip (Note: These bootpacks can also be used to boot macOS Catalina) Clover Bootpack (Up to macOS Catalina) The Clover bootpack can be downloaded from the following link:- Mac OS Catalina 10.15.7 (Clover v5126) CLOVER-10.5.7.zip Mac OS Catalina 10.15.4 (Clover v5116) :- CLOVER10.15.4.zip Mac OS Catalina 10.15.1 (Clover v5070) :- CLOVER-10.15.1.zip Mac OS Catalina 10.15 (Clover v5070) :- CLOVER-10.15.zip Mac OS Mojave 10.14.4 (Clover v4910) :- CLOVER-10.14.4.zip Mac OS Sierra 10.12.6 / Mac OS High Sierra 10.13 (Clover v4241) :- CLOVER.zip Credits goes to Jake Lo, Bronx Teck & Herve Notes on Big Sur 11.0.1 (OpenCore) (1) This bootpack is able to boot Mac OS Big Sur Beta 10. However, it is still getting issue where installer will exit prematurely after starting. If anyone managed to resolve this issue do give me a buzz. Found the cause of installer exiting prematurely after start. Its a hard disk issue. Also had issue similar issue when installing windows on the same hard disk. (2) So everything should works except sleep. integrated graphics need to be disabled in bios in order for sleep to work (i.e. no desktop freeze after wake). (3) Updated all kexts to latest version. Notes on Big Sur Beta 4 (20A5343i) (OpenCore) (1) So far everything works except sleep. System freezes after wake. (2) This bootpack is based on latest OC and lilu & friends kext release based on OC 0.6.0 Notes on Big Sur Beta 2 (20A4300b) (OpenCore) (1) So far everything works except sleep. System freezes after wake. (2) This bootpack allow both updating of existing beta 1 to beta 2 and installing new hard drive by running the installer app from an existing Mac OS system. (3) USB installer created from createmediainstall still cannot be booted. Resolved. As @Jake Lo advise, with latest lilu we can omit "-lilubetaall vsmcgen=1 booter-fileset-kernel booter-fileset-basesystem" stuff. Make sure to reset nvram on first OC boot and boot the usb installer on reboot. However, looks like "booter-fileset-kernel & booter-fileset-basesystem" need to be remove when booting usb only and 1st stage installation. 2nd stage looks like it still need those to boot. Notes on Big Sur 11.0 Beta (20A4299v) (OpenCore) (1) USB installer still cannot be booted using clover or opencore. Big Sur need to be cloned from existing real mac disk image. (2) So far everything works except for sleep. (3) Downloaded the real mac disk image and followed installation guide from here: https://www.olarila.com/topic/8977-guide-installrestore-bigsur-with-opencore/. (4) Initial bootpack for OpenCore obtained from here: https://www.reddit.com/r/hackintosh/comments/fuf6z7/open_core_056_catalina_10154_gaz87mxd3h_i74770/. Updated network card kext from my clover bootpack and updated OpenCore to version 0.6.0. Notes on Catalina 10.15.7 (Clover) (1) Updated Clover and kexts to latest versions. (2) Clover is already using the Quirks features which are normally required for Intel 4th Haswell desktops. (3) Clover bootpack is able to boot Mac OS Big Sur 11.0.1 after it has been installed. Still not able to boot installer. Notes on Catalina 10.15.4 (Clover) (1) Updated Clover, Lilu.kext, VirtualSMC.kexts & Whatevergreen.kext to latest versions. Notes on Catalina 10.15.1 (Clover) (1) Whatevergreen.kext updated to 1.3.4 to resolve blank screen after boot. Notes on Mac OS Sierra 10.12 / Mac OS High Sierra 10.13 / Mojave 10.14 / Catalina 10.15 (Clover) (1) So far, everything works including sleep with power nap! So far this motherboard is very compatible with Mac OS and patched DSDT / SSDT is not required. Notes on Integrated HD4600 GPU (1) Although the integrated HD4600 GPU can be enabled by simply injecting intel from clover, the GPU cannot be utilized since the motherboard does not have a HDMI output! Using dedicated GPU such as RX 560 while the integrated HD4600 GPU is enabled may cause video playback in chrome to be jibrish and iTunes video playback to freeze the desktop. The integrated GPU need to be disabled from bios to resolve this. Let me know if the clover bootpack works for you. Cheers!
  20. Hi all, Specifications Dell Vostro 5568 7th Gen i7-7500U @2.7GHz 8GB DDR4 2400 MHz Memory Intel Graphics HD620 / NVIDIA® GeForce® 940MX 4GB GDDR5 15.6" screen (1920 x 1080) OpenCore Bootpacks Mac OS Big Sur 11.0.1 (OpenCore 0.6.3) OC-11.0.1 Rev A.zip (AppleHDA.kext for audio) OC-11.0.1.zip (VoodooHDA.kext for audio) So far everything works except the following:- NVIDIA® GeForce® 940MX 4GB GDDR5 (Disabled as cannot work on Mac OS) USB 2.0 Realtek CRW SD Card Reader (Detected but not working) Built-In Intel WLAN Card (Not supported by Mac OS) Headphone jack not working when fully inserted. Got some audio when halfway inserted. I am very pleased that sleep works and both hdmi and vga ports are working. Two monitors can be connected to the laptop! LOL OpenCore guide and credits mainly to here : OpenCore Install Guide for Kaby Lake Laptop Kexts & ACPI patch files credits mainly to my dear friend @Jake Lo. I migrated these from Clover bootloader. Mac OS Catalina 10.15.7 (OpenCore 0.6.3) OC-10.15.7.zip So far everything works except the following:- NVIDIA® GeForce® 940MX 4GB GDDR5 (Disabled as cannot work on Mac OS) USB 2.0 Realtek CRW SD Card Reader (Detected but not working) Built-In Intel WLAN Card (Not supported by Mac OS and using USB WLAN for now) This bootpack is able to boot Mac OS Big Sur 11.0.1 but so far its stuck at "waiting for.. boot-uuid-media...". If anyone managed to resolve this do let me know! @Jake Lo correctly highlighted that Big Sur removed some ports. Using Catalina AHCIPort.kext resolved this issue. Cheers! Clover Bootpacks Credits goes to Bronx Teck, Herve & Jake Lo Mac OS Catalina 10.15.5 (Clover V5119) :- CLOVER-10.15.5.zip Graphics Platform ID injected in order to resolve screen flickering and to get hdmi to work in Mac OS Catalina 10.15.5 Everything works except for the following:- NVIDIA® GeForce® 940MX 4GB GDDR5 (Disabled as cannot work on Mac OS) USB 2.0 Realtek CRW SD Card Reader (Detected but not working) Built-In Intel WLAN Card (Not supported by Mac OS and using USB WLAN for now) Sleeps does not work at the moment. Each time attempting to sleep the screen just wakes up. HDMI works. However, during boot up it does not detect the hdmi is connected. Need to manual unplug and replug the hdmi to get mac os to detect it again. Mac OS Catalina 10.15.4 (Clover V5118) :- CLOVER-10.15.4.zip Everything works except for the following:- NVIDIA® GeForce® 940MX 4GB GDDR5 (Disabled as cannot work on Mac OS) USB 2.0 Realtek CRW SD Card Reader (Detected but not working) Built-In Intel WLAN Card (Not supported by Mac OS and using USB WLAN for now) This bootpack does not inject any graphics platform-id. Seems to resolve the screen flickering after wake from sleep issue. Using the usual graphics platform-id of 59160000 will cause major screen flickering issue after waking from sleep. HDMI does not work without any graphics platform-id injected. However, with platform-id injected, I have yet to resolve my screen going blank or system hang issues when I connect external monitor to hdmi. Further, injecting the usual platform-id will cause flickering issue after sleep wake. So for now I rather live with no HDMI output so that it can sleep without any screen flickering after wake LOL. Mac OS High Sierra 10.13.6 (Clover V4643) :- CLOVER V3.zip Updated Lilu.kext and all Intel graphics kexts to the latest (these are the final intel graphics specific lilu plugins as whatevergreen will integrate all these plugins for 10.14 onwards) Added 10.13.6 USB port limit patch (By Jake Lo) Disabled eDP port patch which was previously enabled as not needed (By Jake Lo) Added EDID entries (disabled by default) as potential solution to screen flicker after wake. @woaiba15 was able to solve this issue with this injection but I could not replicate it. Enable EDID injection to test it. Mac OS High Sierra 10.13.1 (Clover v4289) :- CLOVER V2.zip Mac OS Sierra 10.12.6 / High Sierra 10.13 (Clover v4241) :- CLOVER.zip Added DellSMBIOSPatch in config.plist to show correct Model Identifier. Some software uses Model Identifier to check hardware compatibility such as AutoCAD 2016 LT (P/s: Thanks Jake for highlighting this just in time when I had problem installing it!) (26 Aug 2017) Fixed distorted sound from headphones on Mac OS Sierra 10.12.6 (31 Aug 2017) Kernel Extension (Kext) in "/Library/Extensions" Folder:- KEXT-10.13.zip (Note: Your will need to repair permission and rebuild cache for /Library/Extensions) Everything works except for the following:- NVIDIA® GeForce® 940MX 4GB GDDR5 (Disabled as cannot work on Mac OS) USB 2.0 Realtek CRW SD Card Reader (Detected but not working) Built-In Intel WLAN Card (Not supported by Mac OS and using USB WLAN for now) Sleep (Screen flickers after waking from sleep for 10.12.6 and screen blanks after waking from sleep for 10.13) Disconnecting HDMI out cable causes blank screen Last Remarks Let me know if the above bootpack works for you. If you managed to get some of the remaining issues resolved, do let me know so that I can update this thread. Cheers!
  21. Dear morfin, Try to install using the modcd in the installation guide above. You need to download bootpack for your machine to see what kexts are required and search for a leopard version for all the kexts. Cheers.
  22. Dear aporn, Try the different voodoohda.kext in EDP. The older version are KP proned but the newer one should be more stable. Cheers.
  23. Dear alan, I made some progress on getting sleep to work on my optiplex 755. Try to remove nullcpupowermanagement and sleepenabler in your extra if its there. Also remove unnecessary parameters in org.chameleon.boot.plist. Cheers.
×
×
  • Create New...