Jump to content

Slow Boot & Battery Problem on my Dell Inspiron 5558 High Sierra


Recommended Posts

Hi All. I have a problem with my hackintosh. Everything was running smoothly but I just noticed that my battery charge status was differently with HWMonitor(real charge shows) and battery status on menu bar. See attached picture.



Second one is my boot was slow even on SSD- Samsung 840 Evo. It took 32 seconds(trim enabled) and 28 seconds(trim disabled) to boot my hackintosh. I have reporting files attached. Any help will be greatly appreciated.



My specs:

Dell inspiron 5558

A14 Bios

i5 5200u(broadwell)

Nvidia 920m(disabled via dsdt)


120GB Samsung 840 Evo SSD(main drive)

500gb Seagate & Toshiba HDD(im changing secondary drive-CD Caddy as im migrating files)


Kext used and patches can be seen on my reporting file. Thank you




EDIT - additional info:


Im dualbooting High Sierra & Windows

Windows 10 boots in 7 seconds

I am using APFS

Clover UEFI

Noticed also that HWMonitor shows that my ssdlife is 99% while on windows(hd sentinel and ssdlife pro shows 100%)

Troubleshooting done:

•disabled nvidia via bios

•fixed usb power and usb limit via ssdt for usbinjectall

•tried booting with all kext removed. Left Fakesmc, usbinjectall, realtek only for booting

•tried reseating all hw(memory, hdd, cmos battery, wifi card, HDD caddy)


But issue still persist - slow boot and battery not shown properly




Link to comment
Share on other sites

I can see that you are not using the TRIM Patch which is generally the cause for slow boot-ups on APFS.


Please note that APFS is not recommended on a hackintosh(Non-Apple SSD). Refrain from it.


Hw-Monitor issue is not exactly an issue from my POV, It is fine (Same case on my system)


So, the conclusion is, maybe your SSD Firmware is not properly supported by APFS. If you can, please install on HFS+J



Link to comment
Share on other sites

  • Administrators

20s is about the best one can get.


If you want to enable trim, please note that there is no real need for a patch since Apple introduced a command to enable it as of Yosemite 10.10.4: sudo trimforce enable

Link to comment
Share on other sites

On 11/4/2017 at 3:05 PM, black.dragon74 said:

When using the sudo trimforce enable command you will get a few errors when you try to rebuild caches, Using patch overcomes that error.


Performance wise, you can use any one of them two, no difference.



how can i get the trim patch for the same laptop but have not SSD 
thanks in advance 

Link to comment
Share on other sites


  • Create New...