Jump to content
wojciech679

DW5570: how can i use the WWAN under High Sierra?

Recommended Posts

Hey !

 

I need help. I fight with this modem for a few day, I have read some topic about this, but for me don't work with successfully. 

I have High Sierra 10.13.3, Dell E7240 and Sierra Wireless AirPrime (Qualcomm 4G) DW5570 (7W5P6) (VID 413C; PID 81A3)

 

I used  Legacy_Sierra_QMI.kext (so modem is active in system report - position usb and wwan).

 

Who exactly explain me what and how I must edit. FakeSMC.kext or CellPhoneHelper.kext (or both?).

 

Perhaps I have wrong port on USB ? 

 

Thank for any help. 

Greetings Mates! ;)

Share this post


Link to post
Share on other sites

You can try and add the usual WWAN patch tuned for the DW5570, either into FakeSMC or in CellPhoneHelper; just not in both...

 

You can refer to the guidance and general principles detailed in this recent High Sierra-related thread:

https://osxlatitude.com/index.php?/topic/9560-dw5809e-how-can-i-use-the-wwan/

 

If it worked for the DW5809e, no reason why it would not work for the DW5570...

 

Original Yosemite patch details remain available here:

https://osxlatitude.com/index.php?/topic/8006-sierra-wireless-qmi-modules-mcem73xx77xx8805etc-dell-dw557058085809etc/

 

I had offered a Sierra patch here:

https://osxlatitude.com/index.php?/topic/9403-using-dw5570-under-sierra/

 

Obviously, setting the card to the correct QMI mode remains fully applicable.

  • Like 1

Share this post


Link to post
Share on other sites

I used  Legacy_Sierra_QMI.kext (so modem is active in system report - position usb and wwan).

 
Who exactly explain me what and how I must edit. FakeSMC.kext or CellPhoneHelper.kext (or both?).

 

I made a kext for HS based on what Hervé suggested to me, but card didn't work until I changed USBCOMP mode.

 

You absolutely need to change card's USBCOMP mode (from Linux or Windows), since card can't work in macOS with it's default mode, even if kext is perfectly fine.

 

I would recommend to set USBCOMP mode to 14, since that way card will work in macOS, Windows and Linux and you will probably not have to change it ever again. If you do not care about other OS, you can set it to either 14, 6 or 8 - all of them will work in macOS.

 

It is probably easiest to change USBCOMP mode from Linux with swi_setusbcomp.pl script. Just use a Ubuntu USB stick with persistent storage and install those packages (even I am not sure if modem-manger-gui is actually needed):

sudo apt-get install perl
sudo apt-get install libuuid-tiny-perl
sudo apt-get install libipc-shareable-perl
sudo apt-get install modem-manager-gui

Download script from here and run it like this:

sudo perl swi_setusbcomp.pl --usbcomp=14

 

I changed PID value in my Legacy_Sierra_QMI_10.13.kext in order to make it work for you (in attachment), but it would only work after you change USBCOMP mode.

 

Good luck.

Legacy_Sierra_QMI_10.13.kext.zip

  • Like 3

Share this post


Link to post
Share on other sites

Thank you for your answer. 

 

I have bootable pendrive with the newest UBUNTU, and boot it without installing and looks like this. What I do wrong?

post-4953-0-31620800-1521191721_thumb.jpg

post-4953-0-84762200-1521191725_thumb.jpg

Share this post


Link to post
Share on other sites

I hope that admins would not treat this post as off-topic, since purpose of this post is to help you and probably other people to change USBCOMP mode on their WWAN cards in order to use them under macOS.

 

Looks like you do not have persistent storage enabled on your USB, you do not have universe repository added or both. 

 

If you have Windows machine, it's probably easiest to use LiLi (LinuxLive USB Creator). You can find instructions here.

 

It is possible that persistent is not enabled by default, even if you created USB properly.

 

You might need to check your grub config to see if persistent is enabled:

/boot/grub/grub.cfg
 
Your LIVE menu item probably looks something like this:
menuentry "Ubuntu 16.04 LIVE" {
set gfxpayload=keep
linux /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---
initrd /casper/initrd.lz
}
Just add new menu entry that looks like this:
menuentry "Ubuntu 16.04 LIVE persistent" {
set gfxpayload=keep
linux /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash persistent ---
initrd /casper/initrd.lz
}

In case it still doesn't work after all this, add universe repository and do update:

sudo add-apt-repository universe
sudo apt-get update
  • Like 1

Share this post


Link to post
Share on other sites

@viking1304 - Thanks for the advice.  My E7240 is showing the DW5570 as recognized WWAN after switching to 14 and using your kext.

 

Unfortunately, I do not have a SIM card with that particular size, which I can put inside to test if Internet works fine now.

Share this post


Link to post
Share on other sites

It turned out that DW5570 can't be used in High Sierra, because there's no easy way to turn the card in online status.

 

It stays by default in low power mode, and the windows driver activates it.  Linux guys had the same issue as the one I have in High Sierra, but they made a solution: https://sigquit.wordpress.com/2015/02/09/dell-branded-sierra-wireless-3g4g-modem-not-online/

 

Basically, I could not google successfully and find a way to send qmi command to the modem with FCC authentication, which will turn it on.

 

I have decided to order Ericsson F5521GW which is known to work fine on High Sierra.  I hope that I will never have to use 4G internet, but I must absolutely have this type of alternative link, which costs 5 euro to activate a pre-paid SIM, which will be active for 1 year and has unlimited data transfer at 128Kbps. Yeah, I know it's slow but for some stuff - you don't need speed, just active connectivity :)

Share this post


Link to post
Share on other sites
Hey! 

 

I changed USBCOMP mode on 14 under Live Ubuntu USB Drive with persistent storage (I had to change in script on "/dev/cdc-wdm1" and then changed it succesfully). Now probably I have the same problem like a @pafkata. I have activ sim card inside a laptop, correctly typed APN, but still my modem not getting online. Is there any other way to use this modem getting online under High Sierra ? Or I must will buy other modem e.g. Ericsson F5521GW and this card throw it on the trash?

 

Greetings ;)

 

 

Share this post


Link to post
Share on other sites

Before you give up, can you please check and post info about your card from Hardware / USB and Network / WWAN from System Information, so we can compare few things with info I am getting. Even I have different card (DW5809e) in different Dell laptop (E7450), some basic things should be same. Your card should be shown correctly in all of those places. 

 

My card is under USB 2.0 Bus inside Hardware / USB and info about it looks like this:

Dell Wireless 5809e Gobi™ 4G LTE Mobile Broadband Card:

  Product ID: 0x81b1
  Vendor ID: 0x413c  (Dell Inc.)
  Version: 0.06
  Speed: Up to 480 Mb/sec
  Manufacturer: Sierra Wireless, Incorporated
  Location ID: 0x1d180000 / 6
  Current Available (mA): 500
  Current Required (mA): 500
  Extra Operating Current (mA): 0

Is your card shown under USB 3.0 or USB 2.0 Bus?

 

Inside Network / WWAN I can see this info:

WWAN Information:

  Dell_Wireless_5809e_Gobi____4G_:
  Device Version Number: 6
  idProduct: 0x81b1
  idVendor: 0x413c
  IMEI: 3535XXXXXX20XX2
  IMSI: XX00XX00XX32XX4
  locationID: 0x1d180000 @ 0
  LOCK_STATE: UNLOCKED
  Manufacturer: Sierra Wireless, Incorporated
  Model: EM7305
  Modem Software: SWI9X15C_05.05.58.00 r27038 carmd-fwbuild1 2015/03/04 21:30:23
  Network Name: Unknown
  Serial#: 3X3XXXX53XXX9X2
  WWAN_TYPE: GSM

I am especially curios about your LOCK_STATE and Modem Software.

 

Can you see your WWAN inside Network along with your Ehternet, WiFi and Bluetooth?

 

Have you tried to use Default configuration without any Account Name or Password and empty APN?

 

 

Share this post


Link to post
Share on other sites

My card is under USB 3.0 Bus inside Hardware / USB and info about it looks like this:

 

Dell Wireless 5570 HSPA+ (42Mbps) Mobile Broadband Card:

 

  Product ID: 0x81a3

  Vendor ID: 0x413c  (Dell Inc.)

  Version: 0.06

  Speed: Up to 480 Mb/sec

  Manufacturer: Sierra Wireless, Incorporated

  Location ID: 0x14700000 / 3

  Current Available (mA): 500

  Current Required (mA): 500

  Extra Operating Current (mA): 0

 

 

Inside Network / WWAN I can see this info:

 

WWAN Information:

 

  Dell_Wireless_5570_HSPA___42Mbp:

  Device Version Number: 6

  idProduct: 0x81a3

  idVendor: 0x413c

  IMEI: 355605054636706

  IMSI: 260011702344327

  locationID: 0x14700000 @ 0

  LOCK_STATE: UNLOCKED

  Manufacturer: Sierra Wireless, Incorporated

  Model: MC8805

  Modem Software: SWI9X15C_05.05.67.00 r31378 CARMD-EV-FRMWR1 2016/03/11 14:58:53

  Network Name: Plus GSM

  Serial#: 355605054636706

  WWAN_TYPE: GSM

 

 

Yes, I can see my WWAN along with Ethernet, WiFi and Bluetooth.

 

Yes, I have tried use a default configuration without set Account Name or Password os APN. Always an error is displayed like this:

 

"A connection could not be established to the PPP server. Try reconnecting. If the problem continues, verify your settings and contact your Administrator."

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×