Jump to content

[Solved] Dell Lattitude 7480: OpenCore 0.6.1 / Catalina


Recommended Posts

Hello, and need support :)

In clover i have all work in catalina 10.15.4 фтв clover , but interesting try to use OpenCore.

Now i made config, work all, but touchpad not. (TPD1 , DLL07A0)

cant understand, how to use ACPI patch for it 

Cant understand , how to convert clover parameter TgtBridge to Open Core. 

image.png.426e496a33fe3fa38400dab57d68ff5a.png

Here my EFI (OC)  EFI.zip

Here old work config (Clover) https://osxlatitude.com/applications/core/interface/file/attachment.php?id=24833 

 

 

Link to post
Share on other sites
  • Replies 26
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Catmater, I have the same laptop as you.  I have clover bootloader with Catalina working good on it too.  Was going to try OpenCore when I stumble upon this post.  Post any updates if you can.

Try this, replace Config and SSDT-BRT6.aml   7480_BriteNessFn.zip

You need to fix you Platforminfo You have CustomSMBIOSGuid set to Yes, so you'll need to set UpdateSMBIOSMode to Custom

Posted Images

Good day! Thank you fo helping me, but no one config are working. 

Here is config.plist

config.plist.thumb.png.304ddfa57e4846d7b003e460aecea7f3.png

 

Here is config-2.plist

config-2.plist.thumb.png.c0c7da556fea06286dd69ad65930645e.png

 

And here is full work clover

clover.thumb.png.59ff611d0b22a6cff128735765d5b0a8.png

 

Here is ioreg from clover bootloadeclover.zip

or here is DSDT from cloveSystem DSDT.zip

May be you can do it ACPI ASL patch ? I can't , no luck

Link to post
Share on other sites
  • Moderators

I thought you need help with OpenCore. Sending me system DSDT from Clover doesn't help me to help you.

Send me system DSDT from OpenCore to see if the patch work or need tweaking.

Link to post
Share on other sites
  • Moderators

Ok, looks like Config-2 does set I2C1/TPD1 _crs to XCRS correctly.

GPI0/_STA is already returning (0x0F), but go ahead and enable it and see if it makes a difference. Post new System DSDT

Link to post
Share on other sites
  • Moderators

GPi0 _STA Skip is incorrect, change it from 13 to 14 and try again.

You can disable the 2 kexttopatch by CoolStar. No longer needed for I2C since v2.3

Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...