Jump to content

AR9462: KP trying to use old IO80211Family kext under Big Sur


bisk
 Share

Recommended Posts

Hello all,

 

Been around for a while but new to the OpenCore world.

 

I successfully installed OpenCore 0.7.7 and upgraded from Mojave to Catalina on my Dell XPS2720.

 

This is an old Haswell AIO system. It was a perfect vanilla Mac under Mojave.

Under Catalina it was equally perfect so long as my SMBIOS platform was iMac14,2.

So, I went ahead and upgraded to Big Sur, changing the platform to iMac14,4.

 

It seems very solid so far aside from one little problem.

 

It will Kernel Panic on boot if I try to inject my old Mojave IO80211Family.kext from OC/kexts.

I needed to remove this kext from the config in order to complete the upgrade.

I run with an old Atheros AR9462 WiFi card and so use the Mojave IO80211Family.kext with a

High Sierra AirportAtheros40.kext Plugin and this has worked just fine under 10.14 & 10.15.

 

I  suppose that I could try to move this stuff into LE but would definitely like to avoid that.

 

So, I put this question out there.

 

Is there some config adjustment that I can make to help this kext replacement to happen ?

 

Thanks in advance,

IMG_0335.JPG

Link to comment
Share on other sites

Guys, thanks so much for your responses but I think that you misunderstand my issue.

 

I completely understand the changes needed to keep Atheros WiFi working after High Sierra.

 

I did my own simple mods years ago. Since I make all of the necessary device specific mods in my DSDT, I

just carried the old unmodified IO80211Family/AirportAtheros40 kexts along into Mojave and then Catalina.

No Injector kext necessary. First I put them into /L/E and then later as Clover improved was able to do with

injection instead. My WiFi has been as fast as is to be expected from 802.11ac. No problems at all.

 

Now, I use a Mojave 10.14.6 IO80211Family.kext with and added 10.13.6 High Sierra AirportAtheros40.kext Plugin.

OpenCore injection from OC/Kexts worked just fine under 10.15.7.

 

But now with Big Sur, attempting to inject the Mojave IO80211Family.kext (with faked up version number)

invokes a "Refusing new kext" error accompanied by a kernel panic.

 

Looks like Big Sur doesn't want me replacing a stock kext contained in the prelinked kernel on the fly.

 

And is punishing me for trying !

 

Is this a thing now ?

 

Do I need to go back to dropping this into /L/E again ?

 

Cloning my boot drive before trying ...

 

Link to comment
Share on other sites

No, but seriously, this little card has been working so smoothly for so long and connects so very reliably well at 5GHz.

 

Checked out the link you provided and several other variations on the same theme but all with no luck.

I've tried to delete the snapshot in Big Sur both logged in and in recovery mode but keep getting an -69863 "insufficient privileges" error.

 

I can drop the Atheros-modified IO80211Family.kext into /L/E but it will not load into the prelinked kernel cache to replace the stock Mac version.

 

Since I was unable to affect the sealed boot snapshot, I reverted the system back to Catalina, placed the Atheros-modified IO80211Family.kext

into /L/E, rebuilt the kernel cache and verified that it was working fine. I then updated to Big Sur only to find that Apple removed this kext from /L/E.

 

It looks like even with SIP disabled, kexts with invalid signatures are no longer accepted.

 

kextunloads of the stock Apple IO80211Family.kext fail with an error message and kextloads of my Atheros-modified IO80211Family.kext

quietly fail.

 

It appears that the published methodology of removing and regenerating snapshots no longer works in Big Sur 11.6.x

 

Has anyone been able to delete the boot snapshot under the current version of Big Sur ?

 

Is there any known way to load/replace a stock Apple kext with a hacked one ?

 

Injection definitely causes KP.

 

This is really bumming my trip !

 

Anyone ???

IMG_0338.JPG

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...