Jump to content

Asus Q405U: need fixes for my EFI folder


Santiago93
 Share

Recommended Posts

Hi, I need fix the EFI folder for my Asus laptop

Specifications:

Processor: Intel Core i5-8250u

Graphics: Intel UHD Graphics 620

Ram: 8GB

Wireless card: Intel(R) Dual Band Wireless-AC 8265

Audio: Realtek ALC294

Keyboard: HID Keyboard device

Mouse: HID compilant mouse

 

The things that don't work are:
-Keyboard
-Touchpad
-Wi-Fi and Bluetooth
-Fingerprint sensor
-Sound
 Another thing, I understand that the video memory in my processor should be 1.5Gb but in the image it shows 2Gb, the MacBook model shown is 2017 I think it should be 2018.

Screen Shot 2022-08-16 at 4.10.48 PM.png

Link to comment
Share on other sites

  • Administrators

As expected, VRAM shows 2GB (or 2048MB) because your config includes a patch that does so:

2GB_VRAM_patch.jpg

If you want to revert to default 1536MB, just remove the patch.

 

There will be no support for your fingerprint scanner; that kind of hardware accessory has not been supported in OS X/macOS for about 10 years.

Intel Wireless &Bluetooth: make sure you use the relevant version of itlwm driver; Bluetooth may not work. See the ITLWM site/repo.

Audio: make sure you've tried the various layout-id listed for your ALC294 codec at AppleALC wiki

Keyboard/touchpad: you'll have to identify the exact hardware components you have (eg: ALPS, Elan, etc.), then use the relevant drivers

Link to comment
Share on other sites

@Jake Lo I already tried all the alcid that you suggested but I did not get results with the audio.

 

@Baio77 With this EFI, the touchpad and keyboard work as well as the battery level, on the other hand the audio already shows the sound bar but it does not emit any sound, the bluetooth works partially but the WiFi does work

MacBook Pro.ioreg

 

The brightness keyboard key does not work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...