Jump to content

Trouble installing Mavericks on Optiplex 9020


ktbos
 Share

Recommended Posts

Jake, I've got an Optiplex 9020.  It is an i7-4770 and therefore, should have the same HD4600 you have.  I have followed your guide but I'm stuck booting up the USB installer on the 9020.  It seems to load everything okay and then gets to "BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 No such file or directory" and hangs there while the USB stick's light stops blinking. 

 

I'm pretty confident that the BootCache thing has nothing to do with the problem.  Am I right that the BootCache thing is a nice-to-have and that without it, the boot sequence continues and I just happen to see the activity fail shortly after that? 

 

Guessing it might be related to graphics, I removed the IntelAzulFB from the boot plist file and tried entering it at the chameleon boot prompt.  I tried IntelAzulFB=1 through =15 and all gave the same result.  I've also tried not using IntelAzulFB at all with the same result.  Same with changing GraphicsEnabler=No and not using IntelAzulFB - same result. 

 

I'm using a DisplayPort connection on the computer and hooked in to a monitor that has a DisplayPort input.  I have tried both DisplayPort connections on the back of the 9020 and same result on both. 

 

I tried adding the -gux_defer_usb2 switch at the chameleon boot prompt but that didn't have any effect.  I also tried USBBusFix=Yes which also had no effect. 

 

Booting in safe mode (-x) does not change anything and neither does -f to ignore caches.  Booting to single user mode (-s) will work in that it gets me to a prompt but that won't help get the installation running. 

 

In single user mode, I tried running lspci and got an "illegal instruction 4" error.  So I booted from an Ubuntu Live CD and ran lspci there.  It reports the video as 8086:0412. 

 

I created the installer yesterday using the version of myHack currently available for download.  When I boot, I have "Chameleon svn2266 | myHack 3.3".  And the Extra directory I'm using is downloaded from this post yesterday.  The InstallESD is from a Mavericks installer I downloaded from the AppStore Thursday. 

 

At this point, I'm not sure what to do next.  I don't know if I should pursue graphics issues or not.  Maybe it is a DSDT issue.  BIOS setting.  Maybe something about the Extra directory contents or the boot plist is incompatible with this latest version of myHack.  I'm hoping you have a suggestion on what to check next. 

Link to comment
Share on other sites

  • Administrators

If you're booting a post-10.9.1 version, let me tell you that I encountered a similar issue on my old legacy Precision 670: very slow boot process and sort of hanging at "BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 No such file or directory", though the LED would stay on; things were basically taking for ever to load.
 
I found out that replacing AppleACPIPlatform + IOPCIFamily kexts by those from 10.9.1 actually fixed things. You may want to try that (keep a backup of originl kexts somewhere), the 10.9.1 kexts are available here. The post also links to the original IM post that gives explanation of code changes affecting nVidia graphics cards from 10.9.2.

 

This being said, I'd be surprised if that were your actual problem (the Optiplex 9020 is such a recent system!) as, outside my Precision 670 oldtimer, I've never had any problems with those youngtimers that are my Vostro 200 and Latitude D630.

Link to comment
Share on other sites

Hervé, thanks for the fast reply.  Yes, it is a young system - it's a "new" refurb I just got specifically for use as my new main Mac - it arrived yesterday. 

 

I downloaded those two kexts and put them in the USB installer's E/E directory and also in the S/L/E (both locations because of the comment in your linked post) and then ran myHack's myFix to make sure everything was okay.  Unfortunately, no improvement - same result I got before the kext change.  (If you think I should have put the kexts somewhere different or done something procedurally different, let me know.) 

 

I think the most interesting difference between your result and mine, however, is that your USB drive does keep working, even though it is super slow.  Mine appears to be quite dead. 

Link to comment
Share on other sites

  • Administrators

I found those kexts had to be placed in /S/L/E (would not work in /E/E + myFix quick or full). I then manually set permissions and rebuilt cache:

sudo chmod -R 755 /System/Library/Extensions

sudo chown -R 0:0 /System/Library/Extensions

sudo kextcache -system-prelinked-kernel

 

I'd also suggest you redo your USB installer and boot with -f flag (or UseKernelCache=No) to see if it makes any difference.

 

Which Mavericks version are you installing by the way?

Link to comment
Share on other sites

Hervé, your note about the E/E not working is why I did the S/L/E, although I did not do the chmod/chown thing and I may not have done the -f.  So I just booted in single user mode with the USB installer, and did the chmod and chown and booted with -f.  Same problem. 

 

I also did the kextcache thing but found something peculiar there.  it appears that every kext in S/L/E returned "WARNING - Invalid signature -2147416000 0xFFFFFFFF80010840 for kext ..." and concluded with a "Segmentation fault: 11".  Whoa.  Don't really know what any of that means or what it says about my current situation, if anything. 

 

I've been feeling like if I have gotten past the initial part of the boot up, I must be okay with my installer.  But yeah, maybe now is a good time to see about doing the installer over. 

 

As for Mavericks version, I believe it is 10.9.4 - it's whatever would have come down from the App Store on Thursday. 

Link to comment
Share on other sites

Jake, yes, I confirmed it is 10.9.4  Thanks for the pointer to that post.  I rebuilt the USB installer and substituted that kernel for the one that was in this guide's Extra download.  (Everything else about the new USB installer is per the guide - it does not include the changes I discussed with Hervé above.)  

 

This time I did get further - one line further, to be exact.  Now, shortly after the BootCacheControl line, I see the following, and no I am not making any of it up: 

panic(cpu 0 caller 0xffffff80002526cf): "a freed zone element has been modified: expected 0xdeadbeefdeadbeef but found 0xdeadbeef88098809, bits changed 0x56a436e6, at offset 48 of 64 in zone: malloc.64"@/SourceCache/xnu/xnu-2422.110
Debugger called: <panic>

I'll keep poking at it, but if you have any suggestions, fire away!  Thanks!!

 

I booted again and this time used -f and it went right through to the graphical part of the installer.  Major progress.  Unfortunately the graphics are were completely messed up and I couldn't even tell the installer window was there until "to use English press the return key" came out of the speaker and I jumped out of my chair.  

 

I removed IntelAzulFB=10 from the boot plist and tried again.  I'm looking at the installer screen now.  I know I will need to figure out the right "Azul" later, but for now I can at least proceed with install.  I'll report back again later.  

Link to comment
Share on other sites

Bronxteck, after doing the install, I switched back to the IntelAzulFB=10 and it works fine now.  I haven't bothered checking other Azul numbers to see if any work the same, but as far as graphics go, it appears to be working about as well as it can. 

 

Jake, the install was a success.  Thanks so much for that pointer to the new version of the mach_kernel.  That was definitely the main issue I was having. 

 

I also have the audio problem you reported in your guide, Jake.  I'm going to see if I can improve the situation and I'll report back if I succeed. 

 

But my main problem now is sleep is not working.  The same as described in the guide where it comes back to a black screen.  Interestingly, if you give it enough time, the video flashes once in a while.  I did try adding "-gux_defer_usb2" as you recommend but that didn't have any effect.  I'm wondering if there could be an issue with the new kernel or 10.9.4 with the USB kext?  Or if something else with 10.9.4 is impacting the way the computer sleeps?  I've checked my BIOS and I can choose which sleep states to enable - I have S4 and S5 both on. 

Link to comment
Share on other sites

Just to confirm I have the best "Azul", I went through the other 14 possible numbers and all failed.  The only one that works is the one I started with, number 10, which matches Jake's.  So I'm pretty confident I've got the graphics working correctly and I assume QE/CI is okay because of the translucent menubar and working genie animation.  

 

I've been battling the Sleep/Wake issue and haven't gotten anywhere.  The computer still sleeps just fine (it seems) and it still wakes to a black screen.  I did some log checking and here is a block that shows prior to sleep through eventual hard reboot.  The marker is just prior to selecting sleep on the Apple menu.  8:57:14 starts the sleep process.  The sleep process ends at 8:57:20.  I push the power button to start the Wake at 8:59:36.  (The line with the stamp of 8:57:31 is, I assume, because the clock hadn't yet updated when it writes that entry to the log - not because it is being psychic about how the computer will be woken!) I let the wake try to work with a black screen, periodically flashing, until time stamp 9:02:16 when I gave up and held the power button down to do a hard reboot.  Is there anything in this log that shows where something might be going wrong?  

7/18/14 8:57:08.664 PM Console[155]:  Marker - Jul 18, 2014, 8:57:08 PM
7/18/14 8:57:14.414 PM WindowServer[105]: device_generate_desktop_screenshot: authw 0x0(0), shield 0x7fcd7a65a260(2001)
7/18/14 8:57:14.447 PM WindowServer[105]: device_generate_lock_screen_screenshot: authw 0x0(0), shield 0x7fcd7a65a260(2001)
7/18/14 8:57:15.148 PM WindowServer[105]: _CGXHWCaptureWindowList: No capable active display found.
7/18/14 8:57:17.000 PM kernel[0]: **** [IOBluetoothHCIController][SearchForTransportEventTimeOutHandler] -- Missing Bluetooth Controller Transport! 
7/18/14 8:57:20.717 PM WindowServer[105]: _CGXHWCaptureWindowList: No capable active display found.
7/18/14 8:57:31.000 PM kernel[0]: Wake reason = PWRB
7/18/14 8:59:36.000 PM kernel[0]: Previous Sleep Cause: 5
7/18/14 8:59:36.149 PM configd[18]: setting hostname to "******.local"
7/18/14 8:59:36.151 PM configd[18]: network changed: v4(en0-:192.168.2.102) DNS- Proxy-
7/18/14 8:59:36.153 PM netbiosd[108]: network_reachability_changed : network is not reachable, netbiosd is shutting down
7/18/14 8:59:36.360 PM WindowServer[105]: CGXDisplayDidWakeNotification [53746685542]: posting kCGSDisplayDidWake
7/18/14 8:59:37.561 PM WindowServer[105]: handle_will_sleep_auth_and_shield_windows: NULL shield_window (lock state: 1)
7/18/14 8:59:40.000 PM kernel[0]: AppleIntelE1000e(Info): e1000e NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
7/18/14 8:59:40.446 PM configd[18]: network changed: v4(en0+:192.168.2.102) DNS+ Proxy+ SMB
7/18/14 8:59:40.454 PM configd[18]: setting hostname to "*****.*****.**.*****.****"
7/18/14 8:59:50.446 PM AirPlayUIAgent[265]: 2014-07-18 08:59:50.445920 PM [AirPlayUIAgent] Changed PIN pairing: no
7/18/14 8:59:50.447 PM AirPlayUIAgent[265]: 2014-07-18 08:59:50.446728 PM [AirPlayUIAgent] Changed PIN pairing: no
7/18/14 9:02:16.000 PM bootlog[0]: BOOT_TIME 1405731736 0
Other than the Mac OS version, my set up should be functionally identical to Jake's.  So is 10.9.4 causing the problem?  And if so, what should I do about it?  If not, any suggestions on where to look?  
 
Jake, have you tried updating your setup to 10.9.4?  If not, when you do a wake from sleep, what does your log look like - anything similar to mine?  
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...