Jump to content
PayPal donations: [email protected] ×
Alex Rivera

E7440: some issues with Sierra

Recommended Posts

Hello

I'm using the bootpack posted here on my E7440 i5 (macOS Sierra 10.12.1), it works OK. (I'll update this bootpack with latest changes).

 

With the 10.12.1 update, physical volume buttons are working again.

post-67594-0-15774800-1477750339_thumb.png 

 

Clover version: 3882 (10/28/2016)

post-67594-0-96090000-1477750428_thumb.png

 

Just replace/update your touchpad and keyboard driver (VoodooPS2Controller.kext) with Dr. Hurt's Refined ALPS TouchPad driver Release 5 Final posted here, I must say this one is almost perfect! (Gestures, horizontal and vertical scrolling, trackstick, etc) amazing job Dr. Hurt. No preference pane though (Known issue with this kind of driver and Sierra) unless you update it with one from 10.11.6 or older.

 

Rarely but sometimes it reboots or starts without sound (more often when rebooting) it gets automatically fixed with another reboot or power off & start. (This is probably a rebuild cache issue after an update)

Hangs when trying to play iTunes movies, and certain video formats on the web. (still can't figure what's going on here...)

For those using Fortinet VPN client (which includes antivirus for some weird reason...) I've found that Forticlient (5.4 latest version) is not compatible with macOS Sierra, it was causing some bad issues on my SSD partition, some examples were: an error appeared when booting into macOS (kext not compatible), longer times to load, long time to shutdown (30 seconds or more), I'm sure this caused my partition to die last week, I could not even mount it anymore and i had to format it... (Time Machine saved me), i reinstalled just to see if I had the same results and yes... it even caused an error again...

Edited by Alex Rivera

Share this post


Link to post
Share on other sites

Webcam is usually USB internal. Check if it's reported in your SysProfiler. If it is, your USB ports are working but the camera may not be supported. As for audio volume and mute buttons not working, it's not something specific to your E7440, it affects all Hackintosh. It obviously results from changes Apple made to ACPI handling in Sierra.

Share this post


Link to post
Share on other sites

Known issue. You need to replace trackpad.prefpane with version from 10.11.6

  • Like 1

Share this post


Link to post
Share on other sites

Hello,

did you update from 10.11.6 to 10.12 from apple store ? 

thank

 

Yes, twice in my case... (see edited post above) one was from 10.11.6 and the second time it was from 10.11.

 

If you can't make Sierra installer to work after reboot or you are getting an error try these:

 

  • Revert core storage from your drive, if you have any. (see here)
  • Boot in recovery or with your Installer USB Sierra, El Capitan (probably any with disk utility will do the job) and from Disk Utility resize your OS partition, make it a little bit smaller, I've found on Apple forums that it needs to be at least 128 mb smaller for the temporal new boot Sierra volume installer to work (in my case I resized to be 1GB smaller) and you can reclaim the space after installation is complete.

 

Regards

  • Like 1

Share this post


Link to post
Share on other sites

10.12.1 Public Beta 3 Fixes physical volume controls :P

 

I need to try it more and see if it fixes other annoyances... macOS related of course (like Safari not loading pages sometimes, WiFi dropping, etc).

 

10.12.1 Beta 3 (16B2338c)

10.12.1 Beta 4 (16B2548a)

Edited by Alex Rivera

Share this post


Link to post
Share on other sites

×
×
  • Create New...