Jump to content

[SUCCESS] Acer Aspire V 15 V5-591G-55TU [Mojave] [Dual-Boot Windows]

Recommended Posts


Could anyone help me installing High Sierra on this system?

I succesfully installed Sierra before on this system with help of Jake Lo (thanks!!), I just wondering if could High sierra possible to installed on this system?
Boot stopped at this. I'll attach my Clover folder and a picture from boot.
UEFI enabled, and for skylake I used IntelGraphicsDVMTfixup and IntelGraphicsFixup kexts. My bios is very limited and does not have any option to change dvmt prealloc or anything else.
Everything works fine on Sierra.

Here is my system:


Acer Aspire V15 V5-591G-55TU


(Note: Bootpack works fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)

Mobo: Skylake USOPP_SLS
Bios: Insyde corp latest version
CPU: Intel Core i5-6300HQ 2.30 GHz (Skylake)
GPU: Geforce GTX 950M 2 GB (optimus, disabled), Intel HD 530
Ram: 8 GB DDR4 (4+4 GB)
Wifi: Qualcomm Atheros QCNFA344A, Replaced to BCM94352Z

Ethernet: Realtek 8168B/8111B
Audio: ALC 255 (layout-3 fix)

Card Reader: Realtek

Dual-boot with Windows 10

Any help appreciated!

Successfully installed High Sierra 10.13, 10.13.1, 10.13.3, 10.13.4, 10.13.6

Successfully installed Mojave: 10.14, 10.14.1





  • Wi-Fi and Bluetooth with BCM94352z: (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, install them with Kext Utility or another kext installer) (Original WiFi is Qualcomm Atheros, unsupported but BT works)
  • Hand-off with BCM94352z
  • Full Graphics enabled on HD 530
  • HDMI & VGA Outputs
  • ALC 255 Audio: (Internal Speakers, Internal Microphone, Headphone jack with layout-3 fix
  • Ethernet Realtek 8168B/8111B
  • App Store, Messages, FaceTime, Siri, iCloud (native)
  • Integrated webcam (native)
  • 3.0 USB (native)
  • Touchpad and Keyboard: Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn. (VoodoPS2Controller.kext), for gestures try SmartTouchpad drivers
  • Battery info: Install ACPIBatteryManager.kext with kext utility or other installer.
  • Sleep Mode
  • Please add these 2 patches to ACPI\DSDT\Patches in your config.plist in order to avoid not responding applications after sleep: (added in "v5_591g_55tu_updated_CLOVER.zip")
  • HECI to IMEI
    EC0 to EC
  • Before updating to a new version of Mojave please update kexts to new versions to avoid kernel panics

Not working:

  • Original Wi-Fi: Qualcomm Atheros QCNFA344A unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
  • NVIDIA GTX 950M: Optimus not supported.
  • Card Reader: Unsupported
  • HDMI Audio

For Wi-Fi:

  • You can choose an external USB wifi dongle (I used tp-link Archer T1U (5GHz support), Tp-link have official macOS drivers, you just need to install it
  • (OR)Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kext I wrote above

I'll attach my EFI folder for anyone who want to install High Sierra (acer_aspire_v5_591g_55tu_hs.zip).

*REUPLOADED updated CLOVER folder, attached as "v5_591g_55tu_updated_CLOVER.zip".

For Mojave download "clover_mojave_acer_v5_591g.zip"


I'm using Mojave in Dual-boot with Windows 8.1. To do this in a clean install or with Windows installed first try my little minimal guide:
Dual-boot clean install (on one drive):
1. Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it's no matter what), 1 for Mac),
2. Install Mac, boot with your USB, *mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder, copy the CLOVER folder I attached to the EFI folder, restart,
3. Boot into your Win installer, Format the partition you created for Win, install.
4. Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:

bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi

5. You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
Dual-boot with Windows installed first (on one drive):
If you already have Windows and you don't want to lose all your data there is a hope:
You need bootable Mac Installer and a full system restore image (you can search for it).
(You may see errors if your EFI partition is not 200 MB)
1. Boot into your Windows, resize your partition or create one for Mac.
2. Boot into your Mac installer and in Disk Utility format the partition you created.
3. Restore from image: select your full system restore image.
4. When it's finished restoring you just need to restart, then boot to the system with your usb.
5. Do Step 2. from "*" from clean install dual-boot above. but KEEP "Microsoft" FOLDER IN IT!
6. Do Step 4. from clean install dual-boot above.
7. You're done! You can select your old Windows and your new macOS!
(I only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)


  • Make sure you have partitions in GPT
  • The best version for restore method is Windows 8.1. It's using 200 MB EFI. Windows 10 using 100 MB EFI and will annoy the Mac restore. You can use with Windows 10, just ignore the errors


  • Make sure you have GPT partitions, and GPT installer


  • It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
  • You also could "mount" the EFI from windows, for that open cmd and type:
    • diskpart
    • list vol (Now select the "System" volume,(FAT 32) For example I select 4)
    • sel vol 4
    • list part (Select System type partition, for example 2)
    • sel part 2
    • assign letter=b (This will "mount" your EFI partition, to manage files download totalcmd or explorer++ (run as admin))
    • remove letter=b (This will "unmount" your EFI)


2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working

2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14: AppleIntelSKLGraphicsFramebufferkext_10_14_0.zip


Here is a video from dual-boot with Windows installed first (on one drive):


Here some pictures:










  • Like 4

Share this post

Link to post
Share on other sites

Okay so I tried, but same. Just disappeared "Couldn't alloc class "IntelGraphicsDVMTFixup"" and  "Couldn't alloc class "Lilu""

Still stopping at there:


Share this post

Link to post
Share on other sites

I followed steps, updated clover and my kexts, put apfs.efi to E/C/drivers64UEFI, and added FixHeaders_20000000 to clover.plist, but same happens. I'll attach my current EFI folder.


Share this post

Link to post
Share on other sites

UPDATE: Should I change anything in my DSDT? Because I used my another clover config without DSDT, and it started loading. but it gives me this instead of the installation screen. I think it's can't load my graphics.


Share this post

Link to post
Share on other sites

You have 2 version of HFFPlus* and OsxAptioFix* in driver64UEFI

Keep HFSPlus.efi an OsxAptioFixDrv-64.efi


I don't think the problem is DSDT problem, I think problem lies somewhere else.

Go ahead and upgrade to latest Clover v4233

Share this post

Link to post
Share on other sites

Okay I'll try soon. And one interesting problem with my BCM94352z Wifi card. it's working fine on windows and on mac 10.12.6 too. But when I restarting Mac my wifi is gone. At boot it says: AirPort_Brcm43XX::start failed ‘startGated()’(on windows it's good). I searched a lot of forums, says It's when my card incompatible. But no, my card compatible, I using that right now with Fake_PCIID_Broadcom. Bluetooth and Wifi is working like charm. But when I restarting the system my wifi is gone. When I shut down my comp and waiting about 1 hour, and turned on again, again working everything. why? I thought is something with my system caches, but I don't actually know why. tried NoCaches=Yes, rebuild caches, but nothing. I can't do cmos reset so.. I'm so confused about that. After waiting 1 hour or 2 it's good again.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now