Jump to content
kushwavez

[SUCCESS] Acer Aspire V 15 V5-591G-55TU [Mojave] [Dual-Boot Windows]

Recommended Posts

Hey!

I have a working and stable Mojave running on this Acer notebook.

For installation and post-installation use my bootpack (down in the attachments).

Note: This bootpack can be used for High Sierra too.

For Sierra see this: Acer Aspire V15 V5-591G-55TU Sierra 10.12.6(Outdated)

 

THIS TOPIC WILL NO LONGER UPDATED. PLEASE GO TO THIS LINK FOR UPDATED INSTALL FILES  & GUIDE:

https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-mojave-windows-10/

 

KAzSnVX.png

Acer Aspire V15 V5-591G-55TU

 

(Note: Bootpack works fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)


Mobo: Skylake USOPP_SLS
Bios: Insyde corp latest version
CPU: Intel Core i5-6300HQ 2.30 GHz (Skylake)
GPU: Geforce GTX 950M 2 GB (optimus, disabled), Intel HD 530
Ram: 8 GB DDR4 (4+4 GB)
Wifi: Qualcomm Atheros QCNFA344A, Replaced to BCM94352Z

Ethernet: Realtek 8168B/8111B
Audio: ALC 255

Card Reader: Realtek

HDD: 1 TB

M.2 SSD: Silicon Power M56 240 GB
Dual-boot with Windows 10


Successfully installed High Sierra 10.13, 10.13.1, 10.13.3, 10.13.4, 10.13.6

Successfully installed Mojave: 10.14, 10.14.1, 10.14.2, 10.14.3

Working:

  • Wi-Fi and Bluetooth with BCM94352Z: (Original WiFi is Qualcomm Atheros, unsupported but BT works)
  • Hand-off with BCM94352Z
  • Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
  • HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
  • Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
  • Ethernet Realtek 8168H/8111H: RealtekRTL8111.kext
  • App Store, Messages, FaceTime, Siri, iCloud (native)
  • Integrated webcam (native)
  • 3.0 USB (native)
  • Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), for gestures try SmartTouchpad drivers
  • Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
  • Sleep Mode
  • SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")

Not working:

  • Original Wi-Fi: Qualcomm Atheros QCNFA344A unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
  • NVIDIA GTX 950M: Optimus not supported.
  • Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"

For Wi-Fi:

  • 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
  • 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, install them with Kext Utility or other kext installer). You could buy this card from ebay, aliexpress, or amazon

If you are using a Single RAM and getting panics at boot add these to your config.plist (SMBIOS->after "Version 1.0") Please edit the frequency and size to match your RAM:

<key>Version</key>
		<string>1.0</string>
		<key>Memory</key>
		<dict>
			<key>Channels</key>
			<integer>1</integer>
			<key>SlotCount</key>
			<integer>1</integer>
			<key>Modules</key>
			<array>
				<dict>
					<key>Slot</key>
					<integer>0</integer>
					<key>Size</key>
					<integer>8192</integer>
					<key>Frequency</key>
					<integer>2133</integer>
					<key>Type</key>
					<string>DDR4</string>
				</dict>
			</array>
			</dict>
		</dict>

 

PowerManagement  fix:

set HWPEnable=YES in Clover (Already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

<key>KernelToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				ILniAAAADzA=
				</data>
				<key>MatchOS</key>
				<string>10.14</string>
				<key>Replace</key>
				<data>
				ILniAAAAkJA=
				</data>
			</dict>
		</array> 

 

And now it's ~40°C and 800MHz in idle state, same on Windows! Battery still draining faster on Mac, but I think its because they are different OSs.

cputemp_win.PNG Képernyőfotó 2018-03-06 - 16.41.16.pngKépernyőfotó 2018-03-06 - 16.33.20.png

 

 

Before updating to a new version of Mojave please update kexts to newer versions to avoid kernel panics

For Mojave\High Sierra download "acer_aspire_v591g-55tu_clover.zip" down in attachments with postinstall and bootpack folders.

Please open README in the bootpack

 

I'm using Mojave in Dual-boot with Windows 10. To do this in a clean install or with Windows installed first try my minimal guide:
 
Dual-boot clean install (on one drive), UEFI Only:
1. Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),
2. Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,
3. Boot into your Win installer, Format the partition you created for Win, install.
4. Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:

bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi

5. You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
 
Dual-boot with Windows installed first (on one drive), UEFI Only:
If you already have Windows and you don't want to lose all your data there is a hope:

I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
You need bootable Mac Installer and a full system restore image (link is in my video's description).
(You may see errors if your EFI partition is not 200 MB)
1. Boot into your Windows, resize your partition or create one for Mac.
2. Boot into your Mac installer and in Disk Utility format the partition you created.
3. Restore from image: select your full system restore image.
4. When it's finished restoring you just need to restart, then boot to the system with your usb.
5. When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.
6. Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:

bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi

7. You're done! You can select your old Windows and your new macOS!
(I only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)

 
IF YOU GETTING ERRORS DURING MAC RESTORE:

  • Make sure you have partitions in GPT
  • Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.

 

IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):

  • Make sure you have GPT partitions, and GPT (UEFI) installer

 

IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):

  • It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
  • You also could "mount" the EFI from Windows:
  •  1st method: open cmd in administrator mode and type:
    • diskpart
    • list vol (Now select the "System" volume,(FAT 32) For example I select 4)
    • sel vol 4
    • list part (Select System type partition, for example 2)
    • sel part 2
    • assign letter=b (This will "mount" your EFI partition)
    • Open Explorer++ or TotalCommander in administrator mode to manage EFI
    • remove letter=b (This will "unmount" your EFI)
  • 2nd method: open cmd in administrator mode and type:
    • mountvol b: /s (This will mount your EFI)

    • Open Explorer++ or TotalCommander in administrator mode to manage EFI

    • mountvol b: /d (This will unmount your EFI)

Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!

Notes:

2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack.

2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.

2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).

2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)

2018.12.09: Updated to 10.14.2 -> did without any complication

2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext

2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14: AppleIntelSKLGraphicsFramebufferkext_10_14_0.zip

2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working

 

Here some pictures:
gFiLiXh.png

1AUVSqk.png

BZaJFXp.png

sDPznj8.png

KFoP0TV.png

 

Screenshot-2019-01-21-at-12-01-21.png

 

 

 

 

 

  • Like 4

Share this post


Link to post
Share on other sites

I followed steps, updated clover and my kexts, put apfs.efi to E/C/drivers64UEFI, and added FixHeaders_20000000 to clover.plist, but same happens. I'll attach my current EFI folder.

 

Share this post


Link to post
Share on other sites

UPDATE: Should I change anything in my DSDT? Because I used my another clover config without DSDT, and it started loading. but it gives me this instead of the installation screen. I think it's can't load my graphics.

post-102255-0-87161500-1506807618_thumb.jpg

Share this post


Link to post
Share on other sites

Tried but same. Also tried with my other clover, but also same. booting into that (last picture).  :-( I'll attach that CLOVER folder too. This Clover is without DSDT patches.

 

Share this post


Link to post
Share on other sites

You have 2 version of HFFPlus* and OsxAptioFix* in driver64UEFI

Keep HFSPlus.efi an OsxAptioFixDrv-64.efi

 

I don't think the problem is DSDT problem, I think problem lies somewhere else.

Go ahead and upgrade to latest Clover v4233

Share this post


Link to post
Share on other sites

Okay I'll try soon. And one interesting problem with my BCM94352z Wifi card. it's working fine on windows and on mac 10.12.6 too. But when I restarting Mac my wifi is gone. At boot it says: AirPort_Brcm43XX::start failed ‘startGated()’(on windows it's good). I searched a lot of forums, says It's when my card incompatible. But no, my card compatible, I using that right now with Fake_PCIID_Broadcom. Bluetooth and Wifi is working like charm. But when I restarting the system my wifi is gone. When I shut down my comp and waiting about 1 hour, and turned on again, again working everything. why? I thought is something with my system caches, but I don't actually know why. tried NoCaches=Yes, rebuild caches, but nothing. I can't do cmos reset so.. I'm so confused about that. After waiting 1 hour or 2 it's good again.

post-102255-0-46661000-1506956418_thumb.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...