Jump to content
EMlyDinEsH

ELAN, FocalTech and Synaptics (Smart Touchpad) Driver (Mac OS X)

Recommended Posts

@Andrey1970 Thanks for your fast reply. I did it but it is not working. I am using Clover. Do I have to delete any other kext? My keyboard works but trackpad not. I am using VoodooPS2Controller.kext by @RehabMan

 

I tried with the SmartTouchpad Version v4.7 beta 5

Share this post


Link to post
Share on other sites

04F3 is a USB id for Elan.

 

Also he will probably never release an updated version of the source code so you might want to contribute to voodoo instead.

Share this post


Link to post
Share on other sites

I've found something interesting for settings via PrefPane

 

So, who has an empty prefPane when you installed a fresh copy of modern system 10.12+ and you want to make some settings in it. Like to enable Clicking.

By default PrefPane saves it's settings in plist file located at 

~/Library/Preferences/com.apple.AppleMultitouchTrackpad.plist

and by default sometimes earlier you can enable Clicking via Terminal:

defaults write com.apple.AppleMultitouchTrackpad Clicking -bool true

but something went wrong (AAPL cheers) and a Key 'Clicking' has a wrong value format. It should be bool but has an integer. So we have to fix this issue

integer --> bool

Open this file with your editor.app (PlistEdit for ex) and fix this:

FM5Hdmw.png

to this

el9MK26.png

and then reboot or reenter account. 

Voila! Your prefPane will work properly.

 

EDIT:  Also I tried to revert this value format to the wrong one (integer --> 0) and reentered acc.  PrefPane worked after all. Setting 'Tap to click' was enabled but no clicking was physically. Then I tried two commands:

defaults write com.apple.AppleMultitouchTrackpad Clicking -integer 1

defaults write com.apple.AppleMultitouchTrackpad Clicking -int 1

without success. Then  unchecked 'Tap to click' and prefPane automatically fixed in it's plist integer (0) --> bool (false). Checked it once more to enable Clicking and voila: plist file has bool (true) and everything is working fine.

  • Like 1

Share this post


Link to post
Share on other sites

Hey.
I installed Mojave 10.14.5 on my Skylake laptop.
I tried to add kext ApplePS2SmartTouchPad.kext to the folder /CLOVER/kexts/Other, reboot, but the touchpad is that there is very limited without multigetto. I tried to throw this text in the Kext Utility, but after rebooting the result was the same.
Does anyone know how to make my Synaptics touchpad work on mac OS 10.14.5?

Share this post


Link to post
Share on other sites

I had a problem with all the touchpad kexts (VoodooPS2Controller, ApplePS2SmartTouchpad and VoodooPS2Trackpad) - I just put them in Other (separately, together I didn't use them), rebooted the OS and the trackpad was not recognized in the settings. Then I began to try to install these kexts (for the touchpad) in the desired /L/E, performed in the terminal
Code: sudo kextcache -i /
and rebooted. Tried them using KextUtility to install. Naturally on one since all together they don't work.
I do not know after which iteration it helped, maybe right after zakidyvaniya in /L/E and run the command in the terminal, and maybe later after using KextUtility or manual throwing kext in /S/L/E and run the same command in the terminal. If you do experiment, then I recommend mark kexts color point (RMB on the file and choose a colored dot, XS as it is properly called) so that when everything is working to remove them from /L/E and /S/L/E and use of kexts/Other.
In General, after that, the appleps2smarttouchpad and VoodooPS2Trackpad kexts began to work as intended and the trackpad was recognized by the system and now these kexts work from kexts/Other.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...