Jump to content
EMlyDinEsH

ELAN and FocalTech (Smart Touchpad) driver Issues

Recommended Posts

Hello,

 

thank you for making such a good kext.

 

My issue is that the touchpad can only move cursor, 

no more actions can work on the touchpad WITHOUT pressing L/R buttons.

 

Laptop: Lenovo V470A IFI-H

OS X: Mavericks.

 

Hardware ID: ACPI\VEN_ETD&DEV_0605

 

Information extracted from ETDDeviceInformation.exe: 

http://pastebin.com/b7iZivhC

 

Thank you

 

PM me for beta testing your touchpad.

Share this post


Link to post
Share on other sites

I seem to have similar issue, though I don't have a clue whether my touchpad is v2 or v3 (my laptop is Lenovo G580). I tried out v3.7. and otherwise it worked nicely, but neither right mouse button nor three finger tap worked like they should, just seemed to perform normal click. So I just decided to try out v2.8.3 and the right click works perfectly now.

 

So this fixed my current right click problem, but just decided to drop a line in case it might help EMlyDinEsH to figure out the possible problem with newer versions. You're done really great job with this driver!

will try this again with v3.7, and v3HWLegacyMode set to YES, and I'll report back ;)

-- edit

seems that the problem still persists. Anyway, I'm doing a little test with v3.7 driver and v2.8 driver using KeyRemap4Macbook's EventViewer. Here's the output :

 

 

Screen-Shot-2014-04-25-at-12.12.14-PM.pn

 

Might be a bit of a help ;)

Share this post


Link to post
Share on other sites
Hi everyone,

 

 

I started this thread in order to know the bugs in my driver, so please post your issues here and I'll try to fix them. After fixing the issue, I'll mention it in the my post.

 

CHANGE LOG:

 Version v3.5

Added option for customizing Extended functions F13-F24 with custom shortcuts

Added option to choose custom shortcuts to gestures actions list

Added physical buttons support present in some v4 hardware

Fixed some keyboard, touchpad and controller related probe issues

Fixed horizontal scrolling bug and added option to disable inertia

Fixed slow edge scrolling and inertia effect

Removed SlowSynch scroll option and integrated as default to improve scroll

Added option for choosing pressure for tap and hold drag

Updated EAPD Fix (Read my EAPDFix post for details on update)

Added support for Asus Keyboard backlight

Added option to make shift + caps shortcut as Fn key

Added custom german layout option for keyboard to fix the key mapping

Added support for new firmware from v4 and fixed some bugs related to v4

Added option to map Delete as command + backspace shortcut for deleting files

Fixed many bugs encountered so far

Optimized code a lot (means less code doing same work even better)

 Version v3.3

Added v2 hardware support

Added support for some of the old v3 hardware (found in Gigabyte notebooks, need to enable v3HWLegacyMode in plist)

Added support for the most of the Fn key scan codes in notebooks from Acer, MSI, Dell, Samsung and few others

Reworked on keyboard keys dispatch to improve (check keyboard thread for details)

Added Fast and Rewind support for Media keys Next and Previous if you hold it

Moved ApplePS2Controller and ApplePS2Keboard kexts to plugins folder of ApplePS2ElanTouchpad

Merged AppleACPIPS2Nub to ApplePS2Controller

Improved scrolling and added new feature SlowSynch scroll

Fixed button dragging issue and added new option for choosing single button/emulated three buttons in v4 from plist

Improved staiblity for all the features

Many bugs fixed

Optimized code

Version v3.0.2

Fixed a bug in right click button in v4 hardware

Fixed a bug in App switch swipe gesture which was making right click not working

Changed Fn key mode to 1 and disabled experimental elastic effect

 Version v3.0

Reworked on almost every feature from the scratch to make it better

Added support for new firmwares from v4 hardware 

Added EAPD fix support for realtek codecs

Added more functions for gestures option list

Added new effects to scroll

Improvements to everything

Fixed so many bugs

UPDATE: Version 2.8.3 

Disabled some of the features which are not used to for the most, so if you want enable them from plist after reading details about that feature

Changed Notification centre function from Soft mode to Keyboard shortcut of Apple in Keyboard Preferences

Improved Swiping and dragging

Changed Plist options for enabling/disabling swipes from 4 options to 2(3FingersSwipes and 4FingerSwipes)

Fixed some bugs

Changed FingerLift dragging timeout from 0.5s to 0.1s

 

UPDATE: Version 2.8 released (Sorry for long delay)

Fixed issues related to Keyboard and touchpad Kexts, which are not loading properly due to kernel cache issues

Added new Feature "Taps Feature Toggle" for enabling/disabling some features using Double/Triple Taps (Read Taps Feature toggle section for more details)

Changed 'Three Finger Press gesture' for v3 hardware to Show Desktop

Improved Three and Four Fingers Swipe gestures detection

Fixed Fn keys mode key mapping issues in Keyboard kext

Added option(need to set the value to "disable" for Fn key) to disable Fn key Mapping in Fn keys mode

some bug fixes

UPDATE: Version 2.7.5

Removed CommandKeyPos plist entry, now the driver detects it automatically

Added new Fnkeys mode  without using fn key and mapped keys to Apple Fn keys layout

Reworked Keyboard from the scratch for Normal and Extended Key Sequences, check the keyboard section for updated details

Fixed NumLock key for enabling/disabling num keys properly

Fixed ISO layout issues in the previous version

Fixed double tap to drag for v4 and some dragging issues

Added timeout for finger lift drag release and the timeout can be edited in plist entry "FingLiftDragTimeOut", default value is 1/2 second (500ms)

Added acceleration preference option in plist, for details read Pointer Acceleration tables section

Added support for Asus Fn key driver to enable/disable touchpad with the fn key Fn+F9

Improved Corner tapping detection

Fixed Single tap issue which was not releasing in safari and finder back buttons

Added Control + Pause/Break key to eject Optical drive

Assigned Scroll Lock key for enabling/disabling Inertial scroll

Optimized some features

Fixed many bugs

UPDATE: Version 2.6

Added new feature Fnkeys mode to access standard fn functions using right Context key as fn key

Added few more functions to swipe gesture

Added few enhancements to keyboard (check those in keyboard section)

Added new features Continuous and Inertial Scrolling effects

Reworked Edge swipe and Corner tapping features to better

Reworked Scrolling for both two finger and edge which is very smooth now

Fixed Double tap to drag on Windows

Fixed an issue for driver to work in Lion

Improved code for all the features with optimizations

Smoothed Mouse pointer with some acceleration tables and curves from Mac touchpads( so accelerations apps I said are not needed mostly)

Added a workaround for ALC269 jack sense after sleep(only for those users who have this issue)

Many Bug fixes

 

UPDATE: Version 2.1.3

Fixed a bug with Right Click

Improved code for Three/Four Finger Swipe to v4 hardware

Improved with Touchpad detection after sleep

UPDATE: Version 2.1 Final

 

This update brings every feature of the touchpad for v3 and v4 with improvements to the already released features.

Added the features Swipe, Zoom, Rotation, Tapping and many other, so check my details above

Improved all the features of v4 hardware

Integrated the code of v3 with v4 in a single Kext

Added the feature Edge Swipe to v3 hardware

Improved the code of v3 hardware across all the features

 

 

 

ISSUES: 

 

*  

 

 

Fixed Issues

 

*

 

 

 

 

Hi , thanks for your efforts. Please let us know where we can download it , and instructions for instal, can it be used on Lenovo thinkpad,? LION 10.8.5 or any version?

Thanks

Share this post


Link to post
Share on other sites

Hi , thanks for your efforts. Please let us know where we can download it , and instructions for instal, can it be used on Lenovo thinkpad,? LION 10.8.5 or any version?

Thanks

Your Lenovo x201 has a synaptics touchpad not Elan Touchpad. Use voodoops2controller by Rehabman.

Share this post


Link to post
Share on other sites

Ah ok Thanks Jake! But the voodoo does not do all those things like multi-touch, scroll etc..right? Then what can I do to add those functions. System profiler says: no trackpad on my LM 1085

Share this post


Link to post
Share on other sites

hello...

 

ApplePS2ElanTouchpad.kext S/L/E install...

ApplePS2 Controll.kext, AppleACPIPS2Nub.kext remove

 

reboot

 

but don't works (keyboard works, trackpad don't works).... please help me

 

me system Clevo W650EH Laptop

i7-3632QM,HM76,HD4000

 

Share this post


Link to post
Share on other sites

HW ID ETD0403

 

consol message

 

Apr 30 17:21:56 localhost kernel[0]: ETD :: Initializing ELAN Keyboard...
Apr 30 17:21:56 localhost kernel[0]: ELAN Touchpad v3.7 Final Copyright © EMlyDinEsH (OSXLatitude) 2012-2014.
Apr 30 17:21:56 localhost kernel[0]: ETD :: ELAN touchpad found, Hardware version 3 (Firmware version 0x450f02).

Share this post


Link to post
Share on other sites

Thanks for the v2, now my touchpad has a multitouch function 2-finger tap and 3-finger flick/slide works fine. Although there's 1 problem, how should I enable the two-finger scroll? In System Preferences > Touchpad said it was enabled but It can't.  Salamat Dinesh

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...