Jump to content
quantan

E6410 nVidia - El Capitan

Recommended Posts

Hi,

 

I try to use Clover for making the USB installer but I cannot go through the error Still waiting for root device. Would you please help me on this issue?

 

Thanks so much

Share this post


Link to post
Share on other sites

First of all, thanks for creating a new topic for discussing on El Capitan E6410 :)

 

Make sure you have AHCI set in the BIOS.

I already set AHCI in the BIOS. I spent some hours and know the reason :D. El Capitan somehow doesn't work well with USB 2.0. I had to use patched DSDT (change ECHI to EHC1) then I can install it successfully. I will continue to fix some missing kext issue left.

 

Anyone else here installing El Capitan? :D

Share this post


Link to post
Share on other sites

The DSDT will be the same as for previous OS X versions. For EC, you just have to check the USB devices and rename them if required to EHC1, EHC2.

Share this post


Link to post
Share on other sites

Disable hibernation and remove sleepimage file, as usual.

Thanks. I've tried with these but the sleep doesn't really work. The fan still spins while sleeping but I'm comfortable with it.

 

It would be nice if the patch DSDT was supplied, I'm encountering the same problem with Yosemite and the same laptop

USB patch: As Hervé said above, I just search and replace EHCI to EHC1.

Battery patch: Some guys here and I had issue with battery. Then I ask RehabMan about this issue and he told me that the problem is the second battery object in DSDT, but is not present. Disable it by:

into method label _STA parent_label BAT1 replace_content begin Return(0) end;

Other patches (optional): Use Dell E6410 in http://olarila.com/forum/packs.php. Be careful to remove patches related to EHCI because they don't work any more. Use the USB patch above. Actually I'm not sure what these patches do but there's not harm in trying.

Share this post


Link to post
Share on other sites

It seems no one else installs El Capitan on E6410 here :D. Everything now works for me except Sleep  :mrgreen:

Hi Quantan. Can you give some indications how you proceeded to install El Capitan on your E6410. I would like to do the same if it is not too complicated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...